Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

7912 default logo problem

We're trying to change the default bmp logo on the 7912 phone.

We've followed the instructions in the documentation using bmp2logo.exe and put all the converted files in the TFTP folder on the Cisco Call Manager server.

Problem is, it's not changing the logo.

We've followed the directions at: http://www.cisco.com/en/US/products/hw/phones/ps379/products_administration_guide_chapter09186a00801b1b73.html

and the directions in the .txt file from the bmp2logo.zip files.

After a reboot of the phone, the new logo isn't showing, only the Cisco Logo.

We're wondering if there's a config change in CCM that we may be missing. The documentation doesn't refer to anything, but simply rebooting the phone is not pulling the new logo.

If anyone has any help, we'll appreciate it!!

  • Voice over IP
7 REPLIES
Anonymous
N/A

Re: 7912 default logo problem

Once you have created the gkdefault.cfg file, it must go in the locale directory. If they do not have a locale installed, the phone will look for it in c:\Program Files\Cisco\TFTPPath\United States\ .The logo files goes in c:\Program Files\Cisco\TFTPPath\ . Also the file Must be 88 x 27, Black and white. Anything different wil not work. Did you go through the following document?

http://www.cisco.com/en/US/partner/products/hw/phones/ps379/products_administration_guide_chapter09186a008011e054.html#62942

New Member

Re: 7912 default logo problem

The document on CCO is incorrect. I have rewritten the correct proceedure and am waiting for it to post. Meanwhile, this is the correct proceedure. Pay attention to step 7:

1. Download the SCCP Software Package Zip file.

http://www.cisco.com/cgi-bin/tablebuild.pl/ip_phone_client

2. Create the bitmap of the image to load to the phone

-The bitmap must be 88x27 pixels in size

-The bitmap must be black and white

-The bitmap must be saved as a monochrome image type

3. Convert the bitmap into a logo image using bmp2logo.exe

-bmp2logo x input_file output.logo

where x is an arbitrary number

-example: bmp2logo 10 cisco.bmp cisco.logo

4. Create a text file that will be used to build the ld or gk cfg file

-The file can be any name

-Must contain the upgradelogo key

-The SampleLogo.txt can be used as a template.

NOTE: the image number defined in step 3 must be used in this text file

5. Create the cfg file, use the cfgfmt.exe

-cfgfmt SampleLogo.txt lddefault.cfg

NOTE: if the same image is desired on all 7905's and 7912, use the lddefault.cfg and gkdefault.cfg files.

6. Move the .logo file into the TFTPPATH directory

7. Move the lddefault.cfg or gkdefault.cfg) (attached) into the COUNTRY specific folder.

-The ld or gk cfg files will need to be in at least \TFTPPATH\United_States

NOTE: The cfg file will need to be copied to each COUNTRY directory supported by the CM.

8. Reboot the 7905 or 7912 for the new image to display

Dan

AVVID TAC

New Member

Re: 7912 default logo problem

I have another problem with 7912 custom logos. I successfully changed the cisco logo to a test bitmap (just to see if I could do it) and then I wanted to replace that test bitmap with my company logo. It didn't work... The phone just shows the test bitmap. I tried removing all profile and logo files from the tftp server and it still didn't work. So I changed the original Cisco logo with a custom one. And now I want to replace that custom logo with another custom logo. How do I do that?

I have the same kind of problem with the 7970 phone. I added a custom background image to it and then wanted to add more custom background images. No luck. Whatever I do, I still see the first custom background and the default backgrund but nothing else..

Thanks in advance for any help!

Lauri

Silver

Re: 7912 default logo problem

One of the parameters you provide during the process is an integer value, an index per se, I think they give 10 or 11 or something like that as an example.

This is an incremental value, and the phone looks for a higher number in the new image file before it loads it.

This had me going for a while.

New Member

Re: 7912 default logo problem

Lauri I have also tried to change the default logo but ended up with a black screen. Can you possibly send me the bitmap you successfully changed.

christopher.mcinally@esat.com

I am also trying to change the logo back but I have not yet succeeded. I will keep you posted.

Silver

Re: 7912 default logo problem

Try to change the original bmp to all black, that's what I had to do in order to get the phone to be all blank. Crazy, I know - but it worked.

Also, you have to increment the index value when trying to change the logo. The sample is set to 10 I think, just keep adding one to it.

New Member

Re: 7912 default logo problem

Hello Dan,

This procedure do not work for me, I'm using CM 4.2.3

Can you give me some advice please?

470
Views
5
Helpful
7
Replies
This widget could not be displayed.