Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Callback message not appearing on Siemens Hicom connected phones

We have connected two Siemens Hicom 350 PABXs using E1 controllers on two routers. The routers are connected via an IP (over ATM) link. Siemens digital phones are connected to each PABX. Calls are going across smoothly, however, when callback feature is initiated from a phone on one PABX to a phone on the other PABX, the initiating phone shows the message "Not possible" although the callback is actually set and does call back. The message should show as "Will call back".

8 REPLIES

Re: Callback message not appearing on Siemens Hicom connected ph

What kind of protocol are you using on the E1 between the Hicom and Cisco ?

New Member

Re: Callback message not appearing on Siemens Hicom connected ph

We are running QSIG between the router and the Hicom PABX.

Re: Callback message not appearing on Siemens Hicom connected ph

Could you provide a Q.931 debug output from both the sides?

New Member

Re: Callback message not appearing on Siemens Hicom connected ph

Debug from both Routers are attached.

Re: Callback message not appearing on Siemens Hicom connected ph

Ok, the situation now is pretty bright. I think you should have noticed the error in the second debug output. The Cisco has hard time in parsing/decoding the ISDN Q.931 packet and therefore shot an error message.

Could you provide me with the IOS versions of the gateways, or even better - the H323 versions they are running.

For the time being, I would recommend to you to issue the global command "isdn gateway-max-internetworking". With this command the Cisco gateways will try to do their best to pass transparently the unknown ISDN packets without trying to decode them. Let me know if that works.

After checking the H323 version, compiled into your gateway's IOSes, you should see if they are running H323 version 2,3, or 4. AFAIK, 12.3 IOSes are running H323 version 4, which has the ability to "tunnel" QSIG messages over the IP.

New Member

Re: Callback message not appearing on Siemens Hicom connected ph

Hi, its me salsayed using another account.

I tried the 'isdn gateway-max-internetworking' command but that didnt help actually the callback stopped working at all when i applied that command.

Anyway the H.323 ITU-T version running is 4.0, & Stack version is 0.1. The IOS version that i am running is 12.3(10a).

Re: Callback message not appearing on Siemens Hicom connected ph

Well, that's really odd. The max-internetworking command tries to be as much transparent for the Q.931 messages, as possible.

Looks like if you connect directly the Hicom's, the feature won't work... ...

Are you sure both the Hicom are running the same version and the same QSIG protocol ?

New Member

Re: Callback message not appearing on Siemens Hicom connected ph

I managed to get the problem fixed, it seems there was a bug with the IOS i had. Upgraded to another one 12.3 (13b).. Working fine with this one now.

Thanks for your support

193
Views
0
Helpful
8
Replies
CreatePlease to create content