Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Choppy voice issue

Hello,

I have here the following VoIP network structure:

Analog Phone 1<->PABX<->Gateway AS5350<->Router C6509<->Frame Relay Cloud<->Router 1751<->PABX<->Analog Phone 2

The two routers have both data and voice traffic. Supposing that Frame Relay bandwidth is 256 kbps, and the link is congested with data packets. When a phone call is made, we listen the voice with great quality on Phone 1, but on Phone 2 the quality is terrible (choppy voice).

I think something is wrong with the QoS on the 6509's outside packets. But I still wasn't able to find the problem in the config:

*********************** 6509 ***************************

interface Serial3/0/0.7 point-to-point

bandwidth 256

frame-relay interface-dlci 100

class VoIP256-256

map-class frame-relay VoIP256-256

no frame-relay adaptive-shaping

frame-relay cir 256000

frame-relay bc 2560

frame-relay be 0

frame-relay mincir 256000

service-policy output Shape2channels

frame-relay fragment 320

policy-map Shape2channels

shape average 256000 2048 0

service-policy VoIP2channels

policy-map VoIP2channels

class voice-signaling

bandwidth 8

class voice-traffic

priority 45

class class-default

fair-queue

class-map match-all voice-signaling

match access-group 103

class-map match-all voice-traffic

match access-group 102

access-list 102 permit udp any any range 16384 32767

access-list 103 permit tcp any eq 1720 any

access-list 103 permit tcp any any eq 1720

********************************************************

It seems the 6509 isn't giving priority to the voice packets. Or maybe can be a problem with traffic-shaping?

I've already made several changes in the config, specially in Shape2channels/VoIP2channels policies.

And when I execute the "show policy-map interface s3/0/0.7" command, it returns nothing to me (in fact, it returns a blank line...).

Someone have any idea of what is happening?

8 REPLIES
New Member

Re: Choppy voice issue

What is the QoS config of the 1750?

For the 6509, I suggest that you use the very basic QoS to start out to troubleshoot the problem, instead of using nested policy. Are you also running Video Conferencing over IP (1720)?

class-map match-all VoIP

match ip dscp ef

match ip dscp cs5

class-map match-all Video

match ip dscp af41 (if your video equipment is set for ip precedence 4, then use "match ip precedence 4 instead of dscp af41)

class-map match-any VoIP-Signaling

match ip dscp af31

match ip dscp cs3

class-map match-any Network-Control

match ip dscp cs6

policy-map VoIP-256

class VoIP

priority percent 45

class Video

priority percent xx

class VoIP-Signaling

bandwidth percent 3

class Network-Control

bandwidth percent 3

class class-default

fair-queue

random-detect dscp-based

Apply "service-policy output VoIP-256" to your interface.

Use the same QoS in the 1751 and check the QoS output for any drop packet in VoIP class.

HTH,

hieu

New Member

Re: Choppy voice issue

Hieu, thanks for the help!

No, i'm not running video conference right now.

The config of the 1751 is more simple:

interface Serial0/0

bandwidth 256

frame-relay traffic-shaping

frame-relay interface-dlci 101

class VoIP256-256

map-class frame-relay VoIP256-256

frame-relay cir 256000

frame-relay bc 2560

frame-relay be 0

frame-relay mincir 256000

service-policy output VoIP2canais

frame-relay fragment 160

policy-map VoIP2canais

class voice-signaling

bandwidth 8

class voice-traffic

priority 45

class class-default

fair-queue

I've made the changes for this PVC in the 6509, and I think it work on the first time.

But I've made the same test in another PVC that has the same issue and it doesn't work. The strange thing is that when I use the "show policy-map interface" on the interface of this PVC, it returns just a blank line on the screen, and before the changes the command was working alright. So I've returned for the original config, but the command insists in show just the blank line, it doesn't work anymore...

New Member

Re: Choppy voice issue

Take a look at this document regarding setting up QoS for FR.

http://www.cisco.com/en/US/tech/tk652/tk698/technologies_configuration_example09186a0080094af9.shtml

When things don't seem to work right, I would recommend that you use basic config first, verifying that it's working before adding anything else like nested policy or cRTP (compressed RTP).

HTH,

hieu

New Member

Re: Choppy voice issue

Hi,

Well, I tried to implement the basic IP RTP Priority, but it didn't work. But since I never used this QoS method, I don't know if the config is right:

interface Serial3/0/0.7 point-to-point

bandwidth 256

frame-relay interface-dlci 100

class VoIP256-256

map-class frame-relay VoIP256-256

no frame-relay adaptive-shaping

frame-relay cir 256000

frame-relay bc 2560

frame-relay be 0

frame-relay mincir 256000

frame-relay ip rtp priority 16384 16383 45

frame-relay fair-queue

frame-relay fragment 320

This is the same as the example on Cisco's document.

Then I made a big data transfer and a phone call at the same time, but the voice is still breaking, a lot.

I have here a star topology, and all the edges have the same problem.

In one PVC the LLQ method based on dscp have worked well. But after I changed the policies on the other PVCs, when I use the "show policy-map interface" it shows nothing. It seems that the policy doesn't attach to the interface. The only PVC that this command works is the PVC that LLQ QoS is working.

Do you know why this is happening?

New Member

Re: Choppy voice issue

Your config looks right per the Cisco doc., butI am not exactly sure what's happening in your enviroment. Since you know that LLQ works fine, then you might want to try it again.

Sample config:

OK..since you know that LLQ works fine, then try to implement LLQ again

class-map VoIP256

match ip dscp ef

class-map Call-Signaling

match ip dscp af31

match ip dscp cs3

policy-map VoIP

class VoIP256

priority percent 50

class Call-Signaling

bandwidth percent 3

class class-default

fair-queue

random-detect dscp-based

map-class frame-relay VoIP256

service-policy output VoIP

Notice that the "priority percent" command, not just "priority" as shown in your previous config. Since "priority 45" only allocates "45 Kbps" for voice, I don't think it's sufficent bw for VoIP. With "priority percent 50", you're allocating 128 Kbps for VoIP.

Let me know if this works out any better..

HTH,

hieu

Blue

Re: Choppy voice issue

The show policy-map interface command dosen't work when using frame relay priority queuing in the map class. It only works with policy maps.

Please rate helpful posts.

Dave

New Member

Re: Choppy voice issue

I notices that there isnt any prioritztion since your packets arent map with DSCP. your policy map and frame relay traffic shaping seems ok but where are you marking your packets

class-map match-all L3-to-L2_VoIP-Cntrl

match ip dscp af31

class-map match-all L3-to-L2_VoIP-RTP

match ip dscp ef

class-map match-all SIP

match protocol sip

class-map match-all ef-bit

--More-- match cos 5

match ip dscp ef

class-map match-all RTP

match protocol rtp

!

!

policy-map EthOut

class RTP

policy-map output-L3-to-L2

class L3-to-L2_VoIP-RTP

set cos 5

class L3-to-L2_VoIP-Cntrl

set cos 3

policy-map voice

class ef-bit

priority percent 15

!

you have to mark your packets so your can prioritzed you voice packet with LLQ or CBWFQ

New Member

Re: Choppy voice issue

Well, after a month of research I finally discovered the problem:

The 6509 does not do QoS on FlexWAN subinterfaces...

That's why QoS does'nt work. In fact it never worked.

So I think that we will have to put another router in front of 6509 to do this QoS. For now, is the only solution that I see on the horizon. And since we are changing the network topology, this is already in our plan.

But I want to thank everyone for your help. Now that I found this forum, certainly I'll come back here if I have another problem.

Regards.

260
Views
0
Helpful
8
Replies