Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 3825 to OpenSIPs - Cisco Using wrong Port

I have a 3825 running IOS c3825-ipvoice-mz.123-14.T6.bin that I am trying to send calls from to an OpenSIPs server.  I can get inbound calls (from OpenSIPs to Cisco) to work but not outbound.

The OpenSIPS gives thes following debug back:

U 10.11.10.222:54649 -> 222.50.220.51:5060
INVITE sip:4032221111@222.50.220.51:5060 SIP/2.0.
Via: SIP/2.0/UDP 10.11.10.222:5060;branch=z9hG4bKC438.
Remote-Party-ID: <sip:4031112222@10.11.10.222>;party=calling;screen=no;privacy=off.
From: <sip:4031112222@10.11.10.222>;tag=1124C74-13C6.
To: <sip:4032221111@222.50.220.51>.

 

The problem is that the Cisco used port 54649 (in this example - normally random) in the opening line.  Because of this the OpenSIPs is looking for authentication as it expects only port 5060, not a random one, and the call fails.

 

Is there a way to fix the port so that the Cisco used only 5060?

 

I have tried the following on the Cisco:

dial-peer voice 300 voip
 destination-pattern .T
 progress_ind setup enable 3
 voice-class codec 1
 session protocol sipv2
 session target ipv4:222.50.220.51:5060
 session transport udp
 fax rate 9600
 ip qos dscp cs5 media
 no vad
!
!
sip-ua
 sip-server ipv4:222.50.220.51:5060

 

Cheers!
Dave

 

  • Voice over IP
1 ACCEPTED SOLUTION

Accepted Solutions

Ok.Just putting my view on

Ok.

Just putting my view on this debug.

 

Its not an issue with SIP port , actually every thing is correct. I don't know why SIP server is generating this  "U 10.11.10.222:62963 -> 222.50.220.51:5060" as this is not part of any SIP messaging header as per RFC.

If its related to the port , SIP would had replied with Not Acceptable or Unsupported response but SIP server is asking for authentication , that means there is challenge setup for inbound direction call towards SIP server. What you can check for any authentication setup at SIP server side.

Once you get that authentication detail , configure that under sip-ua in 3825 like this..

sip-ua

authentication username xxxxxxxxxx password xxxxxxxxx realm 10.11.10.222

 

This will solve the call set up issue.

 

Thanks

Manish

Rate helpful posts

3 REPLIES

Can you pull "debug ccsip

Can you pull "debug ccsip message" from 3825 and send it across.

If you see the VIA header, its containing the correct port

Via: SIP/2.0/UDP 10.11.10.222:5060;branch=z9hG4bKC438.

I am afraid that some thing before the sip server is manipulating the port and which can be confirmed from the above debug.

 

New Member

Here is my output for the

Here is my output for the debug:

SIP Call messages tracing is enabled
testy#
Jun  9 15:00:09.332: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:5035551212@222.50.220.51:5060 SIP/2.0
Via: SIP/2.0/UDP 10.11.10.222:5060;branch=z9hG4bK1216E
Remote-Party-ID: <sip:5034441313@10.11.10.222>;party=calling;screen=no;privacy=off
From: <sip:5034441313@10.11.10.222>;tag=148054-1D11
To: <sip:5035551212@222.50.220.51>
Date: Mon, 09 Jun 2014 15:00:09 GMT
Call-ID: 958B759A-EF1D11E3-8012ABD9-91A32DA0@10.11.10.222
Supported: 100rel,timer,resource-priority,replaces
Min-SE:  1800
Cisco-Guid: 2453550116-4011659747-2148379609-2443390368
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Max-Forwards: 70
Timestamp: 1402326009
Contact: <sip:5034441313@10.11.10.222:5060>
Expires: 180
Allow-Events: telephone-event
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 226

v=0
o=CiscoSystemsSIP-GW-UserAgent 3732 6639 IN IP4 10.11.10.222
s=SIP Call
c=IN IP4 10.11.10.222
t=0 0
m=audio 16528 RTP/AVP 18 0
c=IN IP4 10.11.10.222
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:0 PCMU/8000

Jun  9 15:00:09.344: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 407 Proxy Authentication Required
Via: SIP/2.0/UDP 10.11.10.222:5060;received=10.11.10.222;rport=62963;branch=z9hG4bK1216E
From: <sip:5034441313@10.11.10.222>;tag=148054-1D11
To: <sip:5035551212@222.50.220.51>;tag=f0d513a54c82f8d71f4f2bc54d21954d.6106
Call-ID: 958B759A-EF1D11E3-8012ABD9-91A32DA0@10.11.10.222
CSeq: 101 INVITE
Proxy-Authenticate: Digest realm="10.11.10.222", nonce="5395cc17000026d4b7a89bbe13ee1321cbbb9020e7401723", qop="auth"
Server: INFOSAT voip service
Content-Length: 0

 

I see what you're saying.  The correct port show up on the Cisco debug, and there are no other devices in between these two (other than switches).

The OpenSIPs debug still shows the same thing:

U 10.11.10.222:62963 -> 222.50.220.51:5060
INVITE sip:5035551212@222.50.220.51:5060 SIP/2.0.
Via: SIP/2.0/UDP 10.11.10.222:5060;branch=z9hG4bK2DF0.
Remote-Party-ID: <sip:5034441313@10.11.10.222>;party=calling;screen=no;privacy=off.
From: <sip:5034441313@10.11.10.222>;tag=15F038-61A.

 

It turns out that for other reasons I cannot connect the calls derectly between these two boxs so I don't need to solve this one.  I do appreciate your help though.

 

Cheers!
Dave

 

Ok.Just putting my view on

Ok.

Just putting my view on this debug.

 

Its not an issue with SIP port , actually every thing is correct. I don't know why SIP server is generating this  "U 10.11.10.222:62963 -> 222.50.220.51:5060" as this is not part of any SIP messaging header as per RFC.

If its related to the port , SIP would had replied with Not Acceptable or Unsupported response but SIP server is asking for authentication , that means there is challenge setup for inbound direction call towards SIP server. What you can check for any authentication setup at SIP server side.

Once you get that authentication detail , configure that under sip-ua in 3825 like this..

sip-ua

authentication username xxxxxxxxxx password xxxxxxxxx realm 10.11.10.222

 

This will solve the call set up issue.

 

Thanks

Manish

Rate helpful posts

215
Views
0
Helpful
3
Replies
This widget could not be displayed.