Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CME 8.x - 6921 Phones not downloading loads.. with a twist.

I'm using CME 8.x on a 3800 ISR, and a couple of 6921 phones.  Two of them have ~8.5.3 code, the others have 9.x code (phone loads).  If I'm understanding things correctly, the phone should be downloading the published phone load via TFTP from CME if what it has already installed doesn't match (either an upgrade or downgrade).

So here's what I'm seeing.

The scenario:

The phone load files exist in a folder on the flash. (/phone).

The TFTP server is configured with the appropriate information on the loads (and aliasing the path)

tftp-server flash:/phone/BOOT69xx.0-0-0-14.zz alias BOOT69xx.0-0-0-14.zz
tftp-server flash:/phone/DSP69xx.0-0-0-3.zz alias DSP69xx.0-0-0-3.zz
tftp-server flash:/phone/SCCP69xx.8-5-3-0.zz alias SCCP69xx.8-5-3-0.zz

TFTP is working fine, I've tested it with a TFTP client. 

Telephony services is configured with the name of the load load 6921 SCCP69xx.8-5-3-0

telephony-service

  load 6921 SCCP69xx.8-5-3-0


The ephones are configured to use a common ephone template, and are configured as the proper model.

The problem:

The phone will power on, request the CNF files, request the SCCP*.loads file, and then just when I think it'll download the actual load itself (.zz file), the phone registers, and that's it.  Nothing I do seems to force the phone to kick into upgrade mode. It just jumps straight into SCCP registration.

What gives? I don't see anything that I'm doing wrong here.   I've tried deleting and recrating the CNF files, no dice. I've tried resetting the phone to factory defaults, no dice .Watching wireshark, it's asking for and receiving the SCCP69xx.8-5-3-0.loads file (which has the correct .zz files listed in it - this is all stock CME stuff) but those .zz files are never requested or transferred via TFTP. 

Would love some thoughts on this.

1 REPLY
Cisco Employee

Re: CME 8.x - 6921 Phones not downloading loads.. with a twist.

What firmware are you upgrading from that going to 8.5.3 is failing on?  Certain versions of firmware need a step upgrade to go to 8.5.3.  Try upgrading the devices to 8.5.2 first, and then go to 8.5.3.

What does 'debug tftp event' show?

2028
Views
0
Helpful
1
Replies
CreatePlease to create content