Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuring QoS over WAN Link

Hi,

I'm fairly new to VoIP and QoS and would like to have a better understanding of my current configuration below, in particular to the policy-map configuration.  By configuring with a priority 240, does this mean that on my T1 line, it is segregating 240 Kbps for voice traffic only when calls are being made or does it segregate 240 Kbps for voice traffic regardless?

Secondly, how can I configure the policy-map to give voice traffic the highest priority over data without segregation?  Many thanks in advance for any help anyone can give.

!

access-list 102 permit udp 192.168.100.0 0.0.0.255 any range 4000 44000
access-list 102 permit ip 192.168.100.0 0.0.0.255 any dscp ef
!
!
class-map match-all voip
match access-group 102
!
!
policy-map Voice
class voip
  priority 240
!
!
interface FastEthernet0/0
description Data
ip address 192.168.50.1 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet0/1
description Voice
ip address 192.168.100.1 255.255.255.0
duplex auto
speed auto
!
!
interface Serial0/0
description T-1 to Remote-Site
ip address 192.168.200.1 255.255.255.252
service-policy output Voice

!

Everyone's tags (5)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Silver

Configuring QoS over WAN Link

Quality of Service (QoS) is applied when congestion is detected. This is usually detected by that the TX-ring is full, meaning no further packets can be queued to be transmitted. Congestion can also be artifically applied by applying a shaper which forces queuing to happen. Normally the queueing applied is First In First Out (FIFO) which is not good especially when you have voice traffic.

In your case you have 240 kbps of priority meaning that voice traffic will go into the Low Latency Queue (LLQ) when there is congestion. However when there is no congestion packets will be transmitted in the order they arrive. Generally this should not be a problem except on low speed links where voice packets can get stuck behind big data packets which take long to serialize.

If there is congestion but no voice calls then the other queues should be able to use that bandwidth as well.

Daniel Dib
CCIE #37149

Daniel Dib CCIE #37149 Please rate helpful posts.
Silver

Configuring QoS over WAN Link

Your voice packets will be prioritized. The case I'm referring to is if you have a slow link but no congestion, then it can take a long time to serialize a data packet. So say that you only have 64 kbps connection. Then to serialize a 1500 byte packet it would take 187.5 ms to serialize the packet. In that case you could use something called Link Fragmentation and Interleaving meaning you would split up the data packets into several pieces and put voice in between.

In your case you have 1544 kpbs which means it takes about 8ms to serialize it. It should not be an issue in this case unless you have a very long queue.

Daniel Dib
CCIE #37149

Daniel Dib CCIE #37149 Please rate helpful posts.
4 REPLIES
Silver

Configuring QoS over WAN Link

Quality of Service (QoS) is applied when congestion is detected. This is usually detected by that the TX-ring is full, meaning no further packets can be queued to be transmitted. Congestion can also be artifically applied by applying a shaper which forces queuing to happen. Normally the queueing applied is First In First Out (FIFO) which is not good especially when you have voice traffic.

In your case you have 240 kbps of priority meaning that voice traffic will go into the Low Latency Queue (LLQ) when there is congestion. However when there is no congestion packets will be transmitted in the order they arrive. Generally this should not be a problem except on low speed links where voice packets can get stuck behind big data packets which take long to serialize.

If there is congestion but no voice calls then the other queues should be able to use that bandwidth as well.

Daniel Dib
CCIE #37149

Daniel Dib CCIE #37149 Please rate helpful posts.
New Member

Configuring QoS over WAN Link

Thanks Daniel your explanation helps a lot.  You mentioned the current configuration works fine, but on a slow link it may still pose issues as voice traffic may get stuck behind big data packets.  I guess my next question is how should I configure the priority so that voice traffic will always take priority over data during congestions on T1 WAN link? 

Many thanks again.

Silver

Configuring QoS over WAN Link

Your voice packets will be prioritized. The case I'm referring to is if you have a slow link but no congestion, then it can take a long time to serialize a data packet. So say that you only have 64 kbps connection. Then to serialize a 1500 byte packet it would take 187.5 ms to serialize the packet. In that case you could use something called Link Fragmentation and Interleaving meaning you would split up the data packets into several pieces and put voice in between.

In your case you have 1544 kpbs which means it takes about 8ms to serialize it. It should not be an issue in this case unless you have a very long queue.

Daniel Dib
CCIE #37149

Daniel Dib CCIE #37149 Please rate helpful posts.
New Member

Re:Configuring QoS over WAN Link

Daniel,

Thanks again for clarifying. This is very helpful.


Sent from Cisco Technical Support Android App

1355
Views
0
Helpful
4
Replies
CreatePlease login to create content