Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Does anyone configure cisco router with MGCP to link Call agent Clarent ?

hi,

We require to configure As5300 with MGCP to link Clarent call agent. Does anyone have cisco router configuration ?

thanks.

best regards.

fred.

3 REPLIES
Cisco Employee

Re: Does anyone configure cisco router with MGCP to link Call ag

Below is the sample configuration for the 5300 to Call-Agent. This is also dependant on which package is configured on the call-agent so we can configure it accordingly. Hope this helps.

version 12.3

no service pad

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname AS5300-5

!

boot system tftp c5300-is-mz.123-2.T1 171.68.191.135

logging buffered 100000 debugging

enable password xxxx

!

backhaul-session-manager

set bh5300-vsc1 client nft

group bhgrp1 set bh5300-vsc1

session group bhgrp1 172.16.20.35 7007 172.16.20.28 7007 0

isdn switch-type primary-ni

isdn voice-call-failure 0

no scripting tcl init

no scripting tcl encdir

!

!

voice call carrier capacity active

!

voice class codec 1

codec preference 1 g723r63

codec preference 2 g711ulaw

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

dial-control-mib retain-timer 240

dial-control-mib max-size 600

!

!

controller T1 0

framing esf

clock source line primary

linecode b8zs

pri-group timeslots 1-24 service mgcp

!

controller T1 1

framing esf

clock source line secondary 1

linecode b8zs

ds0-group 0 timeslots 1-24 type none service mgcp

!

controller T1 2

framing esf

clock source line secondary 2

linecode b8zs

!

controller T1 3

framing esf

clock source line secondary 3

linecode b8zs

!

!

interface Ethernet0

no ip address

no ip mroute-cache

shutdown

!

interface Serial0

no ip address

no ip mroute-cache

shutdown

clockrate 2015232

no fair-queue

!

interface Serial1

no ip address

no ip mroute-cache

shutdown

clockrate 2015232

no fair-queue

!

interface Serial2

no ip address

no ip mroute-cache

shutdown

clockrate 2015232

no fair-queue

!

interface Serial3

no ip address

no ip mroute-cache

shutdown

clockrate 2015232

no fair-queue

!

interface Serial0:23

no ip address

isdn switch-type primary-ni

isdn bind-l3 backhaul bh5300-vsc1

no cdp enable

!

interface FastEthernet0

ip address 172.16.20.28 255.255.255.192

no ip mroute-cache

duplex full

speed auto

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.20.1

no ip http server

!

!

!

!

radius-server host 172.21.59.165 auth-port 1645 acct-port 1646

radius-server key xxxxxxxx

radius-server vsa send accounting

!

voice-port 0:23

!

voice-port 1:0

!

mgcp

mgcp call-agent 172.16.20.35 2427 service-type mgcp version 0.1

mgcp quarantine mode loop

mgcp package-capability dtmf-package

mgcp package-capability rtp-package

mgcp package-capability as-package

mgcp default-package gm-package

!

mgcp profile default

timeout tsmax 100

no max1 lookup

!

dial-peer cor custom

New Member

Re: Does anyone configure cisco router with MGCP to link Call ag

thanks your help.

fred.

New Member

Re: Does anyone configure cisco router with MGCP to link Call ag

it will work with CCM4.2 ??

i cant find the AS5300 on the drop down menu ?

248
Views
0
Helpful
3
Replies
CreatePlease to create content