Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

E1 R2 Digital in Angola (new post)

I'm sorry about all the blank posting and for the former post, but the server keeps returning

servlet errors. I'm reposting the situation here:

I went to Angola to install several AS5400XM to interwork with voice

calls with the existing PBXs. The signaling used is R2 Digital and the

most alike country is Venezuela (go figure).

The Access Servers are now connected to a Call Progress Analyzer, to

help us work out the entire signaling, because, and although it uses

some options from Venezuela's signaling, it has some differences.

It took me a couple of days, together with the Telecom guys, to arrive

to a working condition, but it is still missing a signal B6, to

establish the call normally. What we see is the digits being sent to the

routers, signals going back as expected, but right in the end of the

signal transaction, the router doesn't send a B6 signal (line is free

and chargeable), which the switch needs to begin a sucessfull voice

call. This is where I need some help, because I'm not seeing how can the

router send this signal back to the Call Progress Analyzer.

TIA.

Cheers,

Nelson

9 REPLIES
Anonymous
N/A

Re: E1 R2 Digital in Angola (new post)

The current Config is as follows (sorry for not attaching, but for some reason, the server keeps returning post errors):

controller E1 7/0

framing NO-CRC4

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 1

country venezuela

release-ack

signal-end-to-end

caller-digits 9

dnis-digits min 1 max 3

dnis-complete

timer interdigit incoming 7000

TIA.

Cheers,

Nelson

Anonymous
N/A

Re: E1 R2 Digital in Angola (new post)

The current PBX <-> Router Sequence is as follows:

1.CDMA -> seizure

2.Router -> seizure-ack

3.CDMA -> digito 2

4.Router -> Sinal A1

5.CDMA -> 2

6.Router -> Sinal A1

7.CDMA -> 2

8.Router -> Sinal A1

9.CDMA -> 2

10.Router -> Sinal A1

11.CDMA -> 2

12.Router -> Sinal A1

13.CDMA -> 0

14.Router -> Sinal A1

15.CDMA -> 0

16.Router -> Sinal A1

17.CDMA -> 0

18.Router -> Sinal A1

19.CDMA -> 0

20.Router -> Sinal A5

21.CDMA -> Category 1

22.Router -> Sinal A9

23.CDMA -> 2A92A93A99A96A94A95A97

24.Router -> Sinal A9

25.CDMA -> F

26.Router -> Sinal A3

27.CDMA -> Category 1

28.Router -> Call Alert

29.Router -> Call Proceed

Anonymous
N/A

Re: E1 R2 Digital in Angola (new post)

NECESSARY SEQUENCE:

1.CDMA -> seizure

2.Router -> seizure-ack

3.CDMA -> digito 2

4.Router -> Sinal A1

5.CDMA -> 2

6.Router -> Sinal A1

7.CDMA -> 2

8.Router -> Sinal A1

9.CDMA -> 2

10.Router -> Sinal A1

11.CDMA -> 2

12.Router -> Sinal A1

13.CDMA -> 0

14.Router -> Sinal A1

15.CDMA -> 0

16.Router -> Sinal A1

17.CDMA -> 0

18.Router -> Sinal A1

19.CDMA -> 0

20.Router -> Sinal A5

21.CDMA -> Category 1

22.Router -> Sinal A9

23.CDMA -> 2A92A93A99A96A94A95A97

24.Router -> Sinal A9

25.CDMA -> F

26.Router -> Sinal A3

27.CDMA -> Category 1

28.Router -> B6

28.CDMA -> Call Connect

29.Router -> Call Connect

Hall of Fame Super Gold

Re: E1 R2 Digital in Angola (new post)

Hello,

before we go in deeper analysis, what IOS are you running? E1 R2 still got bug fixes recently and yoy would be in safer position running the latest mainline code in the event you need to raise a TAC case.

Anonymous
N/A

Re: E1 R2 Digital in Angola (new post)

The Access Servers are running IOS 12.4(1)c. At the time they were purchased, it was the latest one. I can imagine that from there to now, there were some developments.

Strangest thing is that I already looked up into the Bugs part and they really don't seem to match this particular situation.

Cheers,

Nelson

Hall of Fame Super Gold

Re: E1 R2 Digital in Angola (new post)

12.4(1) is really not recommended as it was the first release of 12.4. Please upgrade to 12.4(16) that is out now, in that sense probably even the latest 12.3 mainline would be better of what you have now.

I'm not saying that this will fix the problem you have, but at least you can operate with the confidence of using a code that has been used in production by many users and got more bug fixes.

Anonymous
N/A

Re: E1 R2 Digital in Angola (new post)

Hi,

Just uploaded the IOS. My configuration is working perfectly, it's really a bug problem on 12.4(1). IOS 12.4(16) is working nicely.

Thanks for the advice :)

For everyone out there that needs to put up a working config for voice/data calls in Angola, just copy/paste the config I posted earlier.

Cheers,

Nelson Neves

Hall of Fame Super Gold

Re: E1 R2 Digital in Angola (new post)

This is so good news and I'm glad to hear it!

E1 R2 is always a challenging task but luckily you had telco support and the right rig to diagnose it.

Did the post helped? Please rate it using the scrollbox below!

Community Member

Re: E1 R2 Digital in Angola (new post)

Hi Nelson,

could you please let me know what was the name of the site(firm) that you configured. Because i'm trying configuring a R2 in Angola and i used your configuration but i cant make outbound calls, maybe this is happening because your R2 from the network side(operator)is configured diferently. I'm despaired with Angola Telecom !!! Please let me know what was the firm and the public number of it, in order to Angola Telecom compare the two R2 Circuits. Many Thanks . João Fragoso

412
Views
0
Helpful
9
Replies
CreatePlease to create content