Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

FXO Issues

Howdy,

Short story long...

Currently I am using a VG200 with an VIC-2FXO. This VG200 is configured for MGCP in relation to dial-plan and signalling between it and a CCM cluster. I have setup the VIC-2FXO for Loopstart via the CCM, and I seem to get no ring-back tone after dialing any off-net number. After about 10sec, the call gets terminated and dies. Thinking I have a bad FXO, I removed it from the VG200 and inserted a different one in the same exact slot, with the same exact configs as the first. Wouldn't you know it, it works. So, I've done a debug on the first FXO card, and here's what I found.

00:17:27: ccDigitDialStop (callID=0xFFFFFFFF)

00:17:27: ccCallReportDigits (callID=0xFFFFFFFF, enable=0x1)

00:17:27: ccIFCallSetupRequestPrivate: (vdbPtr=0x811BD208, dest=1xxxxxx3680, callParams={called=1xxxxxx3680,called_oct3=0x0, calling=,calling_oct3=0x0, calling_xlated=false, subscriber_type_str=, fdest=0, voice_peer_tag=0},mode=0x0) vdbPtr type = 6

00:17:27: ccIFCallSetupRequestPrivate: (vdbPtr=0x811BD208, dest=1xxxxxx3680, callParams={called=1xxxxxx3680, called_oct3 0x0, calling=,calling_oct3 0x0, calling_xlated=false, fdest=0, voice_peer_tag=0}, mode=0x0, xltrc=-5)

00:17:27: ccCallSetContext (callID=0x5, context=0x81308AA0)

00:17:27: ccIFCallSetupRequestPrivate: (vdbPtr=0x810F0878, dest=0.0.0.0, callParams={called=,called_oct3=0x0, calling=,calling_oct3=0x0, calling_xlated=false, subscriber_type_str=, fdest=0, voice_peer_tag=0},mode=0x0) vdbPtr type = 9

00:17:27: ccIFCallSetupRequestPrivate: (vdbPtr=0x810F0878, dest=0.0.0.0, callParams={called=, called_oct3 0x0, calling=,calling_oct3 0x0, calling_xlated=false, fdest=0, voice_peer_tag=0}, mode=0x0, xltrc=-5)

00:17:27: ccCallSetContext (callID=0x6, context=0x813075B8)

00:17:27: cc_api_call_proceeding(vdbPtr=0x811BD208, callID=0x5,

prog_ind=0x0)

00:17:27: cc_api_call_connected(vdbPtr=0x810F0878, callID=0x6), prog_ind = 0cc_api_call_connected: setting callEntry->connected to TRUE

00:17:31: cc_api_call_digit_end (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, srcCallId=0x5,

digit=1,duration=115,xruleCallingTag=0,xruleCalledTag=0, dest_mask=0x0)

00:17:31: cc_api_call_digit_end (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, srcCallId=0x5,

digit=6,duration=115,xruleCallingTag=0,xruleCalledTag=0, dest_mask=0x0)

00:17:31: cc_api_call_digit_end (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, srcCallId=0x5,

digit=3,duration=105,xruleCallingTag=0,xruleCalledTag=0, dest_mask=0x0)

00:17:31: cc_api_call_digit_end (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, srcCallId=0x5,

digit=0,duration=105,xruleCallingTag=0,xruleCalledTag=0, dest_mask=0x0)

00:17:31: cc_api_call_digit_end (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, srcCallId=0x5,

digit=9,duration=105,xruleCallingTag=0,xruleCalledTag=0, dest_mask=0x0)

00:17:31: cc_api_call_digit_end (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, srcCallId=0x5,

digit=1,duration=115,xruleCallingTag=0,xruleCalledTag=0, dest_mask=0x0)

00:17:31: cc_api_call_digit_end (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, srcCallId=0x5,

digit=5,duration=115,xruleCallingTag=0,xruleCalledTag=0, dest_mask=0x0)

00:17:31: cc_api_call_digit_end (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, srcCallId=0x5,

digit=3,duration=105,xruleCallingTag=0,xruleCalledTag=0, dest_mask=0x0)

00:17:31: cc_api_call_digit_end (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, srcCallId=0x5,

digit=6,duration=115,xruleCallingTag=0,xruleCalledTag=0, dest_mask=0x0)

00:17:31: cc_api_call_digit_end (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, srcCallId=0x5,

digit=8,duration=105,xruleCallingTag=0,xruleCalledTag=0, dest_mask=0x0)

00:17:31: cc_api_call_digit_end (dstVdbPtr=0x0, dstCallId=0xFFFFFFFF, srcCallId=0x5,

digit=0,duration=105,xruleCallingTag=0,xruleCalledTag=0, dest_mask=0x0)

00:17:31: cc_api_call_cut_progress(vdbPtr=0x811BD208, callID=0x5, prog_ind=0x8, sig_ind=0x2)

00:17:31: cc_api_call_connected(vdbPtr=0x811BD208, callID=0x5), prog_ind = 2cc_api_call_connected: setting callEntry->connected to TRUE

00:17:31: ccConferenceCreate (confID=0x812DD1BC, callID1=0x5, callID2=0x6, tag=0x0)

00:17:31: cc_api_bridge_done (confID=0x3, srcIF=0x810F0878, srcCallID=0x6, dstCallID=0x5, disposition=0, tag=0x0)

00:17:31: cc_api_bridge_done (confID=0x3, srcIF=0x811BD208, srcCallID=0x5, dstCallID=0x6, disposition=0, tag=0x0)

As you can see, I get a ton of the same repeated strings before I even see the "cc_api_call_cut_progress" come through.

Does anyone have a clue as to why this is happening?

Thanks in advance.

Lee

1 REPLY
Bronze

Re: FXO Issues

Guess, this is just the case of a bad FXO card.

122
Views
0
Helpful
1
Replies
CreatePlease to create content