Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How can i prioritize PBX over Router? (PBX and Router plug directly into Modem)

Hello everyone,

I work for a small ISP and i just got hired here a couple months ago. I've been tasked to figure out a solution to this problem. We have customers that have a network, and they also have a phone system. Both devices (router and PBX box) have a static IP address and plug directly into the modem. The issue we see is that the internal network is hogging the bandwidth and this kills the phone systems quality. What i tried was putting a 2960 in between the modem and router/PBX system. Then rate limiting the port to the internal network but it doesn't work out so well. I have it set to use 8mb/800bk. Which should dedicate 2mb/200kb for their phone system at all times. But when i do speed tests i get 2mb down and 200kb up. My download speeds are not right, yet when i do a "no mls qos" the download goes to the 8mb i have set, but then my upload doesnt work correctly. Does anyone have an idea to fix this? Or any better ideas? 

 


no aaa new-model
system mtu routing 1500
!
ip domain-name XXXXX.com
!
mls qos
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
ip tftp source-interface Vlan1
!
class-map match-all RATE_LIMIT_CLASS
  match access-group name RATE_LIMIT_ACL
!
policy-map RATE_LIMIT_POLICY
 class RATE_LIMIT_CLASS
  police 800000 8000 exceed-action drop
!
interface FastEthernet0/1
 description Internal Network
 speed 10
 duplex full
 srr-queue bandwidth limit 80
 service-policy input RATE_LIMIT_POLICY
!
interface FastEthernet0/2

description PBX Box
!
ip http server
ip http secure-server
!
ip access-list extended RATE_LIMIT_ACL
 permit ip any any
access-list 50 permit X.X.X.X 0.0.2.255
!
!
line con 0
 logging synchronous
line vty 0 4
 access-class 50 in
 logging synchronous
 login local
line vty 5 15
 access-class 50 in
 logging synchronous
 login local
!
end

 

2 REPLIES
New Member

Heres an update, even with

Heres an update, even with the Router plugged into fa0/1 with the following config, it still only gets 2.5mb down. Ideas? Could it be because the ports on 10mb?

interface FastEthernet0/1
 description Internal Network
 speed 10
 duplex full
 

New Member

Another update, i set the

Another update, i set the link to 100mb and i get my full speeds, could anyone explain why this modem doesnt get along with the switch at 10mb?

28
Views
0
Helpful
2
Replies