Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

I/O memory problem after upgrade

AS5400XM after upgrade from 12.4(4)xc to 12.4(4)xc7 i have the following problem every 5 days: all ethernet interfaces become inaccessible. in logs i see

SYS-2-MALLOCFAIL: Memory allocation of 780 bytes failed from 0x605A7C4C, alignment 32

Pool: I/O Free: 103920 Cause: Memory fragmentation

Alternate Pool: None Free: 0 Cause: No Alternate pool

and show mem command shows

Head Total(b) Used(b) Free(b) Lowest(b) Largest(b)

I/O 20000000 134217216 134114300 102916 102916 716

So the problem is that I/O memory is running low every 5 days. The problem can be solved by reboot, but rebooting as5400xm every 5 days is not good. Does anybody know what can be the cause.

P.S. Before upgrade 12.4(4)xc ios was working just fine and memory requirements for both 12.4(4)xc and 12.4.(4)xc7 are the same.

1 REPLY
Silver

Re: I/O memory problem after upgrade

The messages indicate that IOS is attempting to allocate another block of memory and there is not enough available. Either there is not enough memory installed or there is a task allocating memory and not freeing it when it is done. Following link may help you

http://www.cisco.com/warp/public/63/mallocfail.shtml

180
Views
0
Helpful
1
Replies