Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Improve voice quality

we are using cisco ATA 186 to make international call via IP i.e VOIP. We have a cisco 1600.

We have 256kpbs of bandwidth, same is used by quite a few users for other purpose like surfing etc...

When we make calls using this ata the call lag (latency) is very high some time it very bad we just can hear the other person.

I tried Priortiy Queuing and then i m using now Custom Queuing without much of change.

Can any help me in queuing or traffic shaping or any thing that can help me to improve with the latency. I dont mind if the other user get less bandwidth during the call period.

here is my config, the ip given to my ata 186 is denoted by C.C.C.226

Regds

RamP

!

ip subnet-zero

ip name-server A.A.A.A

isdn switch-type basic-ni

!

!

!

interface Ethernet0

ip address B.B.B.1 255.255.255.0 secondary

ip address c.c.c.225 255.255.255.224

no ip directed-broadcast

ip nat inside

!

interface Serial0

backup delay 30 60

backup interface BRI0

ip address D.D.D.D 255.255.255.252

no ip directed-broadcast

ip nat outside

custom-queue-list 1

!

interface BRI0

ip address negotiated

no ip directed-broadcast

ip nat outside

encapsulation ppp

dialer idle-timeout 300

dialer string 28529200

dialer hold-queue 10

dialer-group 1

isdn switch-type basic-net3

ppp authentication pap callin

ppp pap sent-username URURE@KSKSKS.COM password 7 141E1C0D05172E25757A075

!

ip nat inside source route-map rtm-nat-bri0 interface BRI0 overload

ip nat inside source route-map rtm-nat-ser0 interface Serial0 overload

ip nat inside source static C.C.C.226 D.D.D.D

ip nat inside source static F.F.F.3 C.C.C.227

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 0.0.0.0 0.0.0.0 BRI0 100

ip route F.F.F.0 255.255.255.0 B.B.B.5

!

access-list 101 permit ip any any

access-list 101 deny icmp any any

access-list 102 permit tcp host C.C.C.226 any eq 16834

access-list 102 permit tcp host C.C.C.226 any eq 16835

queue-list 1 protocol ip 1 list 102

queue-list 1 default 2

queue-list 1 queue 1 byte-count 20480

queue-list 1 queue 2 byte-count 1

dialer-list 1 protocol ip list 101

route-map rtm-nat-ser0 permit 10

match interface Serial0

!

route-map rtm-nat-bri0 permit 10

match interface BRI0

!

!

4 REPLIES
Silver

Re: Improve voice quality

You can configure Low Latency queueing on the WAN interface, but I suspect it won't help here - the problem is most likely the latency across the public internet. A good test is to do an extended ping from the source to the destination. Rather than the default 5 pings, do somethig like 1000 so you get a much idea of the latency between the sites. It may also show how many packets are dropped. If the pings showed excessive delay and packet loss, then no configs on the gateway router will help. It is common to see these issues with VOIP over the public internet. Some providers even block the well know H323, SIP and UDP ports that VOIP use.

New Member

Re: Improve voice quality

RamP

your bandwidth budget does look pretty tight. Assuming the latency is not at the ISP level (as my predecessor pointed it out so brillantly), you can consider Cisco's Modular QoS CLI. here is a link to it: http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a00800bd909.html

but, again, if ISP is the problem, there is no magic you can pull to change the outcome.

E.

New Member

Re: Improve voice quality

Well, traffice shaping won't do you any good since you have no discardables. Serialization won't help since the two B channels are already small (64kb). Your plan raises many many questions and might not be the best suited for your situation.

Why use dial-up ISDN? (assumption unless you have always on ISDN but that's VERY remote since its an international call) You still pay long distance charges and per min rates. You really don't save anything using ISDN. One of the main purposes of VOIP is to save long distance charges. ROI is the key. A better method is to get a Fr link that is about the same price but without the long distance charges and you could get a SLA and QOS policies along with everything else.

New Member

Re: Improve voice quality

If you have not changed the default codec (I believe it is g711), your calls will take up between 80 and 90 K. You could opt for compressed voice using g729 codec, but the voice quality drops significantly ( which is your problem in the first place). Your issues are most likely with the public internet.

133
Views
0
Helpful
4
Replies
CreatePlease to create content