Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IPIPGW

Hi, I'm looking for a basic config for a 3725 with NM-HDV + PVDM to do SIP transcoding from g711 to g729. Anyone with some pointer where to look to start?

My setup is:

IPIVR<--SIP,G711-->3725<--SIP,G729-->Carrier

I have IOS image:

c3725-adventerprisek9_ivs-mz.124-16.bin

Most of the config I found is for Cisco CallMgr and SCCP. Is there config just for plain generic transcoding with SIP?

Any pointer appreciated.

Thanks in advance.

Here is my current config:

!

! No configuration change since last restart

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname A-37-01

!

boot-start-marker

boot-end-marker

!

aaa new-model

!

!

aaa authentication login local-auth local

!

aaa session-id common

clock timezone GMT 8

no network-clock-participate slot 1

no network-clock-participate slot 2

voice-card 1

dspfarm

dsp services dspfarm

!

voice-card 2

dspfarm

dsp services dspfarm

!

ip cef

!

!

!

!

ip name-server 192.168.1.1

!

!

!

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

!

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

!

voice class codec 2

codec preference 1 g729br8

!

voice class codec 3

codec preference 1 g729r8

codec preference 2 g723r53

codec preference 3 g723r63

codec preference 4 g723ar53

codec preference 5 g723ar63

!

!

!

!

!

!

!

!

!

!

!

!

ip ssh authentication-retries 2

ip ssh version 2

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.1.101 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

speed 100

full-duplex

!

interface FastEthernet0/1

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

shutdown

speed 100

full-duplex

!

router rip

network 192.168.1.0

!

ip route 0.0.0.0 0.0.0.0 192.168.1.1

!

!

ip http server

no ip http secure-server

!

no cdp run

!

!

!

!

control-plane

!

!

!

!

!

!

dspfarm transcoder maximum sessions 120

dspfarm rtp timeout 60

dspfarm connection interval 60

dspfarm

!

!

dial-peer voice 100 voip

tone ringback alert-no-PI

description Incoming

voice-class codec 1

session protocol sipv2

incoming called-number .T

dtmf-relay rtp-nte h245-alphanumeric

!

dial-peer voice 200 voip

description Outgoing

destination-pattern .T

voice-class codec 2

session protocol sipv2

session target ipv4:192.168.1.111

dtmf-relay rtp-nte h245-signal h245-alphanumeric

!

gateway

timer receive-rtcp 5

timer receive-rtp 180

!

sip-ua

retry invite 2

retry response 2

retry bye 2

retry cancel 2

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

transport preferred none

line aux 0

exec-timeout 5 0

login authentication local-auth

transport preferred none

line vty 0 5

access-class 1 in

exec-timeout 5 0

login authentication local-auth

transport preferred none

transport input ssh

!

end

7 REPLIES
New Member

Re: IPIPGW

Transcoding doesn't care about the VoIP protocol, it's only for codec negotiation.

Did you ensure your incoming call is using the right dial-peer (show call active/history voice brief)?

Did you hear ring back on phone A, did the phone B ring out?

The call is dropped after you answer the call on phones B?

This documentation can help you...

http://www.cisco.com/en/US/products/ps6441/products_configuration_guide_chapter09186a0080541bf3.html

New Member

Re: IPIPGW

Yes, the call dropped with SIP error 480 (TIMEOUT) after I answered it. The codec I try to use is:

a=rtpmap:18 G729/8000

a=fmtp:18 annexb=yes

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-15

a=rtpmap:19 CN/8000

a=ptime:20

New Member

Re: IPIPGW

A transcoder will need to register to something- it uses SCCP and this is Master/Slave.

You should define start the telephony-service on the router and register the transcoder locally to the telephony-service on the router (you are not really going to setup the router to become a CME- this is just for the transcoder).

I think the bit of config you are missing is:

sccp

sccp local Vlanxxx

sccp ccm 1.1.1.1 priority 1

!

telephony-service

max-ephones 1

max-dn 1

ip source-address 1.1.1.1

sdspfarm units 1

sdspfarm transcode sessions x

sdspfarm tag 1 mtp

In your dial-peers do not use the voice class codec command otherwise you will not be able to use the transcoder- hardcode the codec to g729r8/g711ulaw...

One more thing- unless its a new feature, transcoding is not supported SIP-SIP. So you may have to use H323 on one leg of the call. Thats how it is in earlier 12.4 releases.

Hall of Fame Super Gold

Re: IPIPGW

That is good advice by vmalhi. However in latest code it should be possible to use transcoding for everything without configuring sccp. See:

http://cisco.com/en/US/products/ps6706/products_feature_guide09186a008076161a.html

Remember to use an Ip-to-ip gw image which filename ends with _isv.

Hope this helps, please rate post if it does!

New Member

Re: IPIPGW

The transcoder needs to register to something- it can't invoke itself. You always need to associate it to you SCCP application that you define on the router and register it to one of CME/SRST/CCM. The document also states this, so I am not sure what you are saying?

Hall of Fame Super Gold

Re: IPIPGW

Point taken and I stand corrected. Thanks!

New Member

Re: IPIPGW

No probs! You had me questioning myself there...

239
Views
0
Helpful
7
Replies