Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ISDN CALLS NOT CONNECTING

I'm trying to troubleshoot a cisco platform for voice calls, using an

ISDN PRI.

This should be a 10 digit local call. It does not complete if I

dial 1+ 10digits. (Seen at bottom)

I am a newbie in Cisco Voice products.

Here is my debug output.

layer3#

*Mar 24 03:16:06.092: ISDN Se1/1:23 EVENT: process_pri_call: call id 0x8007, num

ber 15672520826, Guid 503A29A38008, speed 0, call type VOICE, redial No, CSM cal

l No, pdata Yes

*Mar 24 03:16:06.092: ISDN Se1/1:23 Q931: Applying typeplan for sw-type 0x3 is 0

x2 0x1, Calling num 4047881723

*Mar 24 03:16:06.100: ISDN Se1/1:23 Q931: Applying typeplan for sw-type 0x3 is 0

x2 0x1, Called num 15672520826

*Mar 24 03:16:06.100: ISDN Se1/1:23 Q931: TX -> SETUP p

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Calling Party Number i = 0x2180, '4047881723'

Plan:ISDN, Type:National

Called Party Number i = 0xA1, '15672520826'

Plan:ISDN, Type:National

Locking Shift to Codeset 6

Codeset 6 IE 0x28

*Mar 24 03:16:06.280: ISDN Se1/1:23 Q931: RX <- SETUP_ACK pd = 8 callref = 0x80

86

Channel ID i = 0xA98381

Exclusive, Channel 1

*Mar 24 03:16:06.284: ISDN Se1/1:23 EVENT: process_rxstate: ces/callid 1/0x8007

calltype 2 CALL_SETUP_ACK

*Mar 24 03:16:06.340: ISDN Se1/1:23 Q931: RX <- DISCONNECT pd = 8 callref = 0x8

086

Cause i = 0x8090 - Normal call clearing

*Mar 24 03:16:06.348: ISDN Se1/1:23 EVENT: process_rxstate: ces/callid 1/0x8007

calltype 2 CALL_DISC

*Mar 24 03:16:06.352: ISDN Se1/1:23 Q931: TX -> RELEASE pd = 8 callref = 0x0086

*Mar 24 03:16:06.404: ISDN Se1/1:23 Q931: RX <- RELEASE_COMP pd = 8 callref = 0

x8086

*Mar 24 03:16:06.412: ISDN Se1/1:23 EVENT: process_rxstate: ces/callid 1/0x8007

calltype 2 CALL_CLEARED

8 REPLIES

Re: ISDN CALLS NOT CONNECTING

Hi,

this looks quite normal. Your router sends the telephone number '15672520826' to the telco switch. It gets it (RX <- SETUP_ACK) and then disconnects (RX <- DISCONNECT) with cause code "Cause i = 0x8090 - Normal call clearing".

So the real question is, why does your telco disconnect you, when you hand off the telephone number above? Is the telephone number dialed existing or what is the 11th digit doing? I am no specialist in numbering plans, but could it be that the leading "1" causes this? What is the telephone number format the telco expects?

Hope this helps

Martin

New Member

Re: ISDN CALLS NOT CONNECTING

The following is the cofig my t1's are connect a PBX for calling cards then run thru IP: Ineed your help:

Building configuration...

Current configuration : 3276 bytes

version 12.4

hostname 3640

!

enable secret 5

enable password

!

clock timezone GMT 5

voice-card 1

!

ip subnet-zero

ip tcp path-mtu-discovery

!

ip cef

ip name-server 64.105.202.138

!

isdn switch-type primary-5ess

isdn voice-call-failure 0

!

voice service voip

signaling forward unconditional

cause-code legacy

sip

ds0-num

no call service stop

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

codec preference 3 g723r63

!

controller T1 1/0

framing esf

clock source internal

linecode b8zs

cablelength short 133

pri-group timeslots 1-24

!

controller T1 1/1

framing esf

linecode b8zs

cablelength short 133

pri-group timeslots 1-24

!

interface FastEthernet0/0

ip address 72.x.x.x.255.255.248

speed auto

half-duplex

!

interface Serial1/0:23

no ip address

isdn switch-type primary-5ess

isdn protocol-emulate network

isdn incoming-voice voice

isdn supp-service name calling

!

interface Serial1/1:23

no ip address

isdn switch-type primary-5ess

isdn protocol-emulate network

isdn incoming-voice voice

isdn supp-service name calling

!

interface Ethernet2/0

no ip address

shutdown

half-duplex

!

interface Ethernet2/1

no ip address

shutdown

half-duplex

!

ip default-gateway 72.x.x.137

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 72.214.194.137

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

ip route 72.x.x.x.255.255.248 72.214.194.137

!

ip rtcp report interval 100

!

access-list 100 permit tcp any any eq telnet

access-list 101 permit ip any any

access-list 102 permit udp any any range 16384 32767

access-list 103 permit tcp any eq 1720 any

access-list 103 permit tcp any any eq 1720

snmp-server community RO

!

control-plane

!

call filter match-list 1 voice

!

voice-port 1/0:23

!

voice-port 1/1:23

!

dial-peer voice 1 pots

service session

destination-pattern .T

direct-inward-dial

port 1/0:23

!

dial-peer voice 2 voip

service session

destination-pattern .T

session protocol sipv2

session target ipv4:216.143.130.94

session transport tcp

dtmf-relay rtp-nte

codec g711ulaw

!

dial-peer voice 4 pots

service session

destination-pattern .T

direct-inward-dial

port 1/1:23

!

dial-peer voice 5 voip

service session

destination-pattern .T

session protocol sipv2

session target ipv4:216.143.130.92

session transport tcp

dtmf-relay rtp-nte

codec g711ulaw

!

dial-peer voice 6 voip

service session

destination-pattern .T

session protocol sipv2

session target dns:sip-server

session transport tcp

dtmf-relay rtp-nte

codec g711ulaw

!

dial-peer voice 7 voip

service session

session protocol sipv2

session target ipv4:66.98.180.77

session transport tcp

dtmf-relay rtp-nte

codec g711ulaw

!

gateway

timer receive-rtcp 10

timer receive-rtp 500

!

sip-ua

nat symmetric role active

nat symmetric check-media-src

retry register 10

sip-server dns:sip-server

!

line con 0

line aux 0

line vty 0 4

password

login

!

end

Re: ISDN CALLS NOT CONNECTING

Hi,

thank you for the config, but please also answer the questions above. As I said from your debug the router behaviour looks normal. You need to find out what the telco does not like about the telephone number dialed.

Regards

Martin

New Member

Re: ISDN CALLS NOT CONNECTING

Can you tell us please why you're configured to emulate the network side of the PRI D channel? Usually this is taken care of by the switch you're connected to, and your side is left at the default, user.

Also, Please check with your provider to make sure the proper switch type is 5ess - you are receiving a setup_ack, which is weird for a circuit in the US. I believe that you would normally want to see a call proceeding follwed by an alerting from the far end, not a setup_ack unless this was PRI over an E1.

is there another callmanager system on the other side of this PRI? Why are you emulating the network side?

-Peter

New Member

Re: ISDN CALLS NOT CONNECTING

My 2T1's are connected to a PBX not to a telco switch, I am sending my calls thru IP both in and out bound.

Thx. Knmezi.

Re: ISDN CALLS NOT CONNECTING

Ah, this is news ;-)

Well the setup then depends strongly on the PBX configuration. Without knowing it it is hard to guess the proper settings.

Do you think switch-type 5ess is suitable?

Martin

New Member

Re: ISDN CALLS NOT CONNECTING

The PBX switch-type is 5ess and the PBX vendor stated that it's suitable.

Knmezi

Re: ISDN CALLS NOT CONNECTING

Hi,

then have a look at the telephone number format the PBX expects, can you get information on this? Maybe you have to skip country code, maybe a leading 9 for long distance.

Hope this helps

Martin

211
Views
4
Helpful
8
Replies