Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Modem PassThrough

Friends,

I am currently working on voip setup. With the existing tdm network, dialup

users from different sites dial Remote Access Server in central site. When i

will put routers into that network, can users be able to connect again via

voip setup. Topology includes cisco 3800 routers that connect with Ericson

MD110 pbx through E1 (Pri Qsig). Routers are connected point to point

through E1. RAS is non-cisco.

Existing Topology:

IP Network ---------RAS------------PBX--------------------------------------------PBX--------------Dialup

User (Modem)

Topology after voip setup:

IP Network

---------RAS------------PBX---------Router-----------------------------Router--------PBX--------------Dialup

User (Modem)

With some study i come to know that there is concept of modem passthrough

that can be used but someone please explain it briefly. And if someone

currently using it, please write down a sample configuration according to my

voip topology.

Best Regards

12 REPLIES
Cisco Employee
Community Member

Re: Modem PassThrough

Friends,

I configured routers with for modem passthrough. When my modem dial RAS number, It starts negotiation with RAS but keep negotiate and not connected. Means repeat negotiation again and again till timeout. Once it surprisingly connected but within 30 sec it disconnected. Network Topology below:

RAS--------PBX-----Rt-A--------------------Rt-B----PBX-----------DialupUser

And Configuration below:

hostname Rt-B

isdn switch-type primary-qsig

voice service voip

modem passthrough nse codec g711alaw

controller E1 0/0/0

channel-group 0 timeslots 1-31

controller E1 0/1/0

pri-group timeslots 1-31

interface Serial0/0/0:0

ip address 10.0.0.2 255.255.255.252

interface Serial0/1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-qsig

isdn overlap-receiving

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

router ospf 100

network 0.0.0.0 255.255.255.255 area 0

dial-peer voice 786 voip

destination-pattern 786$

modem passthrough nse codec g711alaw

session target ipv4:10.0.0.1

no vad

!

dial-peer voice 785 pots

incoming called-number 786$

direct-inward-dial

port 0/1/0:15

-------- Router A ---------

hostname Rt-A

isdn switch-type primary-qsig

voice service voip

modem passthrough nse codec g711alaw

!

controller E1 0/0/0

channel-group 0 timeslots 1-31

controller E1 0/1/0

pri-group timeslots 1-31

interface Serial0/0/0:0

ip address 10.0.0.1 255.255.255.252

router ospf 100

network 0.0.0.0 255.255.255.255 area 0

dial-peer voice 786 pots

destination-pattern 786$

direct-inward-dial

port 0/1/0:15

forward-digits 3

!

dial-peer voice 785 voip

modem passthrough nse codec g711alaw

incoming called-number 786$

no vad

Note: i omit all unnecessary configuration.

Waiting for your immediate response.......

Best Regards

Cisco Employee

Re: Modem PassThrough

OK from what you are saying it sounds like there may be some issue with the RTP stream itself. Modem and fax calls are vary vary sensitive to jitter, concealment , and packet loss - things you would not even notice in a voice call.

I would suggest using modem relay instead of passthorugh:http://cisco.com/en/US/products/sw/iosswrel/ps5207/products_configuration_guide_chapter09186a008053b58c.html

If you still have issues, use show call act vo or sh call hist and see what the RTP stats are for the call.

Community Member

Re: Modem PassThrough

Sir,

I studied about modem relay and come to know that it can support maximum 33 kbps speed that is not acceptable for our us due to some limitations. If you can assist me for modem passthrough, i will be thankful.

Best Regards

Cisco Employee

Re: Modem PassThrough

I Understand....

You will need to look at the RTP stream itself then either by capturing statistics for the call with sh call act or after the call is complete with sh call hist. A sniffer capture of RTP in both directions would tell you the same thing. For modem to passthrough to work as well as you are expecting, that RTP stream needs to be as close to flawless as you can make it.

Hope this helps.....

Cisco Employee

Re: Modem PassThrough

I Understand....

You will need to look at the RTP stream itself then either by capturing statistics for the call with sh call act or after the call is complete with sh call hist. A sniffer capture of RTP in both directions would tell you the same thing. For modem to passthrough to work as well as you are expecting, that RTP stream needs to be as close to flawless as you can make it.

Hope this helps.....

Cisco Employee

Re: Modem PassThrough

I Understand....

You will need to look at the RTP stream itself then either by capturing statistics for the call with sh call act or after the call is complete with sh call hist. A sniffer capture of RTP in both directions would tell you the same thing. For modem to passthrough to work as well as you are expecting, that RTP stream needs to be as close to flawless as you can make it.

Hope this helps.....

Community Member

Re: Modem PassThrough

Thanks again for responding. I will analyze rtp stream but i forget to tell you that all routers and BPXs in a same lab so no delay, congestion and media at all. Tell me, are there any other commands beside these for modem passthrough or commands to tweak it???

Thanks Again for your assistance.

Regards

Cisco Employee

Re: Modem PassThrough

Can you do a 'sh controller e1' and post the result in here please. Also post the complete SH RUN of both routers as well.

If you see any clock slips on the E1 interfaces of either controller, then this will be what is making the modem passthrough fail.

Why ?

http://www.cisco.com/en/US/prod/collateral/routers/ps5854/prod_white_paper0900aecd805b9915_ps5855_Products_White_Paper.html

http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a008031a072.shtml

If this is due to slips, it should be easy to clear them once we see the configs.

Community Member

Re: Modem PassThrough

Dear pcameron/crieman,

Thank again for reply. I am on leave for few days thats why i cann't perform steps you mention above. I will get you back very soon..

Thanks & Regards

Community Member

Re: Modem PassThrough

Dear pcameron,

Sorry for that delay. Please find routers configuration and show controller output in attachment. I think you are right, this may be due to slips. Please look into it and tell me the solution........

Best Regards

Cisco Employee

Re: Modem PassThrough

Hi - yes you have some clock slips here, you will need to use the network-clock-select commands (and show network-clocks) to eliminate them.

http://cisco.com/en/US/prod/collateral/routers/ps5854/prod_white_paper0900aecd805b9915_ps5855_Products_White_Paper.

http://cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a008031a072.shtml

397
Views
0
Helpful
12
Replies
CreatePlease to create content