Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

MoH not playing

We have Cisco Unified CallManager 5.1 and I've been trying to add a new MoH source. The file I've uploaded to the server is a .wav. I've tried a number of different formats and sample rates suggested by both our contract support and a Cisco white paper. The .wav translates with no errors and I create a Music on Hold Audio source with that .wav. I've set the DN to use that audio source but when tested I get nothing when a call is placed on hold.

If someone has a clue in their clues closet for me, I'd appreciate it.

6 REPLIES

Re: MoH not playing

PsdTech01, can you provide a bit more information about who the call is between and who is pressing the hold key?

You need to make sure that the party that you are expecting to be listening to the Music On Hold has an MRGL assigned (either to the Device itself or to its Device Pool) that contains an MOH server that has that audio source.

Community Member

Re: MoH not playing

It's for both internal and external calls. As for who is pressing the hold key it would be any internal user.

The MRGL is assigned to the to device itself.

Re: MoH not playing

You have assigned an MRGL to the device that is being PUT on hold (for external calls this would be the gateway you are using)?

Make sure that MRGL contains the MOH server with the audio source.

Community Member

Re: MoH not playing

Problem solved. I hadn't uploaded the music to both the subscriber AND the publisher.

Re: MoH not playing

You shouldn't need to put them on both servers - unless you are specifying both servers in the MRGL.

Community Member

Re: MoH not playing

I know that in CM 4.1.(3) you also need reset MOH servers.

628
Views
0
Helpful
6
Replies
CreatePlease to create content