Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Need help on basic setup

Hi,

New to Cisco VoIP but been doing SIP for several years now. Here is what I have and what I need.

Cisco 2801 with c2801-advipservicesk9-mz.124-20.T1.

Fa0/0

ip 10.10.10.1/24

Fa0/1

ip 10.98.5.247/23

I have a PC with Xlite softphone

10.10.10.2

Extention 2002

I got the Xlite to register to the router, but trying to route all external calls to a specific IP 10.98.5.245 which is a Acme SBC.

Here is my setup. Can someone tell me what I'm doing wrong?

Router#sh run

Building configuration...

Current configuration : 3965 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable secret 5 $1$DiN8$kyxjpdY/DaGEuqzTFrqlr1

!

no aaa new-model

memory-size iomem 20

dot11 syslog

ip source-route

!

!

!

!

ip cef

!

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

!

voice service voip

allow-connections sip to sip

redirect ip2ip

sip

registrar server

no call service stop

!

!

!

!

!

!

!

!

!

!

!

!

voice register global

mode cme

source-address 10.10.10.1 port 5060

max-dn 30

max-pool 20

authenticate register

!

voice register dn 1

number 2002

allow watch

name xlite

label test

mwi

!

voice register pool 1

id mac 0002.B330.B04A

number 1 dn 1

presence call-list

dtmf-relay rtp-nte sip-notify

username 2002 password 2002

codec g711ulaw

!

!

!

voice-card 0

!

!

!

!

username cisco privilege 15 secret 5 $1$2ssP$haAS0QsYZMyhfSp61rqKl.

archive

log config

hidekeys

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.10.10.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 10.98.5.247 255.255.254.0

duplex auto

speed auto

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.98.4.1

no ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

ip http path flash:/html

!

!

!

!

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

dial-peer voice 2000 voip

description "outbound"

destination-pattern 16137330000

b2bua

session protocol sipv2

session target ipv4:10.98.5.245

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

!

sip-ua

credentials username 2001 password 7 115B495546 realm none

authentication username 2002 password 7 1357474259

!

!

!

telephony-service

max-ephones 20

max-dn 20

ip source-address 10.10.10.1 port 5060

max-conferences 8 gain -6

web admin system name pipsadmin password pipsadm

dn-webedit

time-webedit

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn 2

number 2002

label 2002

description 2002

name 2002

hold-alert 30 originator

!

!

ephone 1

device-security-mode none

!

!

!

line con 0

line aux 0

line vty 0 4

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

end

3 REPLIES

Re: Need help on basic setup

Currently, dial peer 2000 will only send calls to 16137330000 out the SIP trunk. If you are not using an access code such as 9 and you want to send all calls to the SIP provider, you can use "destination-pattern .T".

Hope this helps.

Brandon

New Member

Re: Need help on basic setup

Thanks !

WHere can I get more info on the patterns?

Re: Need help on basic setup

Take a look at the following link.

http://www.cisco.com/en/US/docs/ios/12_2/voice/configuration/guide/vvfpeers.html#wp1258752

Hope this helps. If so, please rate the post.

Brandon

155
Views
10
Helpful
3
Replies