Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

No communication between CUCM and IP Phones

Hi there. Am setting up a VOIP network using a 3500 XL with VLAN configured for voice and data and also a 2801 router which is acting as a router on a stick and a dhcp server. I have a CUCM v8 running in Vmware. My IP phones get their IP addreses alright but cannot communicate with the CUCM server. What VLAN is the CUCM server supposed to be please. I have configured option 150 on the dhcp.  Any help will be very much appreciated. Thanks

7 REPLIES
Super Bronze

No communication between CUCM and IP Phones

Hi

Which type of VMware?

If it's workstation, typically you would bridge the CUCM to your LAN interface. The CUCM will go into your access VLAN, and you would set an address from that VLAN on the CUCM.

Take care to follow the correct procedure if you need to change your CUCM IP.

If it's ESXi then 'what VLAN' depends how you configure things - you would normally put the CUCM in the voice VLAN, and what you need to do depends on what you have configured on the ports connecting to the VMware host.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

No communication between CUCM and IP Phones

Thanks Aaron for the quick reply. I am using Vmware workstation which is running on my laptop. I have bridged the CUCM to my LAN interface alright because the virtual machine can ping the LAN interface alright but that is where it ends. My dhcp router cannot even ping the CUCM or the LAN interface IP address on the laptop. This is how I configured my dhcp router.

ip dhcp excluded-address 192.168.10.1 192.168.10.10

ip dhcp excluded-address 192.168.20.1 192.168.20.10

!

ip dhcp pool VOICE

   network 192.168.10.0 255.255.255.0

   default-router 192.168.10.1

   option 150 ip 192.168.10.10

!

ip dhcp pool DATA

   network 192.168.20.0 255.255.255.0

   default-router 192.168.20.1

!

!

!

!

!

!

interface FastEthernet0/0

description TRUNK PORT TO THE SWITCH

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.10

description SUB-INTERFACE FOR VOICE VLAN

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

!

interface FastEthernet0/0.20

description SUB-INTERFACE FOR DATA VLAN

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0

And this is the configuration for the switch. The CUCM is plugged into Fa0/23 and the dhcp is plugged in Fa0/24. I thought the config on that port (Fa0/23) is the problem but cannot figure it out.

interface FastEthernet0/1

description PHONE & PCs

switchport trunk encapsulation dot1q

switchport trunk native vlan 20

switchport trunk allowed vlan 1,10,20,1002-1005

switchport mode trunk

switchport voice vlan 10

spanning-tree portfast

!

interface FastEthernet0/2

description PHONE & PCs

switchport trunk encapsulation dot1q

switchport trunk native vlan 20

switchport trunk allowed vlan 1,10,20,1002-1005

switchport mode trunk

switchport voice vlan 10

spanning-tree portfast

!

!

interface FastEthernet0/23

description PHONE & PCs

switchport trunk encapsulation dot1q

switchport trunk native vlan 20

switchport trunk allowed vlan 1,10,20,1002-1005

switchport voice vlan 10

spanning-tree portfast

!

interface FastEthernet0/24

description TRUNK TO 2801

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,10,20,1002-1005

switchport mode trunk

Thanks for your help

New Member

No communication between CUCM and IP Phones

Nana,

I have been gone through with this situation as well, you are mentioning that

I am using Vmware workstation which is running on my laptop. I have bridged the CUCM to my LAN interface alright because the virtual machine can ping the LAN interface alright but that is where it ends. My dhcp router cannot even ping the CUCM or the LAN interface IP address on the laptop

Well my suggestion for you is first check your Laptop that IP address, Subnet Mask and Default Gatway is right or not.

Second disable the Firewall if any is enable. You will be able to ping the CUCM then after words,

If you will be successful in this please let me know whether you are able to register the phone or not, as now i am encountrying with Problem when my Phones try to register it stucks on Configuring CM List. I am trying to know why, if you or any one know about this please let me know.

Regards,

Atif     

New Member

Re: No communication between CUCM and IP Phones

I will let you know as soon as I give it a go. I have been busy so have not

been on my lab for a while.

Cheers

On Wed, Mar 21, 2012 at 5:05 AM, atifsobia <

New Member

Re: No communication between CUCM and IP Phones

Hi I did what you said and I can now ping the dhcp router successfully. Now

I cannot get the phones to register. Same problem you are facing. I am

still trying but if you do get any solution please let me know. Thx

On Wed, Mar 21, 2012 at 5:05 AM, atifsobia <

New Member

Re: No communication between CUCM and IP Phones

Nana,

Try to make dhcp server your router and then reboot the Phones and see if you are getting the IP address correct with TFTP and DG. Also install CIPC on your pc and in vmware workstation and see if you are able to get these phone registered as before going to do with Physical PHone. as now i am able to registered my cipc, still in progress to find the solution for Configuring CM List error.

I do not know is some here will help as i am not seeing any other reply from any one, but i can assure as soon i will get the answer i will post to you,,,

Atif    

New Member

Re: No communication between CUCM and IP Phones

Hello, my IP phones get all their configurations, like ip address, address

for the TFTP server, default gateway.... But I did reset one of my phones

to the factory setting and this phone cannot connect to the CUCM for its

configuration files. In short I think the phones cannot get to the CUCM for

some reasons. Still looking for solutions

On Thu, Mar 22, 2012 at 8:16 PM, atifsobia <

1765
Views
0
Helpful
7
Replies
CreatePlease to create content