Cisco Support Community
Community Member

Outbound CLID broken after IOS upgrade ?

If anyone can help explain this problem, It will be much appreciated.

Sip Phone ----> 3640 ----> ISDN PRI ====> PSTN

Scenario is 3640 running IOS 12.2(19)A (enterprise plus feature set) (image = c3640-jk9o3s-mz.122-19a.bin), inbound SIP call is forwarded out over an ISDN PRI. Telco sends the CLID provided in the SIP From: field. Now we upgrade to 12.3(4)T2 (ip plus feature set)(image = c3640-is-mz.123-4.T2.bin) and no CLID is sent. Output of "debug isdn standard" shows the following line:

ISDN Se0/0:23 EVENTd: pak_private_number: Calling Number IE is being stripped

Also, no calling party information appears in output of "debug isdn q931".

I have tried various combinations of outbound dial-peer translation rules (including the numbering plan and type) and various possible values in the Remote-party-ID: SIP header (privacy=off;screen=yes), as well as no Remote-party-ID header. Output of "debug voice ccapi inout" looks OK (calling number is OK, cisco-ani, ani-type, ani-plan, ani-pi, ani-si look OK).

Also, I tried IOS 12.3(5) and the problem does not exist.

Why would the router strip out the outbound calling party IE? Why would a configuration that works with 12.2 and 12.3(5) break with 12.3(4)T2 ? Could it have anything to do with the feature set (Enterprise Plus vs. IP Plus) ?

If anyone can answer these questions or point me to some explanation, I will be VERY grateful.

Thanks in advance -


Community Member

Re: Outbound CLID broken after IOS upgrade ?


I have exactly the same problem ! Although on a AS5350 running c5350-js-mz.123-4.T2.bin.

tried "isdn map address . plan isdn type national" on the serial interface. Did not work.

Also tried adding "isdn calling number ........" (8 digits). Did not work.

When debugging on SIP the CLID is being received from the SIP client.

Interesting that we have the same problem on the same software ? hopefully someone will give pointer as to which software that works or a workaround command.



CreatePlease to create content