Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QOS for Voice

I have access layer switch, where Cisco IP phones are directly connected.With IP phone,pc is connected. Acees layer switch(4506) is connected with 6509 core switch and 6509 is then connected to 7206 router for WAN connectivity. I want to implement QOS end-to-end. Can you please let me know the best practice and the best way to achieve quality of service starting from acess switch to core switch and on router.

3 REPLIES

Re: QOS for Voice

Hi

Your IP Phones does marks the packet with COS - 5 and DSCP EF.

on your 4500 switch port whereever you got ur ip phones connected do remember to trust the device which is ur ip phone and also trust the qos markings.

now you need to concentrate upon the queueing part which you need to configure on your switch so that the different traffic patterns have differen queues configured.

it also depends upon how total queues your 4500 can support.it comes like 1p3q etc.,

so plan your queuing technology in place.

Also in your 6500 match the dscp values being marked or being sent withe tos field of your traffic sent from 4500.

configure your 6500 accordingly to carry forward the same qos markings till to your 7200.

again in your 7200 vxr place your voip in LLQ and other traffic in CBWFQ.

you can alwasy do RTP compression also if ur P2P link is less than 1Mbps capacity,also you can try out LFI.

i hope you are well aware of configuring class-maps,policy maps to achieve the main qos config components and also about wrr or srr based on the support in ur box.

regds

New Member

Re: QOS for Voice

Hi,

Thanks for your help and support. Following is the configuration which I have done in my devices. I haven't enable any qos under VLAN interface and under interface between Cores witch to WAN router.Is there any need for above? I am not much confortable with wrr/srr queuing, so is it necesaary to define?

Also let me know, if anything else I have to configure.

Router-

inteface Serial 1/0

ip address 1.1.1.1 255.255.255.252

encapsulation ppp

ip rtp header-compression

service-policy output voice-policy

no shut

!

class-map voice-signaling

match access-group 112

class-map match-all voice-traffic

match access-group 111

!

policy-map voice-policy

class voice-traffic

priority percent 75

class voice-signaling

priority 1024

class class-default

fair-queue

!

access-list 111 permit udp any any range 16384 32776

access-list 112 permit tcp any eq 1720 any

access-list 112 permit tcp any any eq 1720

Core switch (6509) -

interface GigabitEthernet7/1

description ### Towards access switch 4506 ###

switchport trunk encapsulation dot1q

switchport mode trunk

mls qos trust dscp

auto qos voip trust

no cdp enable

!

Access switch (4506) -

interface GigabitEthernet0/2

description ## Uplink towards Core switch ##

switchport trunk encapsulation dot1q

mls qos trust dscp

auto qos voip trust

switchport mode trunk

no cdp enable

!

interface FastEthernet1/1

description ## towards IP Phone ##

switchport access vlan 147

switchport voice vlan 1147

mls qos trust cos

mls qos trust device cisco-phone

power inline auto

spanning-tree portfast

Re: QOS for Voice

hi

do revert back about the config status on ur uplink between the 6500 amd your router ethernet port ?

also any specific funda behind configuring signalling traffic ?

coz all other traffic you are just leaving like that not giving any guranteed bandwidth.

do take care of that part too.

regds

151
Views
0
Helpful
3
Replies