Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

QoS for VoIP link 128kbps

hi

what is the best solution QoS, for a link of 128kbps....

PQ-WFQ

LLQ

thanks,

Hugo

  • Voice over IP
1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: QoS for VoIP link 128kbps

Hi Hugo,

PQ/WFQ is no longer the recommended way of doing this. Therefore, I suggest you go with 128kbps. The other thing you will have to do is Link Fragmentation and Interleaving (LFI) since you will have significant issues with serialisation delay at 128k. The options you have are:

- FRF.12 if using Frame Relay

- Multilink PPP (MLP) with interleaving if using other link-layer technologies. You can run MLP over FR and MLP over ATM too.

Hope that helps - pls rate the post if it does.

Paresh

4 REPLIES
Purple

Re: QoS for VoIP link 128kbps

Hi Hugo,

PQ/WFQ is no longer the recommended way of doing this. Therefore, I suggest you go with 128kbps. The other thing you will have to do is Link Fragmentation and Interleaving (LFI) since you will have significant issues with serialisation delay at 128k. The options you have are:

- FRF.12 if using Frame Relay

- Multilink PPP (MLP) with interleaving if using other link-layer technologies. You can run MLP over FR and MLP over ATM too.

Hope that helps - pls rate the post if it does.

Paresh

New Member

Re: QoS for VoIP link 128kbps

I just have a serial link DTE with DCE.....

two routers

thanks

hugo

New Member

Re: QoS for VoIP link 128kbps

Hi Paresh,

In my case I have one router with two Eth interfaces.

My provider not provided v.35 interfaces.

I have a link to 128 Kbps working on the Eth0 interface .

In this case , the serialisation is a problem ?

How can I improve my config ?

Here the config in my router :

ip access-list extended VoIPCID1000

permit udp any any range 16384 32767

permit tcp any any eq 1720

permit tcp any eq 1720 any

!

class-map match-any VoIP

match ip precedence 5

match access-group name VoIPCID1000

!

policy-map wan-CID1000

class VoIP

priority 40

class class-default

fair-queue

!

policy-map sedes

class class-default

shape average 128000

service-policy wan-CID1000

!

interface loopback 1

description IP para VoIP

ip address 10.10.30.2 255.255.255.255

h323-gateway voip bind srcaddr 10.10.30.2

interface Ethernet0/0

description WAN

ip address 10.9.30.114 255.255.255.240

service-policy output sedes

!

voice-port 1/0/0

!

voice-port 1/0/1

!

dial-peer voice 1 pots

destination-pattern 200

port 1/0/0

!

dial-peer voice 100 voip

incoming called-number 200

destination-pattern 100

session target ipv4:10.10.30.1

codec g729r8 bytes 80

ip precedence 5

no vad

!

dial-peer voice 110 voip

destination-pattern 300

session target ipv4:10.10.30.3

codec g729r8 bytes 80

ip precedence 5

no vad

Thks /Juan Carlos G

Purple

Re: QoS for VoIP link 128kbps

Hi Juan,

Serialization delay will not be a problem in your case, since you are using an Ethernet access. However, the shaping interval will be a problem. Ideally, you want to use a shaping interval of 10ms. In your case, that equates to 1280 bits (160 bytes). Since your data packets could be up to 1500 bytes, this will not help you.

There is no LFI mechanism that you can use with Ethernet so I'm afraid you don't have too many options here. You need to have at least a 768k service to be able to run voice traffic properly.

Hope that helps - pls rate the post if it does.

Paresh

143
Views
4
Helpful
4
Replies
This widget could not be displayed.