Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

QOS on Ubr10000

Currently our Company is deploying voice services over the cable infrastructure, we have configured QOS on the UBR10000 to our best knowledge, Does Cisco have some sort of QOS best practice for MSO's that want to provide end to end QOS for voice services. Here is an example of what we did I am curious of any input on this matter.

class-map match-all voice-signaling-classifier

match access-group 111

match ip dscp af31

class-map match-all voice-bearer-classifier

match ip dscp ef

match access-group 112

!

!

policy-map QOS

class voice-bearer-classifier

priority percent 25

class voice-signaling-classifier

bandwidth percent 5

class class-default

bandwidth 118240

set dscp default

interface GigabitEthernet1/0/0

no ip address

service-policy input QOS

service-policy output QOS

interface GigabitEthernet2/0/0

no ip address

service-policy input QOS

service-policy output QOS

access-list 111 permit udp 10.100.0.0 0.0.255.255 eq 2427 172.23.7.0 0.0.0.255 eq 2727

access-list 111 permit udp 172.23.7.0 0.0.0.255 eq 2727 10.100.0.0 0.0.255.255 eq 2427

access-list 112 permit udp 10.100.0.0 0.0.255.255 172.23.7.0 0.0.0.255

access-list 112 permit udp 172.23.7.0 0.0.0.255 10.100.0.0 0.0.255.255

Thanks,

Jeremy

5 REPLIES

Re: QOS on Ubr10000

Hello,

some remarks. First you do not have to specify a bandwith for the class-default. It will get the rest anyhow. second I would suggest weigted fair queueing and weighted random early detection for the default class. It generally will give good results for the average internet traffic today. So my suggesting is

policy-map QOSout

class voice-bearer-classifier

priority percent 25

class voice-signaling-classifier

bandwidth percent 5

class class-default

fair-queue

random-detect

set dscp default

interface GigabitEthernet2/0/0

ip address 10.1.1.1 255.255.255.0

service-policy output QOSout

As you have seen I renamed the class to QOSout. The thing is that your policy is using CBWFQ and that is an output feature on all but some platforms. So most likely your router would not accept the command "service-policy input QOS" at all. As I do not know your hardware I can not be sure.

The way it looks to me, there is no input policy needed, unless the voip traffic is not properly marked. If it does not have "ef" your class voice-bearer-classifier will not see any traffic.

In addition you can only apply the service-policy describing IP traffic, if an IP address is assigned to the interface.

Hope this helps! Please rate all posts!

Regards, Martin

New Member

Re: QOS on Ubr10000

When you add the fair-queue command it automaticly addes the bandwidth 118240 command on the Ubr10000 platform. For some odd reason fair-queue does not show up. I can only assume that it the class-default is running fairqueue

Service-policy output: QOS

Class-map: voice-bearer-classifier (match-all)

295133660 packets, 64343729648 bytes

5 minute offered rate 263000 bps, drop rate 0 bps

Match: ip dscp ef

Match: access-group 112

priority : 250015 kbps

Class-map: voice-signaling-classifier (match-all)

866384 packets, 205534738 bytes

5 minute offered rate 2000 bps, drop rate 0 bps

Match: access-group 111

Match: ip dscp af31

bandwidth : 50052 kbps

Class-map: class-default (match-any)

44733361549 packets, 14213382830434 bytes

5 minute offered rate 10838000 bps, drop rate 0 bps

Match: any

bandwidth : 226637 kbps

QoS Set

dscp default

Packets marked 0

What I find odd is that no Packets get marked to dscp default

Jeremy

New Member

Re: QOS on Ubr10000

Just a few notes:

Your class-maps are match-all statements, so they must match both the DSCP value and that ACL to have the action applied to them. I'm not sure if this is your intention.

When using percentage based CBWFQ, the maximum percentage allocated by default is 75%. This is to allow 25% for control traffic. Typically control traffic doesn't account for 25%, so you can get away with either adjusting max-reserved-bandwidth under the interface 90-98%, or set it to 100% and create a control class matching IPP 6 & 7.

New Member

Re: QOS on Ubr10000

Since this is a Ubr10000 we have a mixture of data and voice traffic, We run two ospf processes to and two vlans to seperate the traffic. I was under the impression if I use fair-queing that our ospf traffic will always be in the first queue. or should I actuallly reserve bandwidth for IPP 6 and 7

Jeremy

New Member

Re: QOS on Ubr10000

I re-read the C10k docs and see that you can configure at most 99% using max-reserved-bandwidth. The remaining 1% is left for PAK_PRIORITY. The short answer is that OSPF hellos are marked with PAK_PRIORITY and are put at the front of the queue, no matter how your QoS policy is configured. Your other OSPF packets are marked with IPP 6, and unless you have a specific class for IPP 6 traffic, they will be left in class-default.

I prefer to explicitly define a control class for both IPP 6 & IPP 7 traffic, typically 1-2% of the total bandwidth.

Here's a list of protocols which are marked PAK_PRIORITY:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120s/120s28/12sclocp.htm#wp1046068

140
Views
4
Helpful
5
Replies