Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS (RPM)

Hi, guys!, using MPLS VPN, using a MGX 8830 (RPM) providing QoS to costumer; costumer is complaining about voice cuts when passing data...we`re using Multilink (ppp) interfaces fot the costumer, the conf:

class-map match-any VOZ

match ip dscp ef

match ip precedence 5

class-map match-all Signaling

match access-group name Signaling

class-map match-all DataPlus

match ip dscp af22

!

policy-map QOS

class VOZ

priority percent 50

class Signaling

bandwidth percent 12

class DataPlus

bandwidth percent 25

class class-default

fair-queue

!

!

interface Multilink2001

description COSTUMER

ip vrf forwarding COSTUMER

ip address 1.1.1.1 255.255.255.252

max-reserved-bandwidth 88

service-policy output QOS

load-interval 30

ppp multilink

ppp multilink fragment-delay 10

ppp multilink interleave

multilink-group 2001

!

interface Virtual-Template1

description COSTUMER

no ip address

ppp multilink

multilink-group 2001

!

And the PVC for the RPM:

interface Switch1.2001 point-to-point

description COSTUMER

pvc 0/201

ubr 150

oam-pvc 10

encapsulation aal5ciscoppp Virtual-Template1

no protocol ip inarp

!

switch connection vcc 0 201 master remote

pcr 354

cost 4294967295

rpcr 480

rutil 100

util 100

!

In the CPE is seems OK the conf, in facto we applied an ACL on the CPE receiver interface (Multilink), and it seems is receiving good marking, i`m just not very sure about what (0) means...a port??:

Apr 19 09:40:34: %SEC-6-IPACCESSLOGP: list 102 permitted udp 1.1.1.1(0) -> 1.1.1.2 (0), 2 packets

Apr 19 10:49:05: %SEC-6-IPACCESSLOGP: list 101 permitted udp 1.1.1.1(5004) -> 1.1.1.2(5004), 1 packet

Apr 19 10:54:44: %SEC-6-IPACCESSLOGP: list 102 permitted udp 1.1.1.1(0) -> 1.1.1.2(0), 1002 packets

Apr 19 10:54:44: %SEC-6-IPACCESSLOGP: list 101 permitted udp 1.1.1.1(5004) -> 1.1.1.2(5004), 1018 packets

i can`t find any conf issue..can anyone give any ideas for troubleshooting?, thanks!!

2 REPLIES
New Member

Re: QoS (RPM)

OK, not much experience of MPLS. You do not say if the policy is working. i.e if you enter show pol int multi 2001 does it give you the class counts you are hoping for ? do you see packet drops in certain classes ?

anothet thing, in your classifying section you apply precedence for voice traffic but not for signalling. Would commend a precedent value of 5 with a bandwidth statement of some percent. (I have had similar problems to yours myself and using this solved call drops)

What is the WAN bandwidth value ?

Can be significant in your config. Good Luck !

New Member

Re: QoS (RPM)

Hi, thanks for the answer, yes , the policy is supposed to be working:

RPM#sh policy-map interface multilink 2001

Multilink2001

Service-policy output: QOS

Class-map: VOZ (match-any)

773079 packets, 44114342 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: ip dscp ef

773079 packets, 44114342 bytes

30 second rate 0 bps

Match: ip precedence 5

0 packets, 0 bytes

30 second rate 0 bps

Queueing

Strict Priority

Output Queue: Conversation 72

Bandwidth 50 (%)

Bandwidth 75 (kbps) Burst 1875 (Bytes)

(pkts matched/bytes matched) 773079/44114342

(total drops/bytes drops) 49/9996

Class-map: Signaling (match-all)

5 packets, 349 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: access-group name Signaling

Queueing

Output Queue: Conversation 73

Bandwidth 12 (%)

Bandwidth 18 (kbps) Max Threshold 64 (packets)

(pkts matched/bytes matched) 5/349

(depth/total drops/no-buffer drops) 0/0/0

Class-map: DataPlus (match-all)

0 packets, 0 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: ip dscp af22

Queueing

Output Queue: Conversation 74

Bandwidth 25 (%)

Bandwidth 37 (kbps) Max Threshold 64 (packets)

(pkts matched/bytes matched) 0/0

(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)

2462195 packets, 380288459 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 64

(total queued/total drops/no-buffer drops) 0/0/0

RPM#

Talking about the signaling, i`m using an ACL :

Extended IP access list Signaling

10 permit tcp any eq 1720 any (15615 matches)

20 permit tcp any any eq 1720 (344 matches)

In order to match these ports, the BW is a 128 kbps; and this problem only happens on an RPM with PPP, not with a normal router with CBWFQ with FR; everything seems to be OK, but the costumer`s config also seems OK..on an ACL that i put on the costumer`s Multilink i`m seeing that the packets are arriving matched; but the problem is still alive...any suggestions for test????, i`ll appreciate it...

136
Views
0
Helpful
2
Replies
CreatePlease login to create content