Cisco Support Community
Community Member

QoS & VoIP


I've a pb to match my VoIP trafic in the correct class-map.

The remote router has the ip set on his loopback.

Here is my conf :



class-map match-all VoIP

match access-group name VoIP

class-map match-all Data

match access-group name Data



policy-map POL1

class VoIP

priority 50

class Data

bandwidth 46





interface Loopback0

ip address





interface Serial3/0

bandwidth 128

ip address

service-policy output POL1




ip access-list extended VoIP

permit ip host host




When I place a call and do a "sh policy-map int s3/0" i can see that the VoIP trafic is not match in the correct class-map :

Service-policy output: POL1

Class-map: VoIP (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group name VoIP


Strict Priority

Output Queue: Conversation 40

Bandwidth 50 (kbps) Burst 1250 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

Class-map: Data (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group name Data


Output Queue: Conversation 41

Bandwidth 46 (kbps) Max Threshold 64 (packets)

(pkts matched/bytes matched) 0/0

(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)

726 packets, 52633 bytes

5 minute offered rate 4000 bps, drop rate 0 bps

Match: any

thks for ur ideas

Community Member

Re: QoS & VoIP


If you see the output you will notice that you matched all traffic in the class-default. Voice packets are RTP (UDP) packets. If you classify the traffic on the basis of UDP voice ports then you will the results. I am posting here a sample LLQ config. that would do the job for you. Hope this would help:

Sample LLQ Config:


The following example shows how to configure LLQ.

access-list 100 permit udp any any range 16384 32767

access-list 101 permit tcp any any eq 1720

access-list 102 permit tcp any any eq 80

access-list 103 permit tcp any any eq 23


class-map match-all voip

match access-group 100

class-map match-all voip-Control

match access-group 101

class-map match-all data1-Web

match access-group 102

class-map match-all data2-Telnet

match access-group 103


policy-map LLQ

class voip

priority 32

class voip-Control

bandwidth 8

class data1-Web

bandwidth 64

class data2-Telnet

bandwidth 32

class class-default



interface Serial1/0

bandwidth 256

service-policy output LLQ

In the example above, any traffic that matches ACL 100 will be classified as "class VoIP" (meaning

voice traffic) and given high priority up to 32 kbps.

- ACL 100 matches the common UDP ports used by VoIP

- ACL 101 matches the H.323 signaling traffic (TCP port 1720).

Class data1-Web matches web traffic (TCP port 80 as seen in Access List 102) and guarantees 64 kbps.

class data2-Telnet matches telnet traffic (TCP port 23 as seen in ACL 103) and guarantees 32 kbps.

The default class is configured to give an equal share of the remaining bandwidth to unclassified flows.

The policy is called "LLQ" and it is applied on outgoing traffic on Serial1/0, which has a

total bandwidth of 256 kbps.

Note By default, the total guaranteed bandwidth and priority bandwidth for all classes should be

less than 75 percent of the interface bandwidth. You can modify this percentage by issuing the

max-reserved bandwidth interface command.

Community Member

Re: QoS & VoIP

Thks for ur help

One more question :

Assuming that i'm going to have 4 simul. calls on my 128 kbps satellite link with the codec "codec g729r8 bytes 40" (a call will need 11.2 kbps bandwith with VAD); I would like to know the bandwith I had to set on my class VoIP for the UDP trafic and the bandwith for the class VoIP-control ?

Thanks again

CreatePlease to create content