Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

QoS

i want to separate my voice traffic and data traffic. can this config will suit to my objectives?please help me.please reply on john_dejesus@telwise.us

Router#config t

Router(config)#ip access-list extended VOIP

Router(config-nacl)#permit udp any any eq 2720

Router(config-nacl)#permit udp any any eq 5060

Router(config-nacl)#permit tcp 172.16.101.0 0.0.0.255 any eq 80

Router(config-nacl)#permit udp any any precedence priority

Router(config-nacl)#deny any any

Router(config-nacl)#exit

Router(config)#ip access-list extended Browsing

Router(config-nacl)#permit ip 192.168.111.0 0.0.0.127 172.16.172.64 0.0.0.31

Router(config-nacl)#permit ip 192.168.111.0 0.0.0.127 172.17.173.3 0.0.0.31

Router(config-nacl)#permit ip 192.168.111.0 0.0.0.127 172.16.172.49 0.0.0.15

Router(config-nacl)#deny ip 192.168.111.128 0.0.0.255 any any

Router(config-nacl)#exit

Router(config)#class-map VOIP

Router(config-cmap)#match access-group name VOIP

Router(config-cmap)#exit

Router(config)#policy-map policyVOIP

Router(config-pmap-c)#class VOIP traffic

Router(config-pmap-c)#ip precedence 5

Router(config-pmap-c)#exit

Router(config)#interface serial1

Router(config-if)#fair-queue

Router(config-if)#service-policy output policyVOIP

Router(config-if)#exit

Router(config)#interface ethernet0

Router(config-if)#ip access-group VOIP in

Router(config-if)#ip access-group Browsing in

Router(config-if)#service-policy input policyVOIP

Router(config-if)#exit

Router(config)#access-list 5 permit 192.168.111.0 0.0.0.127

Router(config)#line vty 0 4

Router(config-line)#access-class 5 in

ROuter(config-line)#exit

4 REPLIES

Re: QoS

Hi,

knowing nothing about your IP addresses and topology it is hard to tell, what your config will do. There are some pecularities however, which look "suspicious".

First, what is tcp port 80 doing in yout VoIP class? remove all data traffic, as this can severely degrade voice quality.

Second you should have a separate class for voip signaling and treat it as DATA with a certail minimum bandwidth guarantee.

Third, VoIP uses dynamically negotiated port numbers, which could deviate from the single port you define (is the ACL direction really right for your setup?).

Fourth, you should enable priority queueing for voip. This is achieved with the command "priority", f.e.

ip cef

policy-map policyVOIP

class VOIP traffic

ip precedence 5

priority percent 70

class VOIP-signal

bandwidth percent 5

ip precedence 3

interface serial1

bandwidth 768 !! set the real line speed in kbps here

In addition you could modify your class-maps to be sure to match voip:

class-map match-all VOIP

match protocol rtp audio

class-map VOIP-signal should match your specifiy signaling protocol (there are a couple of them).

And finally: have a look at auto qos voip. This usually gives the best results for voip, if you do not differentiate between different data applications (like it seems to me you are).

Hope this helps! Please rate all posts.

Regards, Martin

Community Member

Re: QoS

The topology would be ISP-->CiscoRouter-->Switch-->ip phones.

policy-map policyVOIP

class VOIP traffic

ip precedence 5***

priority percent 70***

class VOIP-signal

bandwidth percent 5***

ip precedence 3***

note:

***-can you further explain this to me, please bear with me coz this is my first time to configure a VoIP. So i am quite confused.

Community Member

Re: QoS

The IP precedence command marks traffic which matches your Class VOIPtraffic to 5 in the IP header.

IP Precedence is a legacy Layer 3 marking technology which has been superceded by marking using DSCP.

So, I would suggest you mark traffic like this :-

policy-map policyVOIP

class VOIP traffic

set ip dscp ef

priority percent 70***

class VOIP-signal

bandwidth percent 5***

set ip dscp cs3

Secondly, the priority percent command is reserving a percentage of your bandwidth as a strict priority queue which gets serviced before any other traffic. Cisco guidelines (from the Enterprise QoS SRND) specify you should not use more than 75% of your bandwidth for your QoS policy - reserving 25% for overhead & network control etc. The exact percentage you use depends on your topology but signalling is usually no more than 5%.

I would expect something like this instead :-

policy-map policyVOIP

class VOIP traffic

set ip dscp ef

priority percent 50

class VOIP-signal

bandwidth percent 5

set ip dscp cs3

So, the two queues take up <75% of your bandwidth.

HTH,

Paul.

Community Member

Re: QoS

ok i get it now.thanks for your help.

another question. re E1 R2 signaling, i'm using a 3745 Cisco router(OFFICE) and will connect it to PHILIPPINES TELCO then to US TELCO. they ask me to configure the r2 signaling. i used these configuration. my router has four E1 ports, 2 FastEthernet with no serial interfaces. with default gateway 205.5.75.17/30. and ip address 205.5.75.18/30. where i should put this address(205.5.75.18/30)? is it alright if i input it to the fa0/0 interface?and create a static default route to (205.5.75.17/30). i usually expect to put it on the serial interface, but since my router doesn't have one, are there any conflict with this. what are the fallbacks.thanks.

note: the ip addresses are just for example purposes.

Router(config)#controllers e1 1/0

Router(config-controller)#no framing crc4

Router(config-controller)#linecode hdb3

Router(config-controller)#clock source line primary

Router(config-controller)#cas-group 1 timeslots 1-31 type r2-digital r2-compelled ani -means caller id

Router(config-controller)#cas-custom 1

Router(config-ctlr-cas)#

173
Views
0
Helpful
4
Replies
CreatePlease to create content