Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

QOS

IOS Version 12.2(12a)

I need to implement QOS to Prioritize VOIP traffic.

Router has 2 interfaces

FastE 1

FastE 2

I have set up my Class map and policy map

I have tried to change class-default to fair-queue but nothing changes, it does not show in my config or when I do a show int.

Any sugestions on how to make this qos solution better?

Here is my config -

class-map match-any VOIP

match ip rtp 16384 16383

match access-group 100

match ip precedence 5

!

!

policy-map qos-policy

class VOIP

set ip precedence 5

class class-default

!

!

!

!

interface FastEthernet0

description WAN

full-duplex

!

interface FastEthernet1

description LAN

full-duplex

service-policy input qos-policy

!

access-list 100 permit udp any any eq 5060

access-list 100 permit udp any any eq 5061

Thanks,

7 REPLIES

Re: QOS

Dan,

Basically if you are looking to do classification only, then this should work. Now for the best practices. First off the signaling and media should be classified differently. Media is recommended to use EF, but I've been in shops using CS5. Signaling should be marked as CS3. Second, even on an ethernet medium, you should apply outbound queuing. Third fair-queue should be set on your class-default and you shouldn't try to classify best-effort traffic (which you aren't) since on nondistributed platforms only the class-default can fair-queue.

All of this is referenced in the QoS SRND. Definitely highly recommend reading that document.

http://www.cisco.com/application/pdf/en/us/guest/netsol/ns432/c649/ccmigration_09186a008049b062.pdf

Also the document above will discuss the ways to verify your QoS implementation. Briefly though you will use "show policy-map interface" to see the QoS policy stats.

Please rate any helpful posts

Thanks

Fred

New Member

Re: QOS

Thanks for the very helpful post-

I will definitely read the document, I have not ran across it before.

(if I understand this wrong I apologize)

-I will change signaling to CS5

-I should remove (set ip precedence 5) and (set dscp ef) on media

-set class-default to fair-queue

Couple questions-

When I try to set class-default to fair-queue it does not work, am I missing something?

Also when you say apply outbound queuing, what interface should I apply this to WAN?

Do I also keep the inbound queuing on the lan interface?

My goal is to have all voice packets sent before any other packets. When I make these changes this I assume will be happening?

Thank You,

New Member

Re: QOS

Also on my class-map config I have added

match ip dscp ef

some of my equipment on the lan side sets dscp ef on voice packets.

Re: QOS

Dan,

You shouldn't use CS5 for signaling but really this is going to depend on your WAN/LAN topology. Also currently you aren't queing on your input interface, just classifying. I see you have a Ethernet uplink, but where is that going to? We could better help you design a policy for your router if we knew more about your environment. Mainly QoS is something that is designed end-to-end, not applied to just one device. The key is to read the SRND and understand it. If you get to that point that will make your QoS Administration dramatically easier. Again though, post what your topology is and we can probably steer you in the right direction.

Thanks

Fred

New Member

Re: QOS

Sorry typo, I ment CS3 for signaling -

My ethernet uplink feeds into a 54mbs Wireless connection. From there it ends up at a core router where the internet connection resides (OC3) and (DS3).

I will be implementing this policy on the entire network end-to-end.

Thanks,

Re: QOS

Dan,

Ok so this starts to get a little more complicated. You should be safe using the generic guidelines documented in the SRND for QoS on your router and switches. But that document will not cover QoS on any Cisco wireless device by name. The Aironet devices running IOS should be very similiar to routers when configuring QoS, but I'm not sure, as I haven't implemented them yet. You will need to do more research on that device or maybe post what the device is and maybe someone can post a sample configuration.

Beyond that follow the SRND and apply the recommendations for your platforms with the understanding that it might not include ever platform but is a good overall reference document. Mainly stict to the Trusted endpoint model if you can, that way you will not have to do classification throughout. If you are unsure of the queuing sizes then use the generic percentage values.

Thanks

Fred

New Member

Re: QOS

The wireless gear is made by another manufacturer, there is a wireless link on both sides (lan) and (wan). I created a policy that shapes the traffic to the actual data rate that the wireless is capable of.

my new configuration -

(classification is done at the endpoints)

class-map match-any voip-signal

match ip dscp cs3

match ip dscp af31

class-map match-any voip-media

match ip dscp ef

!

!

policy-map qos-policy

class voip-media

bandwidth percent 75

class voip-signal

bandwidth percent 5

class class-default

fair-queue

policy-map shape-wan

class class-default

shape average 48800000

service-policy qos-policy

!

!

!

!

!

interface FastEthernet0

description WAN

bandwidth 48800

full-duplex

service-policy output shape-wan

!

interface FastEthernet1

description LAN

bandwidth 33000

#show int

FastEthernet0 is up, line protocol is up

Description: WAN

Queueing strategy: fifo

Shouldn?t the queue strategy change?

Should I apply the policy to both interfaces?

Any other suggestions?

Thanks again,

Dan-

256
Views
5
Helpful
7
Replies
CreatePlease to create content