Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Quality of service for prioritizing Voice by limiting Bandwidth

Dear Members,

I am trying to give priority to voice over other traffic by setting up a below test bed in my lab.

Voice receiver

Background receiver ---- Ethernet E0---- Router 1------Ethernet E 1----- Background traffic generator

Voice generator

Here Voice receiver, Background receiver and router 1's EO interface forms one Ethernet segment.

(Actually I am using three routers. But for easy debugging presently I am working with one router)

Router 1's E1 interface, Voice generator and background traffic generator form other Ethernet LAN.

I am limiting bandwidth of router E0 interface to 48kbps by below commands:

***********

I am sniffing at the interface E0 using Ethereal sniffer-protocol analyzer. But I am unable to get better results for voice application over background traffic. For both Testing without QoS and with QoS I am getting the same results.

FOR EVERY VOICE PACKET I GET ONE BACKGROUND PACKET- SAME RESULTS FOR BOTH WITH AND WITHOUT QOS DEPLOYED

***********

The voice application is generating at 32 kbps with packet size frame size of 876 bytes.

It uses UDP port no 60600. It uses TCP port# 8896 for connection activeness. I am using these details in my QoS configurations.

For initial testing, I am also generating background traffic also with 32kbps rate and frame size of 876 bytes.

Since total net traffic voice + background = 32 + 32 = 64 Kbps, so I am reducing the bandwidth of the interface using 'traffic shape' and 'rate-limit' commands.

Router 1:

Option 1:

Conf t

int e 0

rate-limit output 48000 6000 6000 conform-action transmit exceed-action drop

Option 2:

Conf t

int e 0

traffic-shape rate 48000 6000 6000 1000

I think with the above configuration, all traffic above 48000 bps are dropped.

So there are good chances that 24000 bps of both voice and data are sent, and remaining s 8000bps for both voice and background are dropped. So, therefore QoS does not come into picture because now total traffic is 48 but NOW actual interface bandwidth is 10 Mbps after the 'rate-limit' or 'traffic-shape' phase.

IS THERE OTHER WAY TO REDUCE THE BANDWIDTH OF THE ETHERnet

InTERFACE.?

My router configs for Priority queuing and class based weighted fair queuing

My Full router configuration:

Policy : Priority Queuing

ONE#show run

Building configuration...

Current configuration : 1279 bytes

!

hostname ONE

!

enable password xxxx

!

ip subnet-zero

no ip domain-lookup

!

!

!

!

!

interface Ethernet0

ip address 10.0.0.2 255.255.255.0

rate-limit output 48000 6000 6000 conform-action transmit exceed-action drop

priority-group 1

!

interface Ethernet1

ip address 10.10.0.1 255.255.255.0

!

!

ip classless

ip route 10.20.0.0 255.255.255.0 10.10.0.2

ip route 10.30.0.0 255.255.255.0 10.10.0.2

no ip http server

ip pim bidir-enable

!

priority-list 1 protocol ip high tcp 8896

priority-list 1 protocol ip high udp 60600

no cdp run

!

!

line con 0

escape-character BREAK

line aux 0

line vty 0 4

no login

!

end

+++++++++++

CLASS BASED WEIGTED FAIR QUEUING

ONE#show run

Building configuration...

Current configuration : 1279 bytes

!

hostname ONE

!

enable password xxxx

!

ip subnet-zero

no ip domain-lookup

!

!

class-map match-all voice

match access-group 101

!

!

policy-map catalyst

class voice

priority 36

class class-default

fair-queue 16

!

!

!

!

interface Ethernet0

ip address 10.0.0.2 255.255.255.0

rate-limit output 48000 6000 6000 conform-action transmit exceed-action drop

service-policy output catalyst

!

interface Ethernet1

ip address 10.10.0.1 255.255.255.0

!

interface Serial0

ip address 10.10.10.10 255.255.255.0

!

interface Serial1

ip address xx.xx.xx.22 255.0.0.0

!

ip classless

ip route 10.20.0.0 255.255.255.0 10.10.0.2

ip route 10.30.0.0 255.255.255.0 10.10.0.2

no ip http server

ip pim bidir-enable

!

access-list 101 permit udp any any eq 60600

access-list 101 permit tcp any any eq 8896

no cdp run

!

!

line con 0

escape-character BREAK

line aux 0

line vty 0 4

no login

!

end

++++

Please explain me possible changes in my config/testbed and any suggestion.

Thanks in Advance,

Vijay

2 REPLIES
Silver

Re: Quality of service for prioritizing Voice by limiting Bandwi

You can verify the configuration accurateness with the examples given in the support pages given below:

Voice Quality

http://www.cisco.com/pcgi-bin/Support/browse/psp_view.pl?p=Internetworking:Voice:QoS&viewall=true

QoS (Quality of Service)

http://www.cisco.com/pcgi-bin/Support/browse/index.pl?i=Technologies&f=1387

New Member

Re: Quality of service for prioritizing Voice by limiting Bandwi

Hi Vijay, this may be an old post, but I just found it so I thought I would reply.

I think there may be a couple of problems. The first is that policing is performed before queuing, so your rate limit will cut the traffic down to 48K before you prioritise. See the document:

http://www.cisco.com/en/US/customer/tech/tk543/tk757/technologies_tech_note09186a0080160fc1.shtml

Secondly, if you have two generaters sending packets at the same rate, of course you will see one of each packet in turn. You probably will never get congestion on the link.

try a GTS configuration with CBWFQ, and see if it does what you want. Sample config:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t2/clsbsshp.htm#54265

and

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t2/clsbsshp.htm#51807

226
Views
0
Helpful
2
Replies