Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
lkc
New Member

SIP authentication with CSPS

I have got a major problem with my ATA and SIP Proxy Server setup. Whenever i try to enable authentication on the proxy server my ATA registrations drop immediately.

My protocol analyzer shows me that the registration is getting a 401 unauthorized (although the user is registered within the CSPS). Should i not get a 407 BTW from a proxy server when i'm being denied authentication ??

My ATA setup is pretty simple (using UID0 and PWD0), UseLoginID set to 0.

The error.log on the CSPS tells me that:

[Sat Mar 20 15:26:39 2004] mod_sip_authen.c(837) Digest

aff57e1b652bd5a5af59cf52d0a87fbc, Response f1857a54cbcef3d7127521a0d6ed220a

[Sat Mar 20 15:27:10 2004] mod_sip_authen.c(254) Auth: can't get domain for

user 88273888 in the AUTHORIZATION header. Try to get it from the FROM header

instead.

[Sat Mar 20 15:27:10 2004] mod_sip_authen.c(278) Auth: got domain for user

88273888 in the FROM header: flubber.no

[Sat Mar 20 15:27:10 2004] mod_sip_authen.c(811) HA1 is

e174c9bcc2586ea49b7b685c37951472

[Sat Mar 20 15:27:10 2004] mod_sip_authen.c(822) qop is auth-int, HEntity is

d41d8cd98f00b204e9800998ecf8427e

[Sat Mar 20 15:27:10 2004] mod_sip_authen.c(837) Digest

f83d3d907c8c8191e1652c283a44b96e, Response 681429e1babeae7ef78ee6a372e7df8f

[Sat Mar 20 15:27:10 2004] mod_sip_authen.c(811) HA1 is

e174c9bcc2586ea49b7b685c37951472

[Sat Mar 20 15:27:10 2004] mod_sip_authen.c(822) qop is auth-int, HEntity is

d41d8cd98f00b204e9800998ecf8427e

[Sat Mar 20 15:27:10 2004] mod_sip_authen.c(837) Digest

e328ee4113dd376943864df5e6b09db9, Response f27ab799ff0785477df85311328069b1

X-lite registers just fine !

I have never seen that before !

Any hints or pointers here ? Since i cannot seem to find the solution anywhere (apart from disabling authentication which i do not want to do:-))

Regards

Lasse

3 REPLIES
Silver

Re: SIP authentication with CSPS

Check if you are hitting the bug CSCec54698

lkc
New Member

Re: SIP authentication with CSPS

It may very well be ! but i cannot see the bug in bug tracker.

New Member

Re: SIP authentication with CSPS

You say you were able to get x-lite to register fine. Can you share how you set this up?

I've tried numerous settings and cannot get my x-lite to connect.

Thank you.

119
Views
0
Helpful
3
Replies
CreatePlease to create content