Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Troubleshooting ISDN call in a 5400 Gateway

Hi, I am looking for the best way to troubleshooting ISDN calls, made from a AS5400HPX. The links are 16 E1´s which are multiplexed into a DS3 pipe, to end into 16 lines also. The E1 lines are configured to be PRI. Currently, I am having issues with the calls connectivity. The customer is telling me, that the call are not complete because we are sending the NOA equal to 17.

Please advice, regards,

Hector

6 REPLIES
New Member

Re: Troubleshooting ISDN call in a 5400 Gateway

Hi!

Do you really have "ISDN calls" or you have some ss7 call agent and sending calls using ss7 signalization? Can you post your AS5400 config?

Regards,

Ivan

New Member

Re: Troubleshooting ISDN call in a 5400 Gateway

Hi!

If you really have an ISDN, you could troubleshoot this problem using "debug isdn q931".

You should be able to change NOA using voice translation rule (like this):

ISDNtest(cfg-translation-rule)#rule 1 /.*/ /\1/ type any ?

abbreviated Abbreviated numbering type

international International numbering type

national National numbering type

network Network numbering type

reserved Reserved numbering type

subscriber Subscriber numbering type

unknown Unknown numbering type

So you could do something like this:

voice translation-rule 1

rule 1 /^.*/ /\1/ type any subscriber plan any national

!

voice translation-profile NoaChange

translate called 100

translate calling 100

!

dial-peer voice 1 pots

translation-profile outgoing NoaChange

destination-pattern 123....

forward-digits all

Regards,

Ivan

New Member

Re: Troubleshooting ISDN call in a 5400 Gateway

Hi!

I made an error here - it should be:

voice translation-rule 100

Hope this helps,

Ivan

New Member

Re: Troubleshooting ISDN call in a 5400 Gateway

Thanks for the rule, Ivan.

I am attaching the configuration file.

Hector!!!

New Member

Re: Troubleshooting ISDN call in a 5400 Gateway

Hector,

the translation rule should help you. Did you try it? Please let me know if it helps. If still does not help, post "debug isdn q931" output of a call.

Ivan

New Member

Re: Troubleshooting ISDN call in a 5400 Gateway

Hi Ivan,

Well, before trying your rule, I found another way to do the same:

!

interface Serial6/5:15

no ip address

isdn switch-type primary-net5

isdn incoming-voice modem

isdn map address . plan isdn type international

no cdp enable

!

This also corrected the NOA.

With this we were able to send traffic without having the issue with the NOA at the far end. I am still testing to verify that everything is working fine.

Regards,

Hector!!!

393
Views
0
Helpful
6
Replies
CreatePlease login to create content