Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Using some timeslots in a pri-group

Hi. We had a R2 signaling configuration, in which we used ds0-groups to specify the use of only some timeslots, like this:

controller E1 1

framing NO-CRC4

ds0-group 2 timeslots 1-2 type r2-digital r2-compelled ani

ds0-group 3 timeslots 3-15,17-19 type r2-digital r2-compelled ani

ds0-group 4 timeslots 20-23,30-31 type r2-digital r2-compelled ani

cas-custom 2

We migrated to SS7 signaling (AS5400 with PGW). We used pri-groups and it's working OK. But now we need to specify the use of only some timeslots per customer (kinda like the R2 config above), but with pri-groups we can't do this. I think the solution will be using trunk-groups, maybe like the following:

trunk group CUSTOMER1

description B Channels reserved for Emergency Calls

!

controller E1 6/0

framing NO-CRC4

pri-group timeslots 1-31 nfas_d primary nfas_int 0 nfas_group 0

trunk-group CUSTOMER1 timeslots 1-2

trunk-group CUSTOMER2 timeslots 20-31

!

controller E1 6/1

framing NO-CRC4

pri-group timeslots 1-31 nfas_d none nfas_int 1 nfas_group 0

!

interface Serial6/0

no ip address

!

interface Serial6/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-ni2c

isdn incoming-voice modem

isdn rlm-group 1

no isdn send-status-enquiry

isdn negotiate-bchan resend-setup

!

voice-port 6/0:D

!

!

!

dial-peer voice 7099 voip

destination-pattern xxxxx

progress_ind setup enable 3

voice-class codec 1

session target ipv4:xxxxx

!

dial-peer voice 9999 pots

trunkgroup CUSTOMER1

huntstop

destination-pattern xxxxx

progress_ind setup enable 3

direct-inward-dial

port 6/0:D

!

Would this work? Do we have to change something in the PGW in order to make this config work? Any help would be very appreciated.

2 REPLIES

Re: Using some timeslots in a pri-group

Community Member

Re: Using some timeslots in a pri-group

Thanks marwanshawi.

We configured the solution so a customer would use only two timeslots, and it works ok when there are just two calls, but when the third call tries to connect, it should receive a busy tone or something like that, but that's not happening, instead of that, we get a message like this "the number you dial don't exist, please try again".

Any hint on what's going on? is there something we could do on the AccessServer or the PGW ? Thanks in advance.

197
Views
4
Helpful
2
Replies
CreatePlease to create content