Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Voice Vlan help

HI All,

I need your expertise on following questions, I appreciate in advance for your time

We just purchased cisco 2960 for our VoIP needs and we are using polycom phones,  and Phone and Computer will use same port.

Since Polycom phones are capable working with CDP protocol and we are hoping to get another switch to expand VoIP network.

I found easiest way of setting up each port is as following (from the cisco tutorial)

Switch#configure terminal
Switch(config)#mls qos
Switch(config)#interface fastethernet 0/1
Switch(config-if)#mls qos trust cos
Switch(config-if)#switchport voice vlan dot1p
Switch(config-if)#switchport voice vlan 10

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 20

Switch(config-if)#exit

My first question,when we are using switchport voice vlan dot1p ,I thought we instruct the switch port to use 802.1P priority tagging
for voice traffic and to use the default native VLAN (VLAN 0) to carry  all traffic.Do I still need to create a Vlan 20 for data and Vlan 10 for voice ?

Secondly,same tutorial adds these commands as well,Do you think for our set up, using those commands are feasible ?
Switch(config-if)#switchport priority extend trust
Switch(config-if)#priority-queue out
Switch(config-if)#spanning-tree portfast
Switch(config-if)#spanning-tree bpduguard enable
Switch(config-if)#exit

Thirdly,when we get another switch and do the same configuration for the second switch, can I use any port on Switch 1 as uplink without doing any configuration ?

Thank you for your time.











Everyone's tags (3)
1 REPLY

Voice Vlan help

First answer

The command "switchport mode access" instructs the switch to use 802.3 frame (untagged frame, no vlan).

The command "switchport mode trunk" instructs the switch to use 802.1q frame (tagged frame, vlan).

The command "switchport voice vlan dot1p" instructs the switch to use 802.1p priority tagging for voice.  802.1p resides within the 802.1q header so the swtich port is in an "hybrid" mode and can handle both frames (tagged and untagged). Voice traffic will be put in a tagged 802.1q frame with the voice vlan and so the voice vlan should be declared with the command "switchport voice vlan". The CDP will inform the neighbor device of this configuration.

All other (not tagged) data traffic will be put in the native vlan. The vlan 0 is reserved and used only for internal processes. So you must declare also a native vlan. (If you configure an access ports where the voice and data reside on the same vlan, with no explicit configuration for a voice vlan, the phone will tag the voice frame with dot1q and insert a vlan of zero telling the switch they are only using dot1p and that the frame belongs to the native vlan).

Second answer

Yes.

"Priority" commands work in conjunction with QoS. If you have enable QoS at global level you get advantage during the use.

"Spanning tree" commands enable protection against unwanted incoming BPDU and set the port in forwarding state in few seconds. You can search the exact function in the IOS reference guide.

Third answer

Yes.

Same config also for the second switch. You can use all ports indifferently.

I suggest you to use an 802.1q trunk to connect switches. something like this:

switchport mode trunk

switchport trunk allowed vlan 10,20

mls qos trust cos

priority-queue out

Regards.

1762
Views
0
Helpful
1
Replies