Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

VOIP and NAT problem

Dear All,

have 2 IP-phones connected to C2621 with the below configuration the problem that, the phones used 10.0.0.25 and 10.0.0.26 and both is NATED on the 2600 router, also both registered in international SIP server but thay can not make calls even between each other, But when i trying to using static NAT (Private--> Real IP) everything working fine but i can not deticate IP for each phone and now the problem due to NAT so anybody could help in that, HOw can i use NAT but in the same time the phones working because it's seems that the NAT port changes it the reason behind the problem

Seef-HQ#sh run

Building configuration...

Current configuration : 1596 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Seef-HQ

!

logging buffered 4096 debugging

enable secret xxxx

!

ip subnet-zero

ip cef

!

!

ip name-server 195.219.14.20

ip name-server 64.85.63.6

!

!

!

voice rtp send-recv

!

voice service voip

sip

!

voice class codec 1

codec preference 1 g711ulaw

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

!

!

!

!

interface FastEthernet0/0

ip address 217.X.X.X 255.255.255.240

ip nat outside

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 10.0.0.1 255.255.255.0

ip nat inside

duplex auto

speed auto

!

ip nat pool LAN 217.X.X.X 217.X.X.X prefix-length 28

ip nat inside source list 10 pool LAN overload

ip nat inside source static tcp 10.0.0.113 80 interface FastEthernet0/0 9999

ip nat inside source static 10.0.0.4 217.X.X.Y

ip nat inside source static 10.0.0.3 217.X.X.Z

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 217.X.X.X

!

!

access-list 10 permit 10.0.0.0 0.0.0.255

!

!

!

!

!

!

dial-peer voice 1 voip

session protocol sipv2

session target ipv4:67.X.X.X

session transport udp

!

sip-ua

nat symmetric role active

nat symmetric check-media-src

retry invite 2

retry response 2

retry bye 2

retry cancel 2

sip-server ipv4:67.X.X.X

--

Best Reagrds,

Mounir Mohamed

1 REPLY
New Member

Re: VOIP and NAT problem

Make sure that registration happens (Signaling part works), also you can try configuring stun server address in IP phone (For Media Transmission).

Ritesh

204
Views
0
Helpful
1
Replies
CreatePlease login to create content