Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Voip call will wait long time (12 seconds) to get ring back tone

hi,

I setup 2* 3725 with alcatel PABX (T1 cas).the voip call is fine. But the problem is that we required to wait 12 seconds to hear the ring back tone.

attached configuration.

best regards.

fred.

TTNTaiwanQuanta#s run

Building configuration...

Current configuration : 5003 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname TTNTaiwanQuanta

!

logging buffered 4096 debugging

enable password ttnnet!

!

username hongson password 0 hongson

clock timezone Taiwan 8

voice-card 1

!

ip subnet-zero

!

!

!

!

!

voice call carrier capacity active

voice rtp send-recv

voice dsp auto-reset

!

voice service voip

!

!

!

!

!

!

!

!

!

mta receive maximum-recipients 0

!

controller E1 1/0

framing NO-CRC4

ds0-group 1 timeslots 1-15,17-30 type e&m-immediate-start

cas-custom 1

!

controller E1 1/1

framing NO-CRC4

ds0-group 1 timeslots 1-15,17-30 type e&m-immediate-start

cas-custom 1

!

!

!

!

interface Loopback0

ip address 192.168.248.250 255.255.255.255

!

interface Multilink1

ip address 10.10.10.1 255.255.255.252

ip tcp header-compression iphc-format

fair-queue 64 32 4

traffic-shape group 106 1300000 31200 31200 1000

no cdp enable

ppp multilink

ppp multilink fragment-delay 25

ppp multilink interleave

multilink-group 1

ip rtp header-compression iphc-format

!

interface FastEthernet0/0

ip address 192.168.66.248 255.255.255.0

ip accounting output-packets

no ip route-cache

no ip mroute-cache

duplex auto

speed auto

no cdp enable

!

interface Serial0/0

description TTN IPLC Taiwan to china E1

ip address 192.168.248.1 255.255.255.252

encapsulation ppp

no ip route-cache

no ip mroute-cache

load-interval 30

no keepalive

no fair-queue

no cdp enable

ppp multilink

multilink-group 1

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

no cdp enable

!

interface Serial0/1

description TTN VSAT BACKUP IPLC 512K

bandwidth 1024

ip address 192.168.248.5 255.255.255.252

encapsulation ppp

no ip mroute-cache

priority-group 1

no cdp enable

ppp multilink

multilink-group 1

!

router rip

passive-interface Serial0/0

passive-interface Serial0/1

network 192.168.25.0

network 192.168.66.0

network 192.168.244.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.66.254

ip route 172.16.0.0 255.240.0.0 10.10.10.2

ip route 172.20.251.200 255.255.255.255 10.10.10.2

ip http server

!

!

access-list 102 permit tcp any any eq ftp

access-list 102 permit tcp any any eq ftp-data

access-list 102 permit tcp any any eq www

access-list 102 permit udp any any eq tftp

access-list 103 permit ip host 192.168.19.19 any

access-list 103 permit ip host 192.168.10.19 any

access-list 103 permit ip host 192.168.11.19 any

access-list 103 permit ip host 192.168.22.19 any

access-list 103 permit ip host 192.168.29.19 any

access-list 103 permit ip host 192.168.34.19 any

access-list 103 permit ip host 192.168.231.19 any

access-list 103 permit ip host 192.168.232.19 any

access-list 103 permit ip host 192.168.235.19 any

access-list 103 permit ip host 192.168.236.19 any

access-list 103 permit ip host 192.168.237.19 any

access-list 103 permit ip host 192.168.248.250 host 172.16.251.200

access-list 105 permit icmp any any

access-list 105 permit tcp any any eq telnet

access-list 105 permit udp any any eq snmp

access-list 105 permit udp any any eq snmptrap

access-list 106 deny ip host 192.168.248.250 host 172.20.251.200

access-list 106 deny ip host 192.168.19.19 any

access-list 106 deny ip host 192.168.10.19 any

access-list 106 deny ip host 192.168.11.19 any

access-list 106 deny ip host 192.168.22.19 any

access-list 106 deny ip host 192.168.29.19 any

access-list 106 deny ip host 192.168.34.19 any

access-list 106 deny ip host 192.168.231.19 any

access-list 106 deny ip host 192.168.232.19 any

access-list 106 deny ip host 192.168.235.19 any

access-list 106 deny ip host 192.168.236.19 any

access-list 106 deny ip host 192.168.237.19 any

access-list 106 permit ip any any

priority-list 1 protocol ip high list 105

priority-list 1 protocol ip high list 103

priority-list 1 default low

priority-list 1 queue-limit 100 250 500 1000

no cdp run

!

route-map www-ftp permit 10

match ip address 102

!

!

call rsvp-sync

!

voice-port 1/0:1

define Tx-bits idle 0101

define Rx-bits idle 0101

no ignore rx-b-bit

echo-cancel coverage 32

cptone FR

timeouts interdigit 2

timeouts call-disconnect 1

!

voice-port 1/1:1

define Tx-bits idle 0101

define Rx-bits idle 0101

no ignore rx-b-bit

echo-cancel coverage 32

cptone FR

timeouts interdigit 2

timeouts call-disconnect 1

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 4 pots

destination-pattern 54

port 1/1:1

!

dial-peer voice 5 pots

destination-pattern 68

!

dial-peer voice 6005 voip

destination-pattern 37T

session target ipv4:172.20.251.200

dtmf-relay cisco-rtp

req-qos controlled-load

fax rate 9600 bytes 48

ip qos dscp cs7 media

no vad

!

dial-peer voice 1 pots

destination-pattern 54

port 1/0:1

!

!

line con 0

line aux 0

exec-timeout 0 0

login local

modem InOut

modem autoconfigure discovery

transport input all

autoselect during-login

autoselect ppp

stopbits 1

flowcontrol hardware

line vty 0 4

exec-timeout 0 0

password cisco

login

!

end

  • Voice over IP
1 REPLY
New Member

Re: Voip call will wait long time (12 seconds) to get ring back

The longer than expected post-dial delay could be incurred by the interdigit timeout due to the command destination-pattern 37T. The "T" option instructs VoIP GW to wait for 10 seconds before completing digit collection. Try destination-pattern 37....(actual number of dots depends on the number of digits in the number)to remove interdigit timeout

308
Views
0
Helpful
1
Replies
This widget could not be displayed.