Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

3905 handsets and LLDP

Hi everyone.

I am having an issue with a 3905 handset connecting to a BE3000 running 8.6.4. All of the other handsets I have tried receive their VLAN ID via LLDP and connect to the system without any problem. The 3905, however, will not. It seems that when LLDP is enabled the handset always shows VLAN4095 in its configuration and does not pick up the VLAN ID that is being specified by the switch via LLDP.

I have manually set the Admin VLAN of the handset to 2, but according to the manual this setting will only become active if the phone does not receive any VLAN information from LLDP. With LLDP active on the switch this setting is ignored which shows that the handset is receiving something from the switch but perhaps not interpreting it correctly. If I disable LLDP (or set it to receive only) on the port that the 3905 connects to the admin VLAN comes into effect and the handset connects to the system. If I enable LLDP again the handset will not connect.

All handsets are connected to the same Cisco 300 series small business switch running the latest firmware (at the time of opening this post). The other types of handsets I’ve tried all work correctly with LLDP, but the 3905 must be connected to a port where LLDP is disabled (or set to Rx only) to connect to the system if you wish to specifiy a tagged VLAN ID.

Has anyone else experienced this issue?

Many thanks.

Everyone's tags (3)
13 REPLIES
New Member

Re: 3905 handsets and LLDP

I have some further information..

If I enable LLDP on the switch port that connects to the 3905 the handset shows VLAN 4095 in the Operational VLAN ID, my Admin VLAN ID setting is ignored and the handset will not connect on the tagged VLAN 2 port. If I configure the switch port onto VLAN 2 (untagged) the phone connects, which suggests the handset is not tagging its traffic.

If I disable LLDP on the switch port that connects to the 3905 and set it to VLAN 2 (tagged) the handset will use the Admin VLAN ID which I've configured as 2 and it will connect to the system. Interestingly, in this setup the handset shows Operational VLAN ID 2, but this may simply be because it has taken my Admin VLAN ID setting.

I should have mentioned as well, the phones I am testing with all have static IP addresses so I have no DHCP to worry about in these tests.

I've also obtained logs from the handset's web management pages, the parts that appear relevant are below:

With LLDP activated on the switch port:

16:31:13:871 x [SW] switchConf_confVlan(), type: 1, voice: 4095, native: 1
16:31:13:872 x [SW] swConfVlan(), nVoiceVID: 4095, nNativeVID: 1, Freezed: 0
16:31:13:903 x [SW] swConfVlan(), No Voice Vlan
16:31:13:905 x [SW] switchConf_confVlan(), SW_VLAN_OPERA_TYPE_LLDPCDP
16:31:13:905 x [CENTRAL] State transit REGISTERING --> CONFIGURING_IP
16:31:13:906 x [CENTRAL] Begin to config ip
16:31:13:923 x [CENTRAL] IP Address = 192.168.2.200
16:31:13:924 x [CENTRAL] Netmask    = 255.255.255.0
16:31:13:924 x [CENTRAL] Gateway    = 192.168.2.252

With LLDP deactivated on the switch port:

16:33:39:571 x [SW] switchConf_confVlan(), type: 1, voice: 2, native: 1
16:33:39:572 x [SW] swConfVlan(), nVoiceVID: 2, nNativeVID: 1, Freezed: 0
16:33:39:661 x [SW] switchConf_confVlan(), SW_VLAN_OPERA_TYPE_LLDPCDP
16:33:39:662 x [CENTRAL] State transit REGISTERING --> CONFIGURING_IP
16:33:39:663 x [CENTRAL] Begin to config ip
16:33:39:680 x [CENTRAL] IP Address = 192.168.2.200
16:33:39:680 x [CENTRAL] Netmask    = 255.255.255.0
16:33:39:681 x [CENTRAL] Gateway    = 192.168.2.252

Bronze

Re: 3905 handsets and LLDP

Hi Craig

Have you tried LLDP-MED. According to 3905 documentation,3905 requires LLDP-MED for voice vlan configuration.

http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/3905/8_6/english/admin_guide/3905admin_921.pdf

Thanks

New Member

Re: 3905 handsets and LLDP

Hi Sanjay,

I've checked the switch and LLDP-MED is enabled on all of the ports.

Thanks.

Cisco Employee

3905 handsets and LLDP

Hi Craig,

Do you mean you set voice vlan id = 2 on Switch port that 3905 phone is connected?

Coud you paste the output of command "show run" on your switch?

I can try it on my testbed.

Thanks,

Ning

New Member

Re: 3905 handsets and LLDP

The switch is configured with auto voice VLAN enabled, with a VLAN ID of 2.

Running config is shown below. The 3905 handset is connected on port 4 where LLDP is set to receive only. Any other handset in this port works fine with LLDP set to Tx and Rx.

config-file-header
switch0da7e6
v1.2.5.70 / R750_NIK_1_2_584_002
CLI v1.0
file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
spanning-tree priority 4096
vlan database
vlan 2-5,100
exit
voice vlan id 2
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
bonjour interface range vlan 1
ip access-list extended ACL01
permit tcp 192.168.2.249 0.0.0.0 any 192.168.0.252 0.0.7.0 www
deny tcp 192.168.2.0 0.0.0.255 any 192.168.0.252 0.0.7.0 www
permit ip any any
exit
hostname switch0da7e6
management access-list SecureAccess
permit ip-source 192.168.1.0 mask 255.255.255.240
permit ip-source 192.168.2.0 mask 255.255.255.240
permit ip-source 192.168.3.0 mask 255.255.255.240
permit ip-source 10.1.1.0 mask 255.255.255.240
exit
management access-class SecureAccess
passwords aging 0

ip ssh server
!
interface vlan 1
ip address 192.168.1.252 255.255.255.0
no ip address dhcp
!
interface vlan 2
name BE3000
ip address 192.168.2.252 255.255.255.0
!
interface vlan 3
name UC320
ip address 192.168.3.252 255.255.255.0
!
interface vlan 4
name UC540BRI
ip address 192.168.4.252 255.255.255.0
!
interface vlan 5
name UC540FXO
ip address 192.168.5.252 255.255.255.0
!
interface vlan 100
name UC320Phones
ip address 10.1.1.252 255.255.255.0
!
interface gigabitethernet2
switchport trunk native vlan 2
!
interface gigabitethernet3
switchport trunk allowed vlan add 100
switchport trunk native vlan 3
no macro auto smartport
!
interface gigabitethernet4
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 2
no lldp transmit
macro description ip_phone_desktop
!next command is internal.
macro auto smartport dynamic_type ip_phone_desktop
!
interface gigabitethernet5
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 2
macro description ip_phone_desktop
!next command is internal.
macro auto smartport dynamic_type ip_phone_desktop
!
interface gigabitethernet6
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 2
macro description ip_phone_desktop
!next command is internal.
macro auto smartport dynamic_type ip_phone_desktop
!
interface gigabitethernet11
switchport trunk native vlan 100
no cdp enable
no macro auto smartport
!
interface gigabitethernet12
switchport trunk native vlan 100
no cdp enable
no macro auto smartport
!
interface gigabitethernet16
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 2
macro description ip_phone_desktop
!next command is internal.
macro auto smartport dynamic_type ip_phone_desktop
!
interface gigabitethernet17
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 2
macro description ip_phone_desktop
!next command is internal.
macro auto smartport dynamic_type ip_phone_desktop
!
interface gigabitethernet23
switchport trunk native vlan 100
no cdp enable
no macro auto smartport
!
interface gigabitethernet24
switchport trunk native vlan 100
no cdp enable
no macro auto smartport
!
interface gigabitethernet27
channel-group 1 mode auto
!
interface gigabitethernet28
channel-group 1 mode auto
!
interface Port-channel1
speed 1000
!

Cisco Employee

Re: 3905 handsets and LLDP

Hi Craig,

According to design, phone can get voice vlan id from LLDP/CDP packets sent by switch.

Admin vlan ID is only used when phone is connected to a Switch that doesn't support LLDP and CDP.

I only use Cisco catalyst switch during testing, so i am not very clear about your switch configuration. I have some questions here:

1) is CDP enabled on your switch port gi0/4?

2) can you enable both LLDP and CDP on gi0/4 and then check phone's behavior?

2) can you capture a wireshark trace on switch or on phone?

New Member

Re: 3905 handsets and LLDP

I will get the switch team to take a look at this.

New Member

Re: 3905 handsets and LLDP

Ning, In reply to your questions...

1) is CDP enabled on your switch port gi0/4?

Yes.

2) can you enable both LLDP and CDP on gi0/4 and then check phone's behavior?

The original problem I explained was when both CDP and LLDP were running on the port.

2) can you capture a wireshark trace on switch or on phone?

I can, but I'm not in a position to do this right now.

Navin, thanks, I'll look forward to hearing what they say. Do you need any other information from me?

I'm going to be away from the office for the next week so my replies may be slow from tonight.

I've also noticed a typo in my original post - we're using 8.6.3 not 8.6.4 as I originally suggested.

New Member

3905 handsets and LLDP

Has anybody found the resolve for this issue... ?

I have the same problem... with my 3905's and an SF300 and 500 version.

Cisco Employee

3905 handsets and LLDP

Hi,

Could you send a wireshark trace to nyuan@cisco.com?

Thanks,

Ning

New Member

3905 handsets and LLDP

Hi,

I have the same problem with my SF300 and phones 3905.

Cisco Employee

3905 handsets and LLDP

Hi,

We have fixed this issue in release 9-2-2ES2.

Below is the bug info for your reference:

CSCub09465

CP-3905 fails to configure voice VLAN via LLDP-MED

CP-3905 is connected to Cisco Small Business SF300-24P. LLDP-MED is enabled in the switch port with a network policy advertising the voice VLAN. 
CP-3905 fails to learn and change the operational VLAN value from 4095 to the advertised vlan id. Please see attached packet captures. The phone advertises its own capabilities and the switch replies back with the network policy. It seems that CP3905 is not processing it. 
After disabling LLDP Tx in the switch port, CP3905 learns the vlan id via CDP.
I am not sure whether this is relevant or not. I compared both CP-6941  and CP-3905 Admin settings > Network setup. Both have 9 options. 6941 9th option indicates LLD is enabled where  3905 does not include LLDP configuration option.
New Member

We are facing the same issue

We are facing the same issue in one of our installations.

From cisco software download site i dont see any 9-2-2ES2 version.

i see only 

cmterm-3905-qed.9-2-2-0.cop.sgn

5328
Views
5
Helpful
13
Replies
CreatePlease to create content