Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

504g issue with GPick

hi guys,

Having a strange oneway audio problem with 504g phones hosted on broadworks. Phones are running 7.4.9c software. We deploy two types of codec priorities for different scenarios.

Phone 1:

<Preferred_Codec_1_ ua="na">G729a</Preferred_Codec_1_>

  <Use_Pref_Codec_Only_1_ ua="na">No</Use_Pref_Codec_Only_1_>

  <Second_Preferred_Codec_1_ ua="na">G722</Second_Preferred_Codec_1_>

  <Third_Preferred_Codec_1_ ua="na">G711a</Third_Preferred_Codec_1_>

Phone 2:

<Preferred_Codec_1_ ua="na">G722</Preferred_Codec_1_>

  <Use_Pref_Codec_Only_1_ ua="na">No</Use_Pref_Codec_Only_1_>

  <Second_Preferred_Codec_1_ ua="na">G729a</Second_Preferred_Codec_1_>

  <Third_Preferred_Codec_1_ ua="na">G711a</Third_Preferred_Codec_1_>

When phone 1 dials into the system and phone2 picks up the call through grouppickup (by dialing *98 for example), phone 1 is not able to hear anything but there is audio on phone 2. Looking at the sip trace when phone 2 dial in (with g722 priority) server OKs the call with g722. And the reinvite sent back to phone1 to connect the audio has sdp ( payload 9 8 18) and phone1 OK the call with g729 where the other side of the call was g722.

phone1 invite (payload 18 9 8) --> broadworks

phone 1 <-- 200OK from broadworks (payload 18)

phone2 invite (payload 9 8 18) --> broadworks (group pick dialing *98)

phone 2 <-- 200OK from broadworks (payload  9)

phone1 <-- reinvite from broadworks ( 9 8 18)

phone1 200 OK (payload 18) --> broadworks

phone2 can hear, but phone 1 has no audio since it is negotiated g729 but not g722 even if the reinvite has priority 9.

I'm wondering why phone2 sends 200 OK with 18 and not 9 when it received reINVITE for 9. Other phone (polycoms and aastras) works fine as it 200 OKs the call with payload 9 after the reinvite from broadworks. I dont want to use  Use_Pref_Codec_Only.

Any thoughts?

thanks

Rakesh

1 ACCEPTED SOLUTION

Accepted Solutions
Community Member

504g issue with GPick

I will bet that you have the following parameter on your configuration file:

Yes

Set the parameter to:

No

and retry the test. I already have passed through a similar situation.

Joao

2 REPLIES
Community Member

504g issue with GPick

I will bet that you have the following parameter on your configuration file:

Yes

Set the parameter to:

No

and retry the test. I already have passed through a similar situation.

Joao

Community Member

504g issue with GPick

Hi Joao

Thanks for your help! Looks like that fixed it! :-)

cheers

Rakesh

775
Views
0
Helpful
2
Replies
CreatePlease to create content