Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

7965 on UC560 - small GUI / font issue

Hi Folks,

I recently swapped two older phones for newer 7965s. Configuration was done through CCA.

As long as the phones were not provisioned their GUI looked better then after provisioning them.

Basically the font within the soft-key-labels is noticable smaller when they are provisioned. Also the string which is shown in the lower left corner (to display the company name or whatever you want) is a lot more narrow so the single letters are mashed into each other.

Without provisioning the phones that said string line also had a nice darkened background which made it easier to read in front of light background-images.

After provisioning both phones - one phone still has the darker-lines (also for the lines with active lines) the other phone is missing them completely.

Both phones have the issue with the smaller font in the soft keys and the letter-mashing in the string on the lower left.

Both phones use the same template within CCA and the same localization settings. Any idea what's happingn/wrong?

I attached two pictures - first one is unprovisioned second one is provisioned. You can see the darkened line, and the mashing. The smaller font is much clearer when you sit in front of the phone - in the pictures it's a little bit hard to actually notice it.

thx,

Fabian

7 REPLIES
Community Member

7965 on UC560 - small GUI / font issue

Font size can change between phone load version.  You may check to ensure you are on the latest phone load and see if that helps.

-Trent Good ** Please rate useful posts! **
Community Member

Re: 7965 on UC560 - small GUI / font issue

Hi,

the font-size probably is locale related and not load related. I did a factory rest on one of the phones. First it flashes the factory load, then it upgrades to the UC560 load. Between reboots I clearly see the large font. Someone reported a similar issue: https://supportforums.cisco.com/thread/2075275

After the last reboot the phone says sth. like applying locale - and then refreshes. After this the fonts are small.

Any ideas on how to get those darker lines back for the line lines?

Cisco Employee

Re: 7965 on UC560 - small GUI / font issue

Hello Fast-detect,

You have to reinstall the locale using the tar file.

HTH,

Alex

*Please rate helpful posts

Community Member

Re: 7965 on UC560 - small GUI / font issue

Hello Alexander,

where do I get a "good" copy of the locale *.tar file? Currently my UC560 is on 8.6.0 - I also downloaded the 8.6.1 software pack and took a peek into the locale frome that software pack.

There were some changes for the XML locale files for the SPA-Phones but the be-sccp.jar - which should be the locale file for the 7945/7965 is unchanged. So I see no point in uploading the file, if the very same (bitwise) exists already on the box. The question would be where do I get a correct be-sccp.jar file (need it in German and English...)

regards,

Fabian

EDIT:

poking around within those be-sccp.jar files (German and English) I found some interesting differences within the target-skin.xml

English

 

 

 

 

 

 

 

 

 

 

German

   

   

   

   

   

   

   

   

   

   

   

  

So basically an UI-Element called "kemtext" should be larger for the German version as it is for the English one. Is there any description what those UIComponents actually arre? Does anyone have a stock be-sccp.jar for comparision?

Within the jar is also the sc-font.xml for the german jar it says

German_Germany

for the US-english one it actually says

English_United_Kingdom

I don't know whether this is just descriptive or if the phone actually discards reading that file because it expects "United_States"

regards,

Fabian

Cisco Employee

Re: 7965 on UC560 - small GUI / font issue

Hello Fabian,

On the UC500 these files are usually in the following dirs:

flash:/English_United_States/CME-locale-en_US-English-8.1.2.1.tar

  flash:/its/CME-locale-de_DE-German-8.1.2.1.tar

The locale files for English are included in the software pack and for German is in the corresponding locale pack.

You may reinstall the English one.

The following link provides information how to perform the install of the locale:

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmelocal.html

You may try reinstalling with CCA or CLI whatever you feel more comfortable or entitled for.

HTH,

Alex

*Please rate helpful posts

Community Member

Re: 7965 on UC560 - small GUI / font issue

Hi Alexander,

I actually see no point in replacing the files on my box, when I already downloaded them from the UC560 and compared them with the files from the locale- and software-packs. They are exactly the same.

Did you see my edit about be-sccp.jar file within CME-locale-en_US-English-8.1.2.1.tar ? I guess cisco is distributing somehow messed up phone locales.

When I'm back in the office on monday, I'll play around with the xml's embedded to the be-sccp.jar. What is the easiest way to have my phone reload the locale?


regards,

Fabian

Hall of Fame Super Gold

Re: 7965 on UC560 - small GUI / font issue

Remove locale configuration from UC.

Perform soft reset sequence on phone (search for how).

If still trouble, perform hard reset.

493
Views
9
Helpful
7
Replies
CreatePlease to create content