Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Auto Attendant goes to long

I have a small problem.  Sometimes when customers call into our business either our DTMF or there DTMF does not work.  Our Auto Attendant answers everything except for DID personal numbers.  Our Auto Attendant prompt (wav file) is very long.  It cycles 3 times before the call will be disconnected.  I changed the call to be forwarded to a VM box but 3 cycles of listening to the auto attendant takes forever when the DTMF doesn't work.  My question is can I reduce this to one or two cycles instead of the three?   I'm using the canned S4_main_dialbyname.aef script.  Any help would be appreciated.  Thanks.


Community Member

Re: Auto Attendant goes to long

Doug - ran into a similar issue...  the issue was the prompt that was playing was the wrong one..  and during one recording, users could not hit any buttons..  but if they waiting the right amount of time... it worked fine...  sounds like what you are experiencing..

The way I ran into this was instead of creating my own .aef script for the AA, I used the one that came with the UC500.  Then I hacked the prompts (using dial in prompt management from the ip phone) and listened to each prompt until I figured which prompt was playing (out of the 5 that came with the system)... and then edited that one...  The only thing was the script called for a "play prompt" before it played another prompt and allowed  the user to have options to dial...

So there were 2 prompts playing and one said something like "welcome  to the Cisco Auto Attendant" and the other one said "Please press 1 for blah blah blah...etc".  But together... it sounded like one big prompt...if you called into the AA..

Well I recorded and changed prompt 1 "welcome to the Cisco Auto Attendant" to "Welcome to company XYZ, please press 1 for blah blah blah.... etc." so when that played people where hitting the options I stated.... nothing would happen...  because the script really said just "play the prompt, but dont expect user input"...  and then play prompt 2 (and listen for user input)...  but I erased this one...  and it really stumped me for a while.

so two things...

1) Make sure you did not do what I did.... and edited the wrong prompt because this could be what you are running into...

2) Check the AEF script file with the editor to see what the script you are using is actually doing....

Hope it helps... 

CreatePlease to create content