Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Desktop/Background adjust: "a file with the same namealready being served"

Helping a partner with CCA 3.1 SWP 8.1.0

So everyone is probably aware that each Cisco IP Phone model display screen size is a little different, and if you want to customize the

Setting: User Preferences:Background Images (from the phone)

...the this relies on a file called "List.xml" appearing in each phone type display subdirectory on UC500 flash

7970 - 7971 - 12 Bits - /Desktops/320x212x12

*Full size image - 320 pixels (width) X 212 pixels (height).

*Thumbnail image-80 pixels (width) X 53 pixels (height).

7945 - 7965 - 16 Bits - /Desktops/320x212x16

*Full size image-320 pixels (width) X 212 pixels (height).

*Thumbnail image-80 pixels (width) X 53 pixels (height).

7975 - 16 Bits - /Desktops/320x216x16

*Full size image-320 pixels (width) X 216 pixels (height).

*Thumbnail image-80 pixels (width) X 53 pixels

, and in each List.xml, they point to the flash:/Desktops subdirectory where all the TN (thumbnails) and .png image files are located. 

Then, with the help of some TFTP-server statements, the phone can request its 'List.xml' and allow the end user to select the TN they like and it loads the .png.

In CCA 3.1, they introduced background customizations (Great Job!).  It does all this for you, so you no longer need to use the 'softbranding TEL" I posted 2 years ago :-)

https://supportforums.cisco.com/docs/DOC-9799

BUT, I think there may be an IOS TFTP bug here, preventing the tftp-server statements from being entered for each of the three display directories.

As soon as CCA enters the first one, I believe the next two are being rejected.   If you try manually, you may see an error to the effect of "a file with the same name is already being served" when you try to enter the 2nd display directory for List.xml

As a workaround, I did a " no tftp-server ........." on the one that was there (I believe 320x212x12) and added in the one I needed, and it worked.

So the manefestation of this problem will be partners deploying various phone models will encounter end user complaints stating they see no TN images on their phones when they try to adjust the background.

So the workaround is ugly.  You have to make the CLI changes to allow the one you need to be the prevalent tftp-server statement.

Unless anyone knows that this is fixed in a later (more recent) IOS?  havent tried that yet.

1 REPLY
New Member

Desktop/Background adjust: "a file with the same namealready bei

Hi Steve,

8.1.0 preventing  to add the second  tftp served command (Give error “file with same name already being served”) to the desktops directory and it is only allowing after deleted the existing tftp command. 
 
In 8.2.0 IOS, it is allowing to add more than one tftp command to the desktops directory. Desktop background working fine in the 8.2.0 IOS. 
 
Screen shot 8.1.0
 
 
Screen shot 8.2.0

 

Thanks,

Anna

1102
Views
0
Helpful
1
Replies
CreatePlease to create content