Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

DHCP problem with SPA504g

I configured a SPA504g for a customer demo. worked fine here on my network, hangs "Initializing Network" on their network. Works fine on other networks too. Other devices (other type of SIP phone, printers, my laptop) have no problem getting DHCP address on their network. Wiresharking the issue, I see the DHCP server repeatedly responding with DHCP Offer/DHCP Ack, but it's as if the phone doesn't see it. Wireshark logs show other devices getting DHCP address in the normal 4 step sequence.  No VLAN configuration specified {yet, anyway}.  Any ideas would be MOST welcome.

2 REPLIES
Community Member

DHCP problem with SPA504g

post the trace spanning the phone during boot, there are a couple reasons it might not be getting an IP...

physical - bad cable, bad nic port

layer 2 - are vlans turned off 0n the phone?

does a pc attached to the phone get an IP?

if your config isnt too complex, you might try factory reset and see if it gets an ip then

Community Member

Re: DHCP problem with SPA504g

Thanks, those are all good ideas, but I believe I've worked through

them. the most confounding situation is that I have successfully

connected this phone to about 4 other networks without incident. There

is nothing (that I can see) about this one that it won't boot on.

Isolating the cable was accomplished by booting a PC and getting a DHCP

address on the problem network. The phone NIC must be ok because it gets

a DHCP address on other networks. There are no VLANS configured on the

phone, at least yet.

The configuration at this point is simple, so I will try the factory

reset idea.

Thanks again

Ron Byer Jr.

NetWeave Integrated Solutions, Inc.

+1 732.786.8830 x120

ronb@netweave.com

1359
Views
0
Helpful
2
Replies
CreatePlease to create content