Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Fax on FXS Issue

I have a UC520 using SIP configured for a customer.  All call processing is working and internal faxes to the FXS port work with no problems.  The issue is that the customer cannot send any outgoing faxes.  I have requested the customer to bring a analog phone tomorrow to test the port but anything that would cause the fax not to work?  I ran a debug and all I can see if the following.  I never see the number being dialed.

01444: Sep 16 19:45:41.963: htsp_process_event: [0/0/0, FXSLS_ONHOOK, E_DSP_SIG_1100]fxsls_onhook_offhook htsp_setup_ind
101445: Sep 16 19:45:41.963: [0/0/0] get_local_station_id calling num=301 calling name=Fax Line calling time=09/16 14:45  orig called=
101446: Sep 16 19:45:41.963: //-1/59FDF498AD6A/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=
   ----- ccCallInfo IE subfields -----
   cisco-ani=301
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=0
   dest=
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=0
   cisco-rdnsi=0
   cisco-redirectreason=0   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

101447: Sep 16 19:45:41.967: //-1/59FDF498AD6A/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x861636A4, Call Info(
   Calling Number=301,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE,
   Incoming Dial-peer=1, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), Calling IE Present=TRUE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1
101448: Sep 16 19:45:41.967: //-1/59FDF498AD6A/CCAPI/ccCheckClipClir:
   In: Calling Number=301(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
101449: Sep 16 19:45:41.967: //-1/59FDF498AD6A/CCAPI/ccCheckClipClir:
   Out: Calling Number=301(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
101450: Sep 16 19:45:41.967: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
  
101451: Sep 16 19:45:41.967: :cc_get_feature_vsa malloc success
101452: Sep 16 19:45:41.967: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
  
101453: Sep 16 19:45:41.967:  cc_get_feature_vsa count is 7
101454: Sep 16 19:45:41.967: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
  
101455: Sep 16 19:45:41.967: :FEATURE_VSA attributes are: feature_name:0,feature_time:2260867344,feature_id:14953
101456: Sep 16 19:45:41.967: //89196/59FDF498AD6A/CCAPI/cc_api_call_setup_ind_common:
   Set Up Event Sent;
   Call Info(Calling Number=301(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=(TON=Unknown, NPI=Unknown))
101457: Sep 16 19:45:41.967: htsp_process_event: [0/0/0, FXSLS_WAIT_SETUP_ACK, E_HTSP_SETUP_ACK]fxsls_check_auto_call
101458: Sep 16 19:45:41.967: //89196/59FDF498AD6A/CCAPI/cc_process_call_setup_ind:
   Event=0x8611D0E8
101459: Sep 16 19:45:41.967: //89196/59FDF498AD6A/CCAPI/ccCallSetContext:
   Context=0x87C87770

6 REPLIES
New Member

Re: Fax on FXS Issue

Did you change this FXS port to "FAX" in CCA? If not, you have to.

Thanks,


Marcos

New Member

Re: Fax on FXS Issue

Yes, this is what I have.

voice-port 0/0/0
timeouts ringing infinity
station-id name Fax Line
station-id number 301

dial-peer voice 1 pots
description ** CCA Analog Fax **
destination-pattern 301
direct-inward-dial
port 0/0/0
no sip-register

New Member

Re: Fax on FXS Issue

Could it be that the call is going out a different port and not the SIP trunk? Did you verify that regular voice calls work OK?

Thanks,

Marcos

New Member

Re: Fax on FXS Issue

Voice calls on the port, or in general.  In general it works.  Still waiting on customer to bring in analog phone to connect to fxs port to test a outbound call.  Anything I can check in the meantime?

New Member

Re: Fax on FXS Issue

You seem to have everything in place. If your pending testing does not yield any results, I recommend you contact our TAC.

Thanks,


Marcos

New Member

Re: Fax on FXS Issue

Issue resolved.  I just left the customer site and the dial peer was configured as such.

dial-peer voice 1 pots
description ** CCA Analog Fax **
destination-pattern 301
direct-inward-dial
port 0/0/0
no sip-register
!

Removed the direct-inward-dial and works great.  Not sure how that got there.

Thanks!

3529
Views
0
Helpful
6
Replies
CreatePlease to create content