Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Getting DHCP through WLC526?

I have a WLC526 that I purchased years ago with some other bench testing equipmment when I first got SMB certified and I finally got around to installing the WLC.  I've been screwing around for quites some time now trying to get DHCP to work through the WLC from servers set up on the UC520.  I can change the WLC setting to allow static client addresses and that works fine. My WLC is running sw version and I'm unable to download the latest sw release and TAC is no help.  No contract and out of warranty even though it's only been installed for a week.

My vlan dhcp server works fine on on any access port, I can associate with the WLANs but I can't get a dhcp.  I've been through the forums and I 've seen many posts on this issue but no resolutions.  I've enabled/disabled dhcp proxy on the WLC, I've set the DHCP Server override and DHCP Addr. Assignment in multiple combinations on the WLC per WLAN and still no joy.  With everything I've tried one combination should have worked which Is why I feel a newer sw/fw might be what's needed.  I don't recall what I spent on this device but since installing it for the first time last week I'm ready to toss it into the garbage since it's been extremely frustrating and what I get from TAC is "Sorry, no contract or out of warranty". 

Dow anybody know the secret to getting DHCP to work through this device?

Community Member

Getting DHCP through WLC526?

1-why do you want to use WLC526 as a DHCP?

2- what end devices you need to get DHCP services?

Community Member

Getting DHCP through WLC526?

I don't want the WLC do DHCP, I don't believe the 526 can either, my post reads "I've been screwing around for quites some time now trying to get DHCP to work through the WLC from servers set up on the UC520". My UC520 hosts the servers with bindings and exclusion setup per vlan as required and I want my wi-fi clients to be able to receive addresses through the WLC from the UC520's DHCP servers.

Clients are PCs, iPads, etc. normal everyday clients. 

Community Member

Getting DHCP through WLC526?

I do have one and I did used it for some time it worked fine with UC520 but I had to removed some time ago because I am using deferent system I also had cisco 7921 wireless phone working with no problem. I agree tac was not help but I managed to get it working. I had to create separate VLAN for wireless on UC520.

Community Member

Getting DHCP through WLC526?

Hi Viningele,

You will need to upgrade the firmware to resolve this problem, its been a while since I played with that WLANC but I did have the same issue with the DHCP helper not working.

I would have downloaded the new firmware for you and happily given it to you, but alas my certs have expired and I am no longer associated to any Cisco VAR, so my Cisco credentials are pretty much useful only for the forums

If there is someone kind enough to do it for you, make sure you give them a big thanks

(PS) I do not agree with this particular practice by Cisco, no person should be denied a firmware upgrade because its out of warranty, the vendor I work for now certainly does not... It makes no sense what so ever to impose something like that, none at all.



Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
Community Member

Getting DHCP through WLC526?

I agree with David me too after 10 year been Cisco partner I dropped cisco, because I got fed-up of year after year taking the repetitive Cisco exam.

Community Member

Getting DHCP through WLC526?

I let my certs lapse too mainly cuz those tests are real stupid created by full time test writers who have no concept of networks.  Then pile on all the sales and marketing BS.  I was thinking about going through it again but after this round of BS probably not. 

Yeah the idea that firmware upgrades aren't available for the life of the product is indeed lame and another reason some folks move away from vendors who do this.  The biz management suits that come up with these intended revenue generating ideas should have their head examined since for every $ they make they loose $$ by driving people away to other products.

Yeah I feel I need an updated firmware/software cuz I pretty much tried everything else, well almost. 

What I love about the TAC responses is that this product is dead with an EOL of over a year ago yet they want to hold on to the SW that could help make this device work which is only one week out of the box (brand new) and in the end drive me away from selling Cisco products.  Little robots sitting behind a desk adhering to their scripted responses.   

Community Member

Getting DHCP through WLC526?

Hi Viningele,

 Little robots sitting behind a desk adhering to their scripted responses.    

I am not afraid to criticize Cisco for certain decisions that they make and publicly as well, after all they do pride themselves on being a company that accepts all forms of feedback from the community.

However though I leave the support personnel out of any of my criticism, those guys have a real hard job, they often have to work within tight constraints and very tight rules, sometimes you even get one who says "To hell with it" and steps outside of those boundaries because they have that fire in them to help someone.

Don't be down on them as they are just doing their job and doing what they are instructed to do by their employer, I would though encourage you to voice your opinion against the decisions made by the upper management who at times don't seem to think before they act, or maybe do think but just ignore the writing on the wall in front of them and just do what they think is best based upon solely their opinion.

Not havin ga go at you in any way but I will always defend the support staff as they are all a wonder crew (The majority of the time 98%).

Back to your problem, I did try and get the latest firmware for you, but yeah it is as I thought I am not able too



Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
Community Member

Getting DHCP through WLC526?

Yeah, I'm not really down on the TAC techs but the suits who write the rules.  TACs hands are tied to some extent and I do understand a companies need and right to profit but when a policy is counter productive and bad for biz and the suits are too dumd to comprehend well......

Anyway, since I don't believe in surrendering I managed to get it to work.  I'm sure the newer fw/sw would have eliminated the convoluted procedure I had to go through to get it too work.

Procedure for creating a WLAN on the WLC526 that pulls DCHP from the UC520 or

other device hosting a DHCP server.

I believe the problems I was having was in part due to the order of the

various steps and where the VLAN used for the WLAN was initially created.

Otherwise I'm not doing anything different that I haven't tried dozens of times. 

Normally I create the VLANs first in the UC520 in CCA --> Configure -->

Switching --> VLANs, then go on from there but that wasn't working when I

tried using the WLC.  Maybe subsequent sofware updates corrected this "bug"

but I guess we need to pay for bug fixes. Hmmm!  

From what I'ver gathered you need to start with a fresh VLAN and WLAN.

CCA --> Configure --> Wireless --> WLANs (SSIDS) --> Create -->

Pop Up for my needs I answer "no".

WLAN Type: Check "Data" (haven't tried others yet)

SSID: My-Wi-Fi-5 (just some dumb name for testing)

Broadcast: checked

VLAN: Add Vlan --> Pop Up

VLAN: 202 (I like to use the 3rd octect of my corresponding LAN address)

VLAN Name: my-vlan-202 (only lower case which differs from Switching Vlans)

Port: 1 (my WLC connects via port 1 on the WLC)

IP Add:




OK --> closes Pop Up

Web Authentication: unchecked (not for this)

Security Type: WPA2-PSK

Encryption: aes

WPA Pre-Shared Key: SomeDumbKey (8 character minmum)

Ok --> close Pop Up

Apply -->  Pop Up --> Ok, Pop Up --> Ok (I get comm err 404, forget it) --> Ok

Ok --> close the WLAN (SSID) Pop Up.

Now go to Routing.

CCA --> Configure --> Routing --> IP Addresses

Find the new Vlan

Vlan202 enter IP Mask

Apply --> Pop Up --> Ok --> Pop Up --> Ok

Ok --> closes IP Adresses

CCA --> Configure --> Routing --> DHCP Server

Select Pool Tab


Name: DHCP-P-202 (pool for vlan 202)



Default Router:

Ok --> Closes Pop Up

Apply (could wait until after exclusions but..)

Pop Up:

ip dhcp pool DHCP-P-202
import all
lease 1

Ok --> closes Pop Up --> Pop Up --> Ok

DHCP Exclusions Tab



End (this could be what ever you want to reserve)

Pop Up:

ip dhcp excluded-address

Ok --> closes DHCP Pop Up

Now in the Topology view right click on the WLC device

Double click on the Config Utility

WLC Config Utilty Page..................

I get the security certificate warning, click continue to website (not


Login button, log in

Click on the WLANs tab, General Tab verify My-Wi-Fi-5 is present and click on


Status: checked (enabled)

Radio Policy: All

Interface: my-vlan-202

Broadcast: checked (enabled)

Skip Security and QOS for another day

Advanced Tab:

DHCP Server: check (override)


DHCP Addr. Assign: check (required) leave off if want static clients too(?)

Apply --> Save Configuration (top right)

Interfaces --> verify my-vlan-202 and IP Address of

Left side click the Advanced button

click DHCP

Enable DHCP Proxy: checked (enabled)

Apply if changed or just for the heck of it.

Save Configuration.

Go to any PC and check for the available wi-fi and select My-Wi-Fi-5

You should be good to go to acquire an address but won't get any DNS for


Go to a CLI utility like Inidgo Terminal Emulator (the best I've found)

Log into the UC520 via command line

UC_520#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
UC_520(config)#ip dhcp pool DHCP-P-202
UC_520(dhcp-config)#import all
UC_520(dhcp-config)#lease 1
UC_520(config)#ip dhcp excluded-address

System configuration has been modified. Save? [yes/no]: yes
Building configuration...

Compressed configuration from 29490 bytes to 13449 bytes[OK]
Proceed with reload? [confirm]yes

With luck when it boots up you can connect to your new WLAN, obtain an IP

address from the DHCP server on your UC520 and surf the web.

In my case my NAT is set up for  80 so is

already configured for HTTP (web surfing). 

On your PC clear your wi-fi settings for the new WLAN and re-connect, re-enter

the password.

Once connected check your setting and your DNS values should be imported.  I

don't know what this has to be done twice unless maybe the UC520 config wasn't

saved and reloaded but it's easy enough to and in again via CLI.

Anyway this new WLAN now works, I get my DHCP and I can surf.

FYI, my UC520 ins't my gateway but sits behind an RV082 which I will probably

remove once I get all this new (old) gear up and running.

CreatePlease to create content