Cisco Support Community
Community Member

Issues with UC540 phone system setup

Hi guys/gals,

The main issue that I’m having at the moment is related to the call flow/handling.

We are using a B-ACD prompt to handle calls, but only after the call’s ring at “reception” for a period of time.

For this I have setup an ephone-dn with an internal number of 620 and it will call-fwd to the B-ACD prompt (380) after no-answer of 8 seconds.

I have setup a translation-rule for the incoming number say (03 xxxx 0669) to go to 620.

The issue I have is when I call the internal number 620 it works as it should, rings the 620 extension for 8 seconds before transferring to the B-ACD prompt and then the B-ACD doing its thing.

But when I call in from an external number, it rings the 620 extension and then seems to transfer to the B-ACD prompt but it only rings that for a couple of seconds before returning to ringing the 620 extension then dropping out without playing any of the prompts.

I have tried a few things; such as changing the dtmf-relay from h245-alphanumeric to rtp-nte for the B-ACD dial peer (380) which didn’t seem to affect anything.

I have debugged the dial-peers and everything seems to be resolving correctly.

Have anyone come across this issue before? If you can point me in the right direction for solving it, it would be much appreciated.

Further info that I can provide are the following:

From the config, the main points of interest I believe are the following:

Dial-peer voice 3003 voip

Voice translation-profile First_called_5

Voice translation-rule 5

Ephone-dn 200

Dial-peer voice 5001 voip

Service aaservice1

Service bacd

Ephone-dn 100

Ephone-hunt 50


Dial-peer voice 1023 voip

Dial-peer voice 1024 voip

The reason for ephone-dn 100 is to label the incoming calls so when they are transferred to the blast group people can see which line they have come in on.

If anyone needs the debug logfiles let me know and I provide them.


Cisco Employee

Issues with UC540 phone system setup

Dear Partner;

Due to the specifics of your issue, I suggest you contact the Small Busienss Support Center.


Community Member

Issues with UC540 phone system setup

No worries. I will do just that. Apologies....being a newbie here. :-)

CreatePlease to create content