Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

LDAP Phone directory on SPA5xx not working

We cannot get LDAP working on SPA504g even after we followed the guide .. http://www.mik.ua/products/spa922/SPA900_LDAP_CORP_DIR_V11.pdf

We dont even get the directory name that i have created to come up when you go into the directory menu.

We are using SPA504 and 509gs (Firmware version 7.4.4) with ver 9.5.

There must be something stupid i am doing here as this should just work??

4 REPLIES

Re: LDAP Phone directory on SPA5xx not working

This is my personal working configuration guide:

Before you use the LDAP search feature, you need to know some PBX parameters:

  • PBX IP address
  • PBX name
  • ldap access credentials

Configure LDAP parameters of Cisco Linksys phone as below pictures shows.

LDAP Dir Enable: enable or disable LDAP feature

LDAP Corp Dir Name: the name displayed on your phone Directory

LDAP Server: IP address of PBX

LDAP Auth Method: SIMPLE (in my case)

LDAP Client DN: ldap username

LDAP Username: ldap username

LDAP Password: ldap password

LDAP Search Base: cn="PBX NAME"

LDAP Last Name Filter: cn:(cn=*$VALUE*)

LDAP First Name Filter: sn:(sn=*$VALUE*)

LDAP Display Attrs: a=cn;a=sn;n=Phone,a=e164,t=p; display last name and object phone number to call

You can troubleshooting LDAP problems using wireshark.

Example of successful query:

This configuration is used with Innovaphone PBX without problem but some parameters can be different based on PBX type.
What is your PBX/LDAP server? Can you trace the LDAP query with wireshark?

Regards.

New Member

Re: LDAP Phone directory on SPA5xx not working

Thanks Daniele for your reply,

I want to use active directory as our LDAP server which is obviously on a different server to our pbx. Our pbx is 3CX.

I've managed to get the directory actually showing on the phone by changing the Last name, first name filters. However it just comes up with the error LDAP Error: cannot connect to server. I've tried all 3 Authentication methods, ut still no joy.

Re: LDAP Phone directory on SPA5xx not working

Do you have already seen this documentation?

http://www.3cx.com/blog/voip-howto/active-directory-cisco-phone/

Regards.

New Member

Re: LDAP Phone directory on SPA5xx not working

Followed the guide but the phone wont even reprovision with the template. I've sent it over to 3cx to look at and even they are struggling.

Have you managed to get this working?

2182
Views
0
Helpful
4
Replies
CreatePlease to create content