Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

MWI no longer working following upgrade

Hi,

We recently upgraded our UC520 from V8.2 to V8.6 (uc500-advipservicesk9-mz.151-4.M5).  MWI was working fine but no longer does since the upgrade.  I've been through the config and it all looks fine, I can see no changes to cause the issue.

I cannot find any know issues with the upgrade process we followed.

I hope someone is able to help.

Regards

Neil

5 REPLIES
Hall of Fame Super Gold

MWI no longer working following upgrade

Post relevant config (siap-ua and sip gateway) from both UC and CUE.

New Member

MWI no longer working following upgrade

Hi,

The MWI config is as follows:

CUCME:

ephone-dn  223

number A801... no-reg primary

mwi off

ephone-dn  224

number A800... no-reg primary

mwi on

CUE:

ccn application ciscomwiapplication aa

description "ciscomwiapplication"

enabled

maxsessions 6

script "setmwi.aef"

parameter "CallControlGroupID" "0"

parameter "strMWI_OFF_DN" "A801"

parameter "strMWI_ON_DN" "A800"

end application

I should state I did not install or upgrade this system (I have inherited it) and I would expect there to be slightly different config to what is in place but I've only ever dealt with CUCME rather than UC500.  I have been informed though that MWI was functioning prior to the upgrade and I did try the following config but this made no difference either:

CUCME:

sip-ua

mwi-server ipv4:"IP Address" expires 3600 port 5060 transport udp unsolicited

dial-peer voice 2000 voip

description ** cue voicemail pilot number **

translation-profile outgoing XFER_TO_VM_PROFILE

destination-pattern 39.

b2bua

session protocol sipv2

session target ipv4:"IP Address"

voice-class sip outbound-proxy ipv4:"IP Address"

dtmf-relay rtp-nte

codec g711ulaw

no vad

ephone-dn  223

number 391... no-reg primary

mwi off

ephone-dn  224

number 390... no-reg primary

mwi on

CUE:

ccn application ciscomwiapplication aa

description "ciscomwiapplication"

enabled

maxsessions 6

script "setmwi.aef"

parameter "CallControlGroupID" "0"

parameter "strMWI_OFF_DN" "391"

parameter "strMWI_ON_DN" "390"

end application

Hall of Fame Super Gold

MWI no longer working following upgrade

On CUE you need:

ccn subsystem sip

mwi sip unsolicited

The you can remove all "DN MWI ON/OFF" configuration.

New Member

MWI no longer working following upgrade

You will probably also need the sip-ua portion of the configuration, don't have it sitting in front of me at the moment though.

-Trent Good ** Please rate useful posts! **
Cisco Employee

MWI no longer working following upgrade

Hello Neil,

Do you have ""bind" under voice service voip?

If you do not have sip phones out of the voice vlan you may remove bind control and media for sip under voice service voip and the MWI will work.

HTH,

Alex

*Please rate helpful posts

380
Views
0
Helpful
5
Replies
CreatePlease to create content