Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
joe
Community Member

Need help with getting 7960 phones to work with UC540

Hi,

I tried to follow the directions to load the latest CSSP firmware, but the problem is that I can't download the firmware from since I don't have a Smartnet contract.  Is there a URL to public firmware versions for the 7960?

Thanks!

3 REPLIES
joe
Community Member

Re: Need help with getting 7960 phones to work with UC540

One of my 7960's says "Phone Unprovisioned", and the other says "Protocol Application Invalid" when connected to the UC, so I'm guessing that firmware is the problem at this point.

Community Member

Re: Need help with getting 7960 phones to work with UC540

Hi Joe,

In theory you should still be able to download the phone loads using your CCO credentials (I will stand corrected if I am wrong), as what you are able to download is bound to that CCO not any particular SmartNet contract.

However it is allways a good idea to make sure SmartNet is available on all systems, it is a small price for you/client to pay to ensure longevity of the system and continual support of the system.

Firstly I would suggest you look at resetting the phones back to factory default, this has helped me in the past when I have received these error messages for no apparent reason, you can reset them to factory defaults by doing the following:

  1. Unplug the power cable from the phone, and then plug in the cable             again.

    The phone begins its power up cycle.

  2. Immediately press and hold # and while the Headset, Mute, and             Speaker buttons begin to flash in sequence, release #.

    The Headset, Mute, and Speaker buttons flash in sequence in order             to indicate that the phone waits for you to enter the key sequence  for the             reset.

  3. Press 123456789*0# within 60 seconds after the             Headset, Mute, and Speaker buttons begin to flash.

    If you repeat a key within the sequence, for example, if you press             1223456789*0#, the sequence is still accepted and the phone resets.

    If you do not complete this key sequence or do not press any keys,             after 60 seconds, the Headset, Mute, and Speaker buttons no longer  flash, and             the phone continues with its normal startup process. The phone does  not reset.

    If you enter an invalid key sequence, the buttons no longer flash,             and the phone continues with its normal startup process. The phone  does not             reset.

    If you enter this key sequence correctly, the phone displays this             prompt:

    Keep network cfg? 1 = yes             2 = no

  4. In order to maintain the current network configuration settings for             the phone when the phone resets, press 1. In order to reset             the network configuration settings when the phone resets, press 2.


If you press another key or do not respond to this prompt within  60             seconds, the phone continues with its normal startup process and  does not             reset. Otherwise, the phone goes through the factory reset process.

    If you can monitor the TFTP event on the system to ensure that the phones are able to obtain the Firmware currently on the system, if there are any errors, then your TFT-SERVER entries might be wrong, or you do not have the loads configured in Telephony-Service section.

    You can monitor the TFTP events by doing the following on the appliance.

    ROUTER# debug tftp event

    ROUTER# term mon

    Make sure you do the above before you plug the phones back into the system.

    Cheers,

    David.

    Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
    joe
    Community Member

    Re: Need help with getting 7960 phones to work with UC540

    Thanks for the advice David, but it still seems to not be working properly.  It looks like neither phones try to pull the OS79XX file from my TFTP Server.

    One phone goes straight from the DHCP request to a request for the files CTLSEP.tlv, then SEP.cnf.xml, then SIP.cnf, MGC.cnf, XMLDefault.cnf.xml, SIPDefault.cnf, and finally, MGCDefault.cnf.  This phone then ends up in the "Protocol Application Invalid" screen.

    Is there anything I can do with any of those files it is requesting to tell it to pull the SCCP firmware?

    739
    Views
    0
    Helpful
    3
    Replies
    CreatePlease to create content