Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Phone not getting an IP Address

Hi

I am have just started trying to setup some BYO Cisco SPA504G (running 7.4.7 firmware) on our network which we are using MyNetFone as our virtual PBX.

My issue is that the phone is not picking up an IP address from the SBS 2003 Server. We had an issue initially with the 504G phones we got from MyNetFone because we are using a smart switch (D-Link DGS-1210-28P) and adsl modem (Cisco SRP527W).

Does anyone know what I need to do. Sorry I dont have much experience with this.

Many Thanks

Chris

Everyone's tags (1)
7 REPLIES
Community Member

Hello, Can you configure a

Hello,

 

Can you configure a static I.P to the phones in question to fit in with the network?

Or do you have a DHCP sever running that you want the to connect to?

 

Regards,

 

Oliver.

Community Member

I have tried this but it

I have tried this but it didnt work.

I connected phone to a router and laptop on a different network and set the IP, Subnet and Gateway. Then when I connect this to the main network with the Server running the DHCP server its not updating or connecting.

So I confirmed that its working as I could access the phones webpage we connected to the different network.

I think there is a problem because we have a smart switch and Cisco router but I dont know what to do.

The phone stays on CheckingDNS and on checking the Network details it has the last IP address from the different network.

Thx

Community Member

Chris, What cloud platform

Chris,

 

What cloud platform are you connecting to with this for i.e broadsoft, Hipcom, HVX.

 

It sounds like the phone is not storing the I.P address and reverting back to new. Have you tried factory resetting the phone and also uploading the latest firmware to the phone too?

Also check for typing errors in the proxy server settings and make sure that the phone is set to "use dns srv" in the configuration pages.

 

Olly.

Community Member

Hi OllyConnecting to

Hi Olly

Connecting to MyNetFone

I have tried Factory Reset but didnt help. I am going to take home to my network to check and update the firmware to the latest. I have not done this before but wouldn't I need its IP to upgrade.

I will go back and check proxy server settings. I did check the DNS which was wrong but changing the settings hasnt helped.

I was told that the smart switch might be the issue? What do you think?

Thanks again for your time in helping me

Chris

VIP Gold

Smart switch may be issue.

Smart switch may be issue. Misconfigured dhcp/arp snooping, misconfigured guard feature, access mode or just wrong vlan may affect the phone.

As long as phone's DHCP requests are not reaching the DHCP server (check logs of DHCP server or catch the packets to verify) then it sounds like networking issue.

 

Community Member

Hi AllI have upgraded and

Hi All

I have upgraded and also with help from MyNetFone I had two settings to change in the Phone.

9.Network > 18.CDP to No

21.CallControlSettings >  2.SPCP Autodetect to No

 

Many Thanks for everyones time

Chris

Community Member

This discussion has been

This discussion has been reposted to the SPA IP Phones community

461
Views
0
Helpful
7
Replies
CreatePlease to create content