Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Phones are assigned data vlan IP not voice vlan IP

Install a UC320W with SPA525G2 phones. The phones are all conected to a SG500X-24P switch set for Voice Vlan 100 and Data Vlan 8. The UC320W is configured for Data DHCP 10.10.8.x and Voice DHCP 10.1.1.x. All the phones are getting 10.10.8.x IP addresses. We are having problems with audio only 1 way on internal calls and voicemail is not working. I think it is related to this problem.

How can I get the UC320W to use VLan 8 for data and what is the right configuration for CDP on the SG500X-24P?

4 REPLIES
Green

Phones are assigned data vlan IP not voice vlan IP

Hi Greg, in this scenario the SX500 switch is plug and play. Assuming the UC300 is set up correctly, you can literally plug in the switch and everything 'magically works'.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Community Member

Phones are assigned data vlan IP not voice vlan IP

It is not. The SG500X was already in place and configured. Vlan 8 Data, Vlan 100 Voice. I added the UC320W and the phones all connect the the Data Vlan. If I plug a phone into the UC320W, then it gets Vlan 100 IP address. So I guess it's the configuration in the SG500X. I've ready that you have to reset the SG500X to it's factory defaults in order for it to Auto-Detect the network. I think that will be my next step.

Green

Phones are assigned data vlan IP not voice vlan IP

Hi Greg, that is path of least resistance and quickest resolution would be to default the switch. The switch is not 'plug and play' with the UC320 if there is pre-existing configuration that can overlap or conflict with the macro system.

So, if you'd like you can post the switch config and a topology and we can figure out where it is broken or factory default the switch and see if it recovers and works as expected.

If you need anything, don't hesitate, I'll try to help best I can.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Community Member

Phones are assigned data vlan IP not voice vlan IP

I finally found the problem

. On the SG500X under VLAN Management -> Interface Settings all the ports were set to "Admit Untagged Only" for Frame Type. I changed it to "Admit All" and all the phones are now getting the Voice VLAN IP address of 10.1.1.x. 

Thanks for responding.

1038
Views
0
Helpful
4
Replies
CreatePlease to create content