Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Phones fail to load with uplink from UC540 to Data Lan

Hi

We have a client running a UC540 with 8 SPA509G phones. Each time there is a power cycle of the system we have to remove the uplink from the expansion port which connects to their existing Data LAN switch (Dumb unmanaged device.) On this data LAN is an SBS2003 server with DHCP enabled (and needs to be left this way) which appears to be the reason that when linked and the phones rebooted they simply will not connect to the UC540. Unplug the expansion cable, reboot the phones and all good and we can reconnect the expansion link.

My question is simple, how, retaining the SBS 2003 DHCP server, can we stop this problem with the phones when they are rebooted. The configuration is completed CCA 3.0 completed except for the disabling of the data vlan DHCP server on the UC540.

Thanks in advance.

James.

Everyone's tags (2)
11 REPLIES
Community Member

Re: Phones fail to load with uplink from UC540 to Data Lan

Hello James,

You're probably not interested in inter-vlan routing so I would remove the connection to the expansion port on the UC and connect the switch to the wan side this way you don't have to worry about the dhcp server broadcasting on the voice network.  Then you'd only have to configure routing on your firewall device (which may be under separate administration) to reach the networks internal to the UC.  The routes would of course have to point to the ip address of the UC's wan interface being that it's shared media.  You'd also need a default route from the UC to your edge device.

-Marvin

Community Member

Phones fail to load with uplink from UC540 to Data Lan

Thanks Marvin

Not quite so simply unfortunately as the internet is presented to UC540 as ethernet connection and the UC540 is acting as the firewall for this link at this client. We need a way to either statically set IP address and VLAN configuration on the phones (Not possible through CCA3.0 I think) or to configure the SBS 2003 DHCP server options in such a way as to force the phones to go look for configuration elsewhere (i.e. the UC540)

Can we do this?

We are going to be rolling out UC540 to other SBS 2008/2011 environments shortly where they will need the link between the phone and data networks (already existing) for the integration of email etc. and therefore need to solve this issue. We are not going to be able to replace the existing data network kit with VLAN aware devices unfortunately. (long story!)

Thanks

James.

Community Member

Re: Phones fail to load with uplink from UC540 to Data Lan

Okay James, I see your dilemma.  Now, this may not be possible but first and simplest suggestion is since the UC is the default gateway have that serve voice and data and disable dhcp on the sbs server, sounds like vlan 1 is already on that subnet so it should be an easy integration.

Ideally cdp should tell the phones to pull their ip from vlan 100 but in your scenario this isn't always the case, also not much you can do with the unmanaged switch.

You do have the option of statically assigning ip addresses on the phones which has to be done from the phone interface itself (an administrative choir).  You first have to disable the dhcp option, then you should be able to statically assign an ip address.

In addition, in the unlikely event that the UC is purely serving connections to ip phones with no attached PCs, I would segregate the network even further by checking the smartport roles for an option for only phones/voice so that it removes vlan 1 from those ports.  This option may not be available.

I have to step out so expect a delayed response

Best Wishes

Community Member

Phones fail to load with uplink from UC540 to Data Lan

Thanks Marvin

This is pretty much what I thought so thanks for confirming!

The site only has 8 phones and is not likely to grow so I think that in this instance the static assigning of details may be the way to go. I will investigate the smartport roles and see if there is any mileage in this.

Thanks for taking the time to respond.

James.

Phones fail to load with uplink from UC540 to Data Lan

Let's take the voice component out of the picture a second when thinking of this scenario.  UC540 is capable of doing static routes like any other cisco router.  I would set up the vlans on the UC540 like the existing network, and add vlan 100 for voice.  Also, add vlan 100 to the existing router.  As long as you have routes between the routers, this scenario will work no problem.  You just have to consider the routing side a little more when going with this topology.

Adam Compton

Community Member

Phones fail to load with uplink from UC540 to Data Lan

Thanks Adam

In this instance the routing is not the issue. The problem is the dumb switch which does not support VLans at all and the phones not discovering via CDP correctly for whatever reason.

J.

Community Member

Phones fail to load with uplink from UC540 to Data Lan

Hi James,

I could be wrong here and might be miss-understanding your network topology (A basic diagram would help )

You can have the UC-500 as the default GW if you want, and also have the SBS serve up the DHCP, however if you do not disable the DHCP ip pool on the UC you will run into problems, not immediately but the minute there is an issue on the network the phones will be the first things to be affected, so my possible suggestion is as follows:

  • Go to CLI and remove the DHCP Data pool configuration (Make a copy of it first in the event you need to reinstate it back), don't just disable the entire scope in CCA, this may work but so far each time it has not when I have tried it, problems still occurred
  • Keep your UC as the DGW if you wish (And suspect you have to because your Internet is ethernet hand-off)
  • Let the UC give our DHCP on VLAN-100 your voice VLAN (Unless this has changed)

This is being ultra basic and there may be some further complexities, but this should work as I do it now with our Demo system in the office, and that's with an SBS server and also a different brand phone system in that equation as well... All whilst still maintaining the system within CCA scope and SBCS support requirements, so I am sure you can do it

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
Community Member

Phones fail to load with uplink from UC540 to Data Lan

Hi David

I think most of you suggestion is what we have in place. The only thing I know we did not do is remove the entire scope, I was advised direct from a Cisco tech to 'just disable the data scope' so I will give that a try and see what happens.

James

Community Member

Re: Phones fail to load with uplink from UC540 to Data Lan

David, I sent you a pm.

Thanks,
Marvin

Community Member

Re: Phones fail to load with uplink from UC540 to Data Lan

What software package are you running?

Also change the Expansion port role from a switch to other or none, I forget what the option is.

Sent from Cisco Technical Support iPhone App

Community Member

Phones fail to load with uplink from UC540 to Data Lan

Question,

I'm about to do a deployment and I have a question. I have a 3550 I need to add to the UC, all I would need is a crossover cable and add the VLAN's for voice and data on the switch right?

2012
Views
0
Helpful
11
Replies
CreatePlease to create content