Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
New Member

Problems with SIP trunk


I am trying to get a SIP trunk working (Generic provider), I cannot get the SIP trunk to register. I have entered the debug commands, buit I see nothing in the log as far as standard messages. I have one dial plan setip in CCA that will use the SIP trunk first for a 1888 pattern, all other calls use SIP last (preference).

I know I am missing something simple, I just can't figure out what. I've got the upstram router and firewall set to watch traffic, but I do not see the SIP request (either tcp or udp) going out to the ITSP.

The UC520 is setup on the LAN on a regular port (not using firewall), and ACL 2 is set to allow the SIP Trunk provider to come in, but no hits.

If I tie up all the PSTN lines and try to dial out I get a quick busy. I checked the log and I am getting a: DisconnectCause 3   , DisconnectText no route to destination (3): error. It's like the dial plan is not taking affect.

Any help would be appreciated.




Re: Problems with SIP trunk

Section 5.1 atdoc below would be what we need to look at on the UC520 to check registration issues:

Also a config would be useful - can you ping the registrar server from the UC520?

New Member

Re: Problems with SIP trunk

I can ping the registrar from the UC520, but I don't see the SIP traffic going to it. I will review the doc and get back to you.

New Member

Re: Problems with SIP trunk

I have this document and don't find it helps in troubleshooting this issue. I do have one question; Is DNS required for the registrar or can IP address work as well?

credentials username 4037051476 password 7 xxcc0 realm
authentication username 4037051476 password 7 ccddee
no remote-party-id
retry invite 2
retry register 10
timers connect 100
registrar ipv4: expires 3600
sip-server ipv4:

dial-peer voice 1020 voip
corlist outgoing call-toll-free
description **CCA*North American*Toll-Free**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 81888.......
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
no voice-class sip outbound-proxy 
session protocol sipv2
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad

SNS-UC520#sho sip reg stat
Line                              peer        expires(sec)  registered
================================  ==========  ============  ==========
0                                 20002       161           no            
4037051476                        -1          179           no      
                                  0           0             no



Re: Problems with SIP trunk

Registrar can be IPv4 address, DNS is not mandatory but is most commonly used.

The document helps in that it shows that the registration is configured for 4037051476 but status shows as no (had to check what the config was setup for). Can you try the below with deb ccsip message enabled:


no registrar

registrar ipv4:

You should see SIP messages come up (assume .182 is correct, its not .192 as your SIP server is .192)

For the debug output you attached where outbound calls fail - the 1020 dial peer is not being matched, dial-peer 58 is. To check why this is the case:

- need "show dial-peer voice summ"

- complete config to see if there is a translation rule someplace which is stripping of the access-code of 8 before the VOIP dial peer is matched

New Member

Re: Problems with SIP trunk

The unregister, register with Debug on shows nothing in the log file at all?> Is there a way to stop and start SIP without rebooting?

SNS-UC520#sho dial-peer voice sum
dial-peer hunt 0
             AD                                    PRE PASS                OUT
1      pots  up   up                                0                      down 0/0/0
2      pots  up   up                                0                      down 0/0/1
3      pots  up   up                                0                      down 0/0/2
4      pots  up   up             304                0                      up   0/0/3
5      pots  up   up             ABC                0                      up   0/4/0
2001   voip  up   up             500                0  syst ipv4:     
2000   voip  up   up             777                0  syst ipv4:     
50     pots  up   up                                0                      down 0/1/0
51     pots  up   up                                0                      down 0/1/1
52     pots  up   up                                0                      down 0/1/2
53     pots  up   up                                0                      down 0/1/3
2012   voip  up   up             444                0  syst ipv4:     
65     pots  up   up             8911               5                      up   trunkgroup ALL_FXO
66     pots  up   up             911                5                      up   trunkgroup ALL_FXO
67     pots  up   up             8011T              5                      up   trunkgroup ALL_FXO
69     pots  up   up             8[2-9]..[2-9]...-  5                      up   trunkgroup ALL_FXO
70     pots  up   up             8[2-9]11           5                      up   trunkgroup ALL_FXO
71     pots  up   up             81[2-9]..[2-9]..-  5                      up   trunkgroup ALL_FXO
72     pots  up   up             81800.......       5                      up   trunkgroup ALL_FXO
74     pots  up   up             81877.......       5                      up   trunkgroup ALL_FXO
75     pots  up   up             81866.......       5                      up   trunkgroup ALL_FXO
1000   voip  up   up                                0  syst sip-server         
1001   voip  up   up             *..                0  syst sip-server         
1003   voip  up   up                                0  syst ipv4:     
1005   voip  up   up                                0  syst ipv4:     
2002   voip  up   up             7$                 0  syst ipv4:     
1004   voip  up   up                                0  syst sip-server         
1020   voip  up   down           81888.......       1  syst                    
1021   voip  up   up             81800.......       6  syst sip-server         
1022   voip  up   up             81[2-9]..[2-9]..-  6  syst sip-server         
1023   voip  up   up             81877.......       6  syst sip-server         
1024   voip  up   up             81866.......       6  syst sip-server         
1025   voip  up   up             8[2-9]..[2-9]...-  1  syst sip-server         
1010   voip  up   up             [8]T               0  syst sip-server         
20001  pots  up   up             101$               0                           50/0/1
20002  pots  up   up             0$                 0                           50/0/2
20003  pots  up   up             301$               0                           50/0/5
20004  pots  up   up             302$               0                           50/0/6
20005  pots  up   up             303$               0                           50/0/7
20006  pots  up   up             BCD$               0                           50/0/9
20007  pots  up   up             201$               0                           50/0/10
20008  pots  up   up             202$               0                           50/0/11
20009  pots  up   up             203$               0                           50/0/12
20010  pots  up   up             204$               0                           50/0/13
20011  pots  up   up             205$               0                           50/0/14
             AD                                    PRE PASS                OUT
20012  pots  up   up             206$               0                           50/0/15
20013  pots  up   up             207$               0                           50/0/16
20014  pots  up   up             208$               0                           50/0/17
20015  pots  up   up             209$               0                           50/0/18
20016  pots  up   up             211$               0                           50/0/19
20017  pots  up   up             212$               0                           50/0/20
20018  pots  up   up             210$               0                           50/0/21
20019  pots  up   up             213$               0                           50/0/22
20020  pots  up   up             666$               0                           50/0/49
20021  pots  up   up             4032818701$       10                           50/0/50
20022  pots  up   up             704$               0                           50/0/51
20023  pots  up   up             703$               0                           50/0/52
20024  pots  up   up             702$               0                           50/0/53
20025  pots  up   up             701$               0                           50/0/54
20026  pots  up   up             A801...            0                           50/0/55
20027  pots  up   up             A800...            0                           50/0/56
64     pots  up   up             8911               2                      up   trunkgroup MAIN_FXO
54     pots  up   up             911                2                      up   trunkgroup MAIN_FXO
55     pots  up   up             8011T              2                      up   trunkgroup MAIN_FXO
56     pots  up   up             8[2-9]11           2                      up   trunkgroup MAIN_FXO
3000   voip  up   up                                0  syst sip-server         
20028  pots  up   up             220$               0                           50/0/23
57     pots  up   up             8[2-9]..[2-9]...-  2                      up   trunkgroup MAIN_FXO
58     pots  up   up             81[2-9]..[2-9]..-  2                      up   trunkgroup MAIN_FXO
60     pots  up   up             81877.......       2                      up   trunkgroup MAIN_FXO
61     pots  up   up             81866.......       2                      up   trunkgroup MAIN_FXO
62     pots  up   up             81800.......       2                      up   trunkgroup MAIN_FXO
3002   voip  up   up                                0  syst sip-server         


Re: Problems with SIP trunk

You can start / stop the SIP listening process as below (though I doubt this helps).

UC520(config)#voice service voip
UC520(conf-serv-sip)#call service stop

and then do a no call service stop to re enable

Can you turn on "deb ccsip all" &repeat the test - this is verbose so make sure its done when traffic is minimal.

For the outbound call failure - SIP Trunk dial peer for 81888 is down

1020   voip  up   down           81888.......       1  syst

because you do not have a session target defined for the sip-server - add that in and now you should get further.

New Member

Re: Problems with SIP trunk

I wondered that, I have tried to use the gui as much as possible (to simulate client changes), so if it does not default to the sip-ua when "sip-server" is chosen in the dial pattern, then this is not being set by CCA2.0

Stated differently if I change my dial patterm from PSTN and add SIP, should CCA also not add the "session target ipv4:x.x.x.x" to the dial-plan? If the answer is yes, then it's not doing it for me.

No my one dial-plan is "up" and I am testing the SIP communications. I will let you know if I figure it out.


Re: Problems with SIP trunk

To answer your questions - yes CCA should add the sip-server CLI in there. If it did not, per the other discussion - lets get the logs to see what the issue is. I tried a quick test here in my lab and it did push the right CLI down.

SO I assume after the change, outbound calls work but registration is still an issue (as also inbound calls)?

New Member

Re: Problems with SIP trunk

OK I got it working. There was two problems;

First in the :

voice service voip

section it had:

outbound-proxy dns: (This was configured by CCA2.0)

I changed it to:

outbound-proxy IPV4:


The dial-peers for the SIP group did not have the:

session target ipv4: ( This was not added by CCA2.0)

Once I added these via CLI, everything worked. You say CCA should have have put it in, but it did not for me. I will try to find the log files and/or make a change and see if it gets pushed to the UC520.


Re: Problems with SIP trunk

Glad you got this to work. This may have to do with what you mentioned on the other thread where your config changes did not take effect. I tried this multiple times in my setup - if I enter an IP address for outbound proxy, it does get put in as ipv4: instead of dns. Also all the SIP Trunk dial peers have session target sip-server, that was missing I think in your case. The CCA log would tell us for sure why this did not take effect.

On a side note - you can view the CLI (if you care) that CCA pushes down for Voice  - Go to System -> Preferences -> Advanced -> Check Enable CLI postview of IOS voice features.

Also, who is the SP you are testing with - if this all worked out would be great to put a quick tip on the SIP Trunk page on this site on what your issues were and how you were able to get this up and running. I can help with this if you want - send me a private message (PM)

CreatePlease to create content