Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SIP Invalid Host Error

Dear All,

I am getting a SIP invalid host on sip calls coming in to the UC540

This config normally works however in this instance it is not.It is the IP address from my ADSL router outside intewrface in the invites instead of the internal IP address.

000587: Feb 22 09:14:58.217: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:02393233110@77.44.108.XXX:58275 SIP/2.0 ----> should be 192.168.2.5 (the uc500) instead of outside IP
Via: SIP/2.0/UDP 146.101.248.200:5060;branch=z9hG4bK61a70ed6;rport
From: "08454130833" <sip:08454130833@146.101.248.200>;tag=as7bc34c9b
To: <sip:02393233110@77.44.108.XXX:58275>;tag=2488024-130D  ---> This should be 192.168.2.5 (the UC500) instead of outside IP
Contact: <sip:08454130833@146.101.248.200>
Call-ID: 6423b711756dc8375765d9dc415a27ae@146.101.248.200
CSeq: 102 ACK
User-Agent: VoiceFlex
Max-Forwards: 70
Content-Length: 0

Can anyone shed some light?

Cheers

Rob

4 REPLIES
New Member

Re: SIP Invalid Host Error

Hello Robert,

I had a similar case the other day and the solution was to bridge the ADSL Modem and let the UC500 get the Public IP via PPPoE, since the Modem that we where working on, did not support SIP-ALG.

Please find a link where a Cisco SR500 provided asymmetric digital subscriber line (ADSL) or FastEthernet WAN termination and advanced security features for a Cisco Smart Business Communications System (SBCS) network,  as an example on how to configure this via CCA.

Hope this help as a reference point

Thanks,
Victor.-

Bronze

Re: SIP Invalid Host Error

The UC500 by default will only accept SIP responses that are addressed to its own IP address (any of the interfaces) - not any other IP address. Hence you see the error message. Victor is correct - this is an issue with the NAT ALG on your ADSL modem that does not correctly replace the IP addresses in the SIP message. You are better off putting the modem in bridge mode and letting the UC500 get a public IP (make sure you do not disable the firewall on the UC500).

One potential option to try via CLI (this may not work) is to add the below CLI:

UC520#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
UC520(config)#sip-ua
UC520(config-sip-ua)#permit hostname

This may or may not work as the CLI is usually for a domain name not an IP address but give it a shot.

New Member

Re: SIP Invalid Host Error

Hi,

I replaced the Cisco 857 with a Cisco SR520-ADSL-K9 and it worked

Thanks for the help

Kind regards

Rob

New Member

Re: SIP Invalid Host Error

I'm having the same issue with a ASA in front of the UC5x0, there are known SIP issues that were suppose to be fixed in the version we have but I assume they are not. The issue is the ASA SIP proxy is not translating the address inbound.

I tried the permit host dns:public NAT's IP but no luck.

I have a case open with TAC, but that's not working too well.

Bob

1407
Views
0
Helpful
4
Replies
CreatePlease to create content